Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025919
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2014-03-06 10:002014-03-17 12:48
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q2
StatusclosedFix in branchFixed in SCM revision31ec6d0191e3
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2014-02-26
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/20eb3426d990 [^]
Triggers an Emergency PackNo
Summary

0025919: direct navigation to window with default saved view not working

DescriptionBP window is not rendered when trying to navigate from Sales Order window.

This happens only when BP window has a default saved view (see 0025972)

Steps To Reproduce-Open any existent Sales Order
-Navigate to its BP: BP window is opened but no fields are displayed, in main tab though subtab are properly rendered

Navigation is not working from form nor from grid

The same is reproducible when navigating using a link to a concrete record:
-Save a default view with filter in Sales Order
-Open any record and get the link from the toolbar
-Use that link to navigate to the record -> The page is displayed in blank
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0025574 closeddbaz Upgrade SmartClient 10.0d 
blocks defect 0025972 closedalostale incorrect navigation to windows with default saved view 

-  Notes
(0065165)
hgbot (developer)
2014-03-14 15:53

Repository: erp/devel/pi
Changeset: 31ec6d0191e3b96e1d2223d2fda459cd49a1233f
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Mar 14 15:53:10 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/31ec6d0191e3b96e1d2223d2fda459cd49a1233f [^]

fixed bug 25919, fixed bug 25972

  Preventing double request when in direct navigation to a window with a
  default saved view.

  This case cause after SC upgrade not to navigate to form view (nor to
  show grid) because datasource was in an incorrecte status.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-window.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/personalization/ob-manage-views.js
---
(0065186)
hudsonbot (developer)
2014-03-15 03:04

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8396ec753aec [^]
Maturity status: Test
(0065211)
AugustoMauch (developer)
2014-03-17 12:37

Repository: erp/devel/pi
Changeset: f98bc5e90f33a2761dc8bcf708b3d7729a343c4f
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Mar 17 11:08:09 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/f98bc5e90f33a2761dc8bcf708b3d7729a343c4f [^] [^]

related to bug 25972: fixed incorrect reference

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-window.js
(0065213)
AugustoMauch (developer)
2014-03-17 12:48

Code reviewed and verified in pi@f98bc5e90f33

It has been tested both in header tabs and in subtabs.

- Issue History
Date Modified Username Field Change
2014-03-06 10:00 alostale New Issue
2014-03-06 10:00 alostale Assigned To => AugustoMauch
2014-03-06 10:00 alostale Modules => Core
2014-03-06 10:00 alostale Triggers an Emergency Pack => No
2014-03-06 10:01 alostale Regression level => Pre packaging ( pi )
2014-03-06 10:01 alostale Regression date => 2014-02-26
2014-03-06 10:01 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/20eb3426d990 [^]
2014-03-06 10:01 alostale Relationship added related to 0025574
2014-03-12 15:31 alostale Relationship added blocks 0025972
2014-03-13 07:36 alostale Description Updated View Revisions
2014-03-13 14:14 alostale Description Updated View Revisions
2014-03-13 14:14 alostale Steps to Reproduce Updated View Revisions
2014-03-14 12:21 alostale Summary navigation to BP not working => direct navigation to window with default saved view not working
2014-03-14 15:45 alostale Assigned To AugustoMauch => alostale
2014-03-14 15:53 hgbot Checkin
2014-03-14 15:53 hgbot Note Added: 0065165
2014-03-14 15:53 hgbot Status new => resolved
2014-03-14 15:53 hgbot Resolution open => fixed
2014-03-14 15:53 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/31ec6d0191e3b96e1d2223d2fda459cd49a1233f [^]
2014-03-15 03:04 hudsonbot Checkin
2014-03-15 03:04 hudsonbot Note Added: 0065186
2014-03-17 09:26 alostale Review Assigned To => AugustoMauch
2014-03-17 12:37 AugustoMauch Note Added: 0065211
2014-03-17 12:48 AugustoMauch Note Added: 0065213
2014-03-17 12:48 AugustoMauch Status resolved => closed
2014-03-17 12:48 AugustoMauch Fixed in Version => PR14Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker