Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025910
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2014-03-05 15:472014-03-26 08:12
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q2
StatusclosedFix in branchFixed in SCM revision69c758824b3e
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todbaz
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2014-02-26
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/20eb3426d990 [^]
Triggers an Emergency PackNo
Summary

0025910: quick launch popup is not closed when item is selected

DescriptionQuick launch popup is not closed when item is selected till the window is opened. In case of manual windows is never closed.
Steps To Reproduce-Open quick launch
-Type Sales Order and select it
-Popup is not closed till the window is open

-As sys admin
-Open quick launch
-Open Module Management
-It's never closed automatically
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
duplicate of defect 00260783.0PR14Q2 closedalostale random CI int-gui failure 
related to feature request 0025574 closeddbaz Upgrade SmartClient 10.0d 

-  Notes
(0064887)
alostale (developer)
2014-03-06 08:45
edited on: 2014-03-06 08:47

Problem:

When quick launch popup is being closed focus is set in the quick launch widget (why?). After SC upgrade, pressing enter to select the item in the drop down causes it to be detected as click event in the widget, opening it again just after closing.

Solution:

Don't set focus in the widget.

Test Plan:
-Both for Quick Launch and Create New launchers:
 * Select item by typing and pressing enter
 * Select item with mouse
In all the cases popup should be closed after item is selected.

(0064888)
hgbot (developer)
2014-03-06 08:50

Repository: erp/devel/pi
Changeset: 823fbf69dcf74ba770f0e5900f442bac284542b8
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Mar 06 08:50:29 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/823fbf69dcf74ba770f0e5900f442bac284542b8 [^]

fixed bug 25910: quick launch popup is not closed when item is selected

  Do not set focus on QuickRun when closing, as in some cases enter click to
  select an item in the drop down is captured after the focus set causing the
  launcher to be reopened.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-quickrun-widget.js
---
(0064934)
hudsonbot (developer)
2014-03-06 17:20

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9f242c9968f6 [^]
Maturity status: Test
(0065244)
dbaz (developer)
2014-03-18 01:14

The fix brokes another thing (at least in Chrome):

With the focus in the "Workspace" tab, if you press CTRL + O, the "Quick Launch" is opened. If you press CTRL + O again, the "Quick Launch" is closed.

Now it comes the problem: if you press CTRL + O again the native browser "Open" view is opened. It didn't happen before the fix.

The problem is that once the quick launch is closed the first time, the focus is lost (no element in the page has the focus), so the focus is in the browser itself and keyboard shortcuts are not captured.
(0065253)
hgbot (developer)
2014-03-18 11:11

Repository: erp/devel/pi
Changeset: 56436da527ee599c3d5e74394c25bbb2713aa2db
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Mar 18 11:11:05 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/56436da527ee599c3d5e74394c25bbb2713aa2db [^]

fixed bug 25910: quick launch popup is not closed when item is selected

  Focus needs to be reset in order to make keyboard shortcuts work

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-quickrun-widget.js
---
(0065254)
alostale (developer)
2014-03-18 11:12

New fix resets focus with some delay, this makes shortcuts work.

Tested explained test plan before and shortcuts opening the launcher manually and through shortcut.
(0065286)
hudsonbot (developer)
2014-03-19 02:42

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9b8682dba110 [^]
Maturity status: Test
(0065361)
dbaz (developer)
2014-03-21 15:26

With the focus in the "Workspace" tab, if you do a "long" CTRL+O press (or leave the CTRL+O pressed indefinitely), the native browser "Open" view is opened. It didn't happen in MP31.

Theoretically something that could fix the issue is before the 'setTimeout', set the focus in some place that is for sure that will exist and is able to accept the focus. Then the timeout will change it to the previous focused element. The most important thing is to ensure that at any single moment the focus is inside the application.
(0065385)
hgbot (developer)
2014-03-24 11:56

Repository: erp/devel/pi
Changeset: 69c758824b3e22ac0ac0adf3751ebb5e0f4d95c3
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Mar 24 11:56:34 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/69c758824b3e22ac0ac0adf3751ebb5e0f4d95c3 [^]

fixed bug 25910: prevent continous CRTL-O to open browser's open dialog

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-quickrun-widget.js
---
(0065415)
hgbot (developer)
2014-03-25 10:25

Repository: erp/devel/pi
Changeset: a07f840d54afaa17822f6e4be4a18b996409b2fc
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Mar 25 10:24:01 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/a07f840d54afaa17822f6e4be4a18b996409b2fc [^]

fixed bug 26078, related to bug 25910: fixed CI

  CI was failing due to the timeout introduced in quick run widget in order to
  prevent quick launch to be kept open just after selecting an item.

  This caused sync test to fail as it was closing and opening profile widget without
  waiting the 50ms defined in the timeout.

  Current patch adds this timeout just to quick launch and not to all quick run widgets

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-quick-launch.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-quickrun-widget.js
---
(0065430)
dbaz (developer)
2014-03-25 16:20

Reviewed @ changeset: 22767 - 1dcbf92e17e9

A changeset due to code-review is still pending.
(0065438)
hgbot (developer)
2014-03-25 18:09

Repository: erp/devel/pi
Changeset: 82c2bef68eed5d5fc2bfd518ff69a29f6fa3abb4
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Mar 25 18:09:00 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/82c2bef68eed5d5fc2bfd518ff69a29f6fa3abb4 [^]

related to bug 25910: return super value

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-quick-launch.js
---
(0065444)
hudsonbot (developer)
2014-03-25 19:47

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/05169b1f5a79 [^]
Maturity status: Test
(0065450)
hudsonbot (developer)
2014-03-25 19:47

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/05169b1f5a79 [^]
Maturity status: Test
(0065455)
hudsonbot (developer)
2014-03-26 08:12

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d422276a3bd9 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-03-05 15:47 alostale New Issue
2014-03-05 15:47 alostale Assigned To => AugustoMauch
2014-03-05 15:47 alostale Modules => Core
2014-03-05 15:47 alostale Triggers an Emergency Pack => No
2014-03-05 15:48 alostale Regression level => Pre packaging ( pi )
2014-03-05 15:48 alostale Regression date => 2014-02-26
2014-03-05 15:48 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/20eb3426d990 [^]
2014-03-05 15:48 alostale Relationship added related to 0025574
2014-03-06 08:35 alostale Assigned To AugustoMauch => alostale
2014-03-06 08:45 alostale Note Added: 0064887
2014-03-06 08:45 alostale Issue Monitored: dbaz
2014-03-06 08:45 alostale Review Assigned To => dbaz
2014-03-06 08:47 alostale Note Edited: 0064887 View Revisions
2014-03-06 08:50 hgbot Checkin
2014-03-06 08:50 hgbot Note Added: 0064888
2014-03-06 08:50 hgbot Status new => resolved
2014-03-06 08:50 hgbot Resolution open => fixed
2014-03-06 08:50 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/823fbf69dcf74ba770f0e5900f442bac284542b8 [^]
2014-03-06 17:20 hudsonbot Checkin
2014-03-06 17:20 hudsonbot Note Added: 0064934
2014-03-18 01:14 dbaz Note Added: 0065244
2014-03-18 01:14 dbaz Status resolved => new
2014-03-18 01:14 dbaz Resolution fixed => open
2014-03-18 11:11 hgbot Checkin
2014-03-18 11:11 hgbot Note Added: 0065253
2014-03-18 11:11 hgbot Status new => resolved
2014-03-18 11:11 hgbot Resolution open => fixed
2014-03-18 11:11 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/823fbf69dcf74ba770f0e5900f442bac284542b8 [^] => http://code.openbravo.com/erp/devel/pi/rev/56436da527ee599c3d5e74394c25bbb2713aa2db [^]
2014-03-18 11:12 alostale Note Added: 0065254
2014-03-19 02:42 hudsonbot Checkin
2014-03-19 02:42 hudsonbot Note Added: 0065286
2014-03-21 15:26 dbaz Note Added: 0065361
2014-03-21 15:26 dbaz Status resolved => new
2014-03-21 15:26 dbaz Resolution fixed => open
2014-03-24 11:56 hgbot Checkin
2014-03-24 11:56 hgbot Note Added: 0065385
2014-03-24 11:56 hgbot Status new => resolved
2014-03-24 11:56 hgbot Resolution open => fixed
2014-03-24 11:56 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/56436da527ee599c3d5e74394c25bbb2713aa2db [^] => http://code.openbravo.com/erp/devel/pi/rev/69c758824b3e22ac0ac0adf3751ebb5e0f4d95c3 [^]
2014-03-25 10:20 alostale Relationship added duplicate of 0026078
2014-03-25 10:25 hgbot Checkin
2014-03-25 10:25 hgbot Note Added: 0065415
2014-03-25 16:20 dbaz Note Added: 0065430
2014-03-25 16:20 dbaz Status resolved => closed
2014-03-25 16:20 dbaz Fixed in Version => PR14Q2
2014-03-25 18:09 hgbot Checkin
2014-03-25 18:09 hgbot Note Added: 0065438
2014-03-25 19:47 hudsonbot Checkin
2014-03-25 19:47 hudsonbot Note Added: 0065444
2014-03-25 19:47 hudsonbot Checkin
2014-03-25 19:47 hudsonbot Note Added: 0065450
2014-03-26 08:12 hudsonbot Checkin
2014-03-26 08:12 hudsonbot Note Added: 0065455


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker