Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025190
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfacemajorhave not tried2013-11-20 17:112014-03-16 06:16
ReporterjonalegriaesarteView Statuspublic 
Assigned ToAugustoMauch 
PrioritynormalResolutionfixedFixed in Version3.0PR14Q2
StatusclosedFix in branchFixed in SCM revisioneb415e9bc94f
ProjectionnoneETAnoneTarget Version3.0PR14Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0025190: Error when searching for characters like ß, in grid view

DescriptionError when searching for characters like ß, in grid view
Steps To Reproduce- Create a new business partner with name testßtest
- Filter in grid view by ß in name. It is working fine
- Create a new sales order with one line. Notice that if the user filters the business partner selector using ß, it is working fine
- In grid view in sales order, use character ß, in business partner filter. It does not work.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00257403.0PR14Q2 closedAugustoMauch Grid filters does not discriminate accents 
related to feature request 0030561 closedAugustoMauch Use UPPER to achieve case insensitive filtering in CustomQuerySelectorDatasource 

-  Notes
(0064798)
alostale (developer)
2014-03-04 15:00

Default filtering behavior is to use iContain, meaning upper and lower characters are considered to be identical (ej. 's'=='S'). This default behavior can be changed through grid configuration: http://wiki.openbravo.com/wiki/User_Interface_Introduction#Grid_Filter_Configuration [^]

The logic behind this is:

String param = param.toUpperCase();
String hql = 'select ... where upper(name) = :param';
qry.setParam(param);

The problem is in Java "ß".toUpperCase() returns "SS" whereas in PG (default Locale) select upper('ß') returns 'ß'.

Note this also affects to direct filtering in Business Partner name if it is done in backend (not using adaptive in client filtering).
(0065145)
hgbot (developer)
2014-03-13 19:05

Repository: erp/devel/pi
Changeset: eb415e9bc94f180f23c14b4f1033a24ab123d0ce
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Mar 13 19:04:19 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/eb415e9bc94f180f23c14b4f1033a24ab123d0ce [^]

Fixes issue 25190: Error when searching for characters like ß, in grid view

This happened because when a text field was filtered ignoring the case, the left part of the expression was uppercased using a database method while the right part was uppercased using the String.toUpperCase() java method.

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/AdvancedQueryBuilder.java
---
(0065146)
AugustoMauch (developer)
2014-03-13 19:07

Performance test plan:
- It has been tested both in Oracle and in Postgres
- The explain plan of the query is the same before and after the change
- The execution time of the query is the same before and after the change

It has been checked that this fix works properly with the Grid Configuration project.
(0065185)
hudsonbot (developer)
2014-03-15 03:04

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8396ec753aec [^]
Maturity status: Test
(0065198)
shankarb (developer)
2014-03-16 06:16

Code reviewed and verified in pi changeset 09baf685138e.

- Issue History
Date Modified Username Field Change
2013-11-20 17:11 jonalegriaesarte New Issue
2013-11-20 17:11 jonalegriaesarte Assigned To => AugustoMauch
2013-11-20 17:11 jonalegriaesarte Modules => Core
2013-11-20 17:11 jonalegriaesarte Triggers an Emergency Pack => No
2013-11-21 11:57 alostale Assigned To AugustoMauch => dbaz
2013-12-24 13:15 shuehner Issue Monitored: shuehner
2014-01-02 12:38 jonalegriaesarte Target Version 3.0MP31 => 3.0MP32
2014-02-18 17:03 alostale Relationship added related to 0025740
2014-03-04 15:00 alostale Note Added: 0064798
2014-03-04 15:00 alostale Assigned To dbaz => alostale
2014-03-10 15:29 AugustoMauch Status new => scheduled
2014-03-10 15:29 AugustoMauch fix_in_branch => pi
2014-03-10 15:29 AugustoMauch Assigned To alostale => AugustoMauch
2014-03-11 12:52 jonalegriaesarte fix_in_branch pi =>
2014-03-13 19:04 AugustoMauch Issue Monitored: shankarb
2014-03-13 19:04 AugustoMauch Review Assigned To => shankarb
2014-03-13 19:05 hgbot Checkin
2014-03-13 19:05 hgbot Note Added: 0065145
2014-03-13 19:05 hgbot Status scheduled => resolved
2014-03-13 19:05 hgbot Resolution open => fixed
2014-03-13 19:05 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/eb415e9bc94f180f23c14b4f1033a24ab123d0ce [^]
2014-03-13 19:07 AugustoMauch Note Added: 0065146
2014-03-15 03:04 hudsonbot Checkin
2014-03-15 03:04 hudsonbot Note Added: 0065185
2014-03-16 06:16 shankarb Note Added: 0065198
2014-03-16 06:16 shankarb Status resolved => closed
2014-03-16 06:16 shankarb Fixed in Version => PR14Q2
2015-08-13 09:51 alostale Relationship added related to 0030561


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker