Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025078
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2013-11-05 05:072014-02-12 18:29
ReporterrjapoovaView Statuspublic 
Assigned ToAugustoMauch 
PrioritynormalResolutionfixedFixed in Version3.0PR14Q2
StatusclosedFix in branchFixed in SCM revisioncf95ca28bb9b
ProjectionnoneETAnoneTarget Version3.0PR14Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP27.1SCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0025078: Unchecking Customization Allowed removes system customization template

DescriptionIn the System Info window, the Customization Allowed box controls whether changes can be made to modules not in development. It is used to enable system level configurations.

When this box is checked for the first time, it creates the System Customization template module, in status in development
Subsequent checking / and unchecking are supposed to toggle the development status of that template module.

However, currently, when you uncheck Customization Allowed, the System Customization template is simply deleted.

This makes "upgrade safe" configuration into unsafe customizations that will be lost with an upgrade.
Steps To Reproduce1) Login as system administrator
2) Navigate to System Info
3) Check Customization Allowed. Validate that the System Customization template has been created
4) Modify an element of core. For example, modify the definition of the Value column of C_BPartner as per http://wiki.openbravo.com/wiki/How_to_automatically_populate_search_keys [^]
5) Save.
6) Navigate back to System Info
7) Uncheck Customization Allowed.
8) Verify that the System Customization template has been deleted
9) Navigate to the Value column of C_BPartner. You modification is still there.

This means that you have customized core and your modification will be lost.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0062022)
rjapoova (reporter)
2013-11-05 05:07

I am pretty sure this is a regression. Earlier versions of Openbravo did not behave this way.
(0062025)
AugustoMauch (developer)
2013-11-05 11:44

This is the code [1] that deletes the module from AD_MODULE when changing Customization Allowed from 'Y' to 'N'. It has been like this since the trigger was created in 2008 [2], so probably it is not a regression.

[1] https://code.openbravo.com/erp/devel/pi/file/cbfed8a6d9a0/src-db/database/model/triggers/AD_SYSTEM_INFO_TRG2.xml#l82 [^]
[2] https://code.openbravo.com/erp/devel/pi/diff/6072e1cf1838/src-db/database/model/triggers/AD_SYSTEM_INFO_TRG2.xml [^]
(0063658)
hgbot (developer)
2014-01-23 14:11

Repository: erp/devel/pi
Changeset: cf95ca28bb9b5bf2eb361c37c729a836b52657ec
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Jan 23 14:10:06 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/cf95ca28bb9b5bf2eb361c37c729a836b52657ec [^]

Fixes issue 25078: Unchecking Customization Allowed removes template

When the Customization Allowed flag is unchecked, instead of removing the System Customization template its In Development flag is set to false.

---
M src-db/database/model/triggers/AD_SYSTEM_INFO_TRG2.xml
---
(0063735)
alostale (developer)
2014-01-28 08:42

Code reviewed + verified
(0064108)
hudsonbot (developer)
2014-02-12 18:29

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d1a5bb862230 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-11-05 05:07 rjapoova New Issue
2013-11-05 05:07 rjapoova Assigned To => AugustoMauch
2013-11-05 05:07 rjapoova Modules => Core
2013-11-05 05:07 rjapoova Triggers an Emergency Pack => No
2013-11-05 05:07 rjapoova Note Added: 0062022
2013-11-05 11:44 AugustoMauch Note Added: 0062025
2013-11-25 08:47 alostale Status new => scheduled
2013-11-25 08:47 alostale Target Version => 3.0MP31
2014-01-02 12:38 jonalegriaesarte Target Version 3.0MP31 => 3.0MP32
2014-01-23 14:10 AugustoMauch Issue Monitored: alostale
2014-01-23 14:10 AugustoMauch Review Assigned To => alostale
2014-01-23 14:11 hgbot Checkin
2014-01-23 14:11 hgbot Note Added: 0063658
2014-01-23 14:11 hgbot Status scheduled => resolved
2014-01-23 14:11 hgbot Resolution open => fixed
2014-01-23 14:11 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/cf95ca28bb9b5bf2eb361c37c729a836b52657ec [^]
2014-01-28 08:42 alostale Note Added: 0063735
2014-01-28 08:42 alostale Status resolved => closed
2014-01-28 08:43 alostale Fixed in Version => 3.0MP32
2014-02-12 18:29 hudsonbot Checkin
2014-02-12 18:29 hudsonbot Note Added: 0064108


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker