Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024804
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2013-09-20 09:562013-09-27 22:28
ReportercaristuView Statuspublic 
Assigned Toshankarb 
PriorityurgentResolutionfixedFixed in Version3.0MP28
StatusclosedFix in branchFixed in SCM revisionf497481ca351
ProjectionnoneETAnoneTarget Version3.0MP28
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0024804: Filters are not working properly for translated fields

DescriptionFilters are not working properly for the translated values, if the user filters using the translated value zero results are obtained.
Steps To Reproduce1) Log-in with language Spanish (or any translation).
2) Go to the [Sales Order] window
3) Try to filter by document type used any of the translated values in the list. Notice that zero records are obtained
4) Try to filter, writing the document type original value (in English), the filter works fine now
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0023545 closedshankarb Window field filters are not translated in Menu 
related to defect 00247403.0MP28 closedalostale Filters for columns with list reference doesn't work properly on HQL defined selectors 

-  Notes
(0061364)
shankarb (developer)
2013-09-24 09:56
edited on: 2013-09-25 13:00

The problem is that the grid data for document type is not translated. But the filter contains the translated item. So it is not getting filtered properly.

(0061402)
hgbot (developer)
2013-09-26 08:10

Repository: erp/devel/pi
Changeset: c6dbf71135bc6f94218ec0fed6b35beb3051c24d
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Thu Sep 26 09:41:37 2013 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/c6dbf71135bc6f94218ec0fed6b35beb3051c24d [^]

Fixes Issue 0024804: Filters are not working properly for translated fields

When retrieving the display property name, the values are not translated.
Instead when identifier values are retrieved, the values are translated.
Added code to translate the display property and search key.

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/DataToJsonConverter.java
---
(0061411)
shankarb (developer)
2013-09-26 12:34

Fix creates runtime exception, when loading grid with timestamp values. Example, Sales Invoice - Payment Plan - Payment Details
(0061412)
hgbot (developer)
2013-09-26 13:25

Repository: erp/devel/pi
Changeset: f497481ca351627e5336c307429c9b42c2fb924d
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Thu Sep 26 16:39:58 2013 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/f497481ca351627e5336c307429c9b42c2fb924d [^]

Fixes Issue 0024804: Filters are not working properly for translated fields

Retrieved the toString value instead of typecasting to string to avoid cast exception.

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/DataToJsonConverter.java
---
(0061431)
hudsonbot (developer)
2013-09-27 03:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/71a3ba7a4af8 [^]

Maturity status: Test
(0061433)
hudsonbot (developer)
2013-09-27 03:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/71a3ba7a4af8 [^]

Maturity status: Test
(0061440)
alostale (developer)
2013-09-27 11:42

Current fix correctly displays in grid translated value for table reference fields, but it does not execute the correct query in backend. It is comparing translated value field set in filter with base language value field.

Note this apparently works fine in case of filtering on a record set with a size smaller than 100 records, this is due to the fact in this case filtering is computed in client side.
(0061441)
hgbot (developer)
2013-09-27 11:44

Repository: erp/devel/pi
Changeset: ffeabc536d1746b2f253f840255d74f825da3ed8
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Sep 27 11:44:02 2013 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/ffeabc536d1746b2f253f840255d74f825da3ed8 [^]

related to bug 24804: backend filter for translated fields with table reference

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/AdvancedQueryBuilder.java
---
(0061446)
AugustoMauch (developer)
2013-09-27 14:02

Code reviewed and verified in pi@34a6241c3e04
(0061455)
hudsonbot (developer)
2013-09-27 22:28

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d3e738d010f4 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-09-20 09:56 caristu New Issue
2013-09-20 09:56 caristu Assigned To => AugustoMauch
2013-09-20 09:56 caristu Modules => Core
2013-09-20 09:56 caristu Triggers an Emergency Pack => No
2013-09-20 09:56 caristu Relationship added related to 0023545
2013-09-20 10:00 caristu Description Updated View Revisions
2013-09-23 04:14 shankarb Assigned To AugustoMauch => shankarb
2013-09-23 08:33 alostale Relationship added related to 0024740
2013-09-24 09:56 shankarb Note Added: 0061364
2013-09-25 13:00 alostale Note Edited: 0061364 View Revisions
2013-09-26 08:08 shankarb Review Assigned To => alostale
2013-09-26 08:09 shankarb Issue Monitored: alostale
2013-09-26 08:10 hgbot Checkin
2013-09-26 08:10 hgbot Note Added: 0061402
2013-09-26 08:10 hgbot Status new => resolved
2013-09-26 08:10 hgbot Resolution open => fixed
2013-09-26 08:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/c6dbf71135bc6f94218ec0fed6b35beb3051c24d [^]
2013-09-26 12:34 shankarb Note Added: 0061411
2013-09-26 12:34 shankarb Status resolved => new
2013-09-26 12:34 shankarb Resolution fixed => open
2013-09-26 13:25 hgbot Checkin
2013-09-26 13:25 hgbot Note Added: 0061412
2013-09-26 13:27 hgbot Status new => resolved
2013-09-26 13:27 hgbot Resolution open => fixed
2013-09-26 13:27 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/c6dbf71135bc6f94218ec0fed6b35beb3051c24d [^] => http://code.openbravo.com/erp/devel/pi/rev/f497481ca351627e5336c307429c9b42c2fb924d [^]
2013-09-27 03:11 hudsonbot Checkin
2013-09-27 03:11 hudsonbot Note Added: 0061431
2013-09-27 03:11 hudsonbot Checkin
2013-09-27 03:11 hudsonbot Note Added: 0061433
2013-09-27 11:42 alostale Note Added: 0061440
2013-09-27 11:44 hgbot Checkin
2013-09-27 11:44 hgbot Note Added: 0061441
2013-09-27 11:45 alostale Review Assigned To alostale => AugustoMauch
2013-09-27 14:02 AugustoMauch Note Added: 0061446
2013-09-27 14:02 AugustoMauch Status resolved => closed
2013-09-27 14:02 AugustoMauch Fixed in Version => 3.0MP28
2013-09-27 22:28 hudsonbot Checkin
2013-09-27 22:28 hudsonbot Note Added: 0061455


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker