Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024794
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajorhave not tried2013-09-19 13:072013-11-25 11:29
ReporteradrianromeroView Statuspublic 
Assigned Tomigueldejuana 
PriorityurgentResolutionfixedFixed in VersionRMP27
StatusclosedFix in branchFixed in SCM revision88f42d23710b
ProjectionnoneETAnoneTarget VersionRMP27
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0024794: Filters with characteristics in search panel must be reviewed

DescriptionWhen there are products with characteristics in the POS assortment some behaviours in the search panel are strange and must be polished

* "Clear button" appears and disappears with no clear reason, And in any case this button does the same action as the button with the "X" that is on the right of the text field. After some testing, I found that the button only appears when the filter does not return any result, but only in the case that the filter is combined with a filter with the text field. If for example combining only the filters of brand, color, etc, There is no result, then the button does not appear

* If you first apply some filter in characteristics and you combine with a filter in the text field that does not give any result, the buttons that filter characteristics disappear but you can still see a message that the filter is applyed. (An screenshot is attached)

* If you apply a filter using the text field and you resize the browser window, the text in this text field disappears
Steps To ReproduceIn description
TagsNo tags attached.
Attached Filespng file icon Pantallazo-Openbravo POS - Google Chrome.png [^] (210,735 bytes) 2013-09-19 13:07


png file icon Pantallazo-Openbravo POS - Google Chrome-2.png [^] (184,314 bytes) 2013-09-23 16:35

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0061314)
hgbot (developer)
2013-09-20 12:04

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 88f42d23710bb2ca465f1ccbcd75c1ef9e11b29f
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Fri Sep 20 12:04:07 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/88f42d23710bb2ca465f1ccbcd75c1ef9e11b29f [^]

Fixed issue 24794: Do not filter characs. when text filter is used

---
M web/org.openbravo.mobile.core/source/retail/component/ob-retail-searchproductcharacteristic.js
---
(0061355)
adrianromero (manager)
2013-09-23 16:34

Seems to be not properly fixed

* If instead of combining filtering characteristics wit the filter of text it is combined with the "brand" filter. The behaviour continues. Still "Clear button" appears and disappears with no clear reason.

* The same as previous point, if combined the filter with branch filter, the buttons that filter characteristics disappear but you can still see a message that the filter is applied. (New screenshot attached).

* If you apply a filter using the text field and you resize the browser window, the text in this text field disappears. It has not been fixed yet.
(0061547)
hgbot (developer)
2013-10-04 09:34

Repository: erp/pmods/org.openbravo.mobile.core-levelpricing
Changeset: 88f42d23710bb2ca465f1ccbcd75c1ef9e11b29f
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Fri Sep 20 12:04:07 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core-levelpricing/rev/88f42d23710bb2ca465f1ccbcd75c1ef9e11b29f [^]

Fixed issue 24794: Do not filter characs. when text filter is used

---
M web/org.openbravo.mobile.core/source/retail/component/ob-retail-searchproductcharacteristic.js
---
(0061590)
guilleaer (developer)
2013-10-07 16:59

reclosed
(0062341)
hgbot (developer)
2013-11-22 16:07

Repository: erp/pmods/org.openbravo.mobile.core.cirque
Changeset: 88f42d23710bb2ca465f1ccbcd75c1ef9e11b29f
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Fri Sep 20 12:04:07 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core.cirque/rev/88f42d23710bb2ca465f1ccbcd75c1ef9e11b29f [^]

Fixed issue 24794: Do not filter characs. when text filter is used

---
M web/org.openbravo.mobile.core/source/retail/component/ob-retail-searchproductcharacteristic.js
---
(0062362)
guilleaer (developer)
2013-11-25 11:29

reclosed

- Issue History
Date Modified Username Field Change
2013-09-19 13:07 adrianromero New Issue
2013-09-19 13:07 adrianromero Assigned To => migueldejuana
2013-09-19 13:07 adrianromero File Added: Pantallazo-Openbravo POS - Google Chrome.png
2013-09-19 13:07 adrianromero Triggers an Emergency Pack => No
2013-09-20 12:03 migueldejuana Review Assigned To => marvintm
2013-09-20 12:04 hgbot Checkin
2013-09-20 12:04 hgbot Note Added: 0061314
2013-09-20 12:04 hgbot Status new => resolved
2013-09-20 12:04 hgbot Resolution open => fixed
2013-09-20 12:04 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/88f42d23710bb2ca465f1ccbcd75c1ef9e11b29f [^]
2013-09-20 14:30 marvintm Status resolved => closed
2013-09-20 14:30 marvintm Fixed in Version => RMP27
2013-09-23 16:34 adrianromero Note Added: 0061355
2013-09-23 16:34 adrianromero Status closed => new
2013-09-23 16:34 adrianromero Resolution fixed => open
2013-09-23 16:34 adrianromero Fixed in Version RMP27 =>
2013-09-23 16:35 adrianromero File Added: Pantallazo-Openbravo POS - Google Chrome-2.png
2013-10-04 09:34 hgbot Checkin
2013-10-04 09:34 hgbot Note Added: 0061547
2013-10-04 09:34 hgbot Status new => resolved
2013-10-04 09:34 hgbot Resolution open => fixed
2013-10-04 09:34 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/88f42d23710bb2ca465f1ccbcd75c1ef9e11b29f [^] => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core-levelpricing/rev/88f42d23710bb2ca465f1ccbcd75c1ef9e11b29f [^]
2013-10-07 16:59 guilleaer Note Added: 0061590
2013-10-07 16:59 guilleaer Status resolved => closed
2013-10-07 16:59 guilleaer Fixed in Version => RMP27
2013-11-22 16:07 hgbot Checkin
2013-11-22 16:07 hgbot Note Added: 0062341
2013-11-22 16:07 hgbot Status closed => resolved
2013-11-22 16:07 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core-levelpricing/rev/88f42d23710bb2ca465f1ccbcd75c1ef9e11b29f [^] => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core.cirque/rev/88f42d23710bb2ca465f1ccbcd75c1ef9e11b29f [^]
2013-11-25 11:29 guilleaer Note Added: 0062362
2013-11-25 11:29 guilleaer Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker