Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024698
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2013-09-05 13:332013-09-25 10:21
ReporteregoitzView Statuspublic 
Assigned Toshankarb 
PriorityurgentResolutionfixedFixed in Version3.0MP28
StatusclosedFix in branchFixed in SCM revisiond03d06d3cd71
ProjectionnoneETAnoneTarget Version3.0MP28
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0024698: When opening a window two request to save the view on recent view section are send

DescriptionWhen opening a window two request to save the view on recent view section are send
Steps To ReproduceUsing chrome, open the developer tools on network section.
Open the product window.
See on the developert tools that two request has been done to seve the recent view.
The first is faster than the second. This last request takes arround 1 sec.

TagsPerformance
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
has duplicate defect 0024227 closedshuehner When opening a window the request to update the RecentViewList is sent twice 

-  Notes
(0060973)
hgbot (developer)
2013-09-09 13:07

Repository: erp/devel/pi
Changeset: 9f4f2629b7ff602d495f7336a449b9f0a1c65064
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Mon Sep 09 16:35:02 2013 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/9f4f2629b7ff602d495f7336a449b9f0a1c65064 [^]

Fixes Issue 0024698: When opening a window two request to save the view on recent view section are send

When launching a menu through quick launch, two calls to save the Recent view is made.
One is happening in the quick launch and other in the default openView method.
Removed the code to add to recent view in quick launch.
The same code is accessed when creating a new record through create new record so the issue is fixed there too.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/navbar/ob-quick-launch.js
---
(0061130)
AugustoMauch (developer)
2013-09-13 09:39

Reopened because it is still reproducible.

In live builds, the double request to the StorePropertyActionHandler to set the OBUIAPP_RecentViewList is done in the following cases (tested in https://livebuilds.openbravo.com/erp_pi_pgsql [^]):
- When entering 'Currency' in the quick launch and pressing enter
- When clicking on the Currency label in the Recent Views section
- When clicking on the Currency label in the top part of the Quick Launch section
- When clicking on the Currency label in the top part of the Application section.
(0061163)
hgbot (developer)
2013-09-16 05:51

Repository: erp/devel/pi
Changeset: d03d06d3cd71a3cd0e7c9e08c89ef206758c450c
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Mon Sep 16 09:16:09 2013 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/d03d06d3cd71a3cd0e7c9e08c89ef206758c450c [^]

Fixes Issue 0024698: When opening a window two request to save the view on recent view section are send

Modify recent view list only if needed. If the object at index 0 is going to be readded, skip.
This is done to avoid multiple calls to server for setting the Recent View List.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-recent-utilities.js
---
(0061227)
hudsonbot (developer)
2013-09-17 19:02

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1c53d622fc50 [^]

Maturity status: Test
(0061254)
hudsonbot (developer)
2013-09-17 19:03

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1c53d622fc50 [^]

Maturity status: Test
(0061383)
alostale (developer)
2013-09-25 10:21

Code reviewed + tested

- Issue History
Date Modified Username Field Change
2013-09-05 13:33 egoitz New Issue
2013-09-05 13:33 egoitz Assigned To => AugustoMauch
2013-09-05 13:33 egoitz Modules => Core
2013-09-05 13:33 egoitz Triggers an Emergency Pack => No
2013-09-05 13:33 egoitz Tag Attached: Performance
2013-09-05 15:57 jpcalvente Issue Monitored: jpcalvente
2013-09-08 09:37 shankarb Assigned To AugustoMauch => shankarb
2013-09-09 13:06 shankarb Review Assigned To => AugustoMauch
2013-09-09 13:06 shankarb Issue Monitored: AugustoMauch
2013-09-09 13:07 hgbot Checkin
2013-09-09 13:07 hgbot Note Added: 0060973
2013-09-09 13:07 hgbot Status new => resolved
2013-09-09 13:07 hgbot Resolution open => fixed
2013-09-09 13:07 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/9f4f2629b7ff602d495f7336a449b9f0a1c65064 [^]
2013-09-13 09:39 AugustoMauch Note Added: 0061130
2013-09-13 09:39 AugustoMauch Status resolved => new
2013-09-13 09:39 AugustoMauch Resolution fixed => open
2013-09-15 08:01 shankarb Relationship added has duplicate 0024227
2013-09-16 05:51 hgbot Checkin
2013-09-16 05:51 hgbot Note Added: 0061163
2013-09-16 05:51 hgbot Status new => resolved
2013-09-16 05:51 hgbot Resolution open => fixed
2013-09-16 05:51 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/9f4f2629b7ff602d495f7336a449b9f0a1c65064 [^] => http://code.openbravo.com/erp/devel/pi/rev/d03d06d3cd71a3cd0e7c9e08c89ef206758c450c [^]
2013-09-17 19:02 hudsonbot Checkin
2013-09-17 19:02 hudsonbot Note Added: 0061227
2013-09-17 19:03 hudsonbot Checkin
2013-09-17 19:03 hudsonbot Note Added: 0061254
2013-09-25 10:21 alostale Note Added: 0061383
2013-09-25 10:21 alostale Status resolved => closed
2013-09-25 10:21 alostale Fixed in Version => 3.0MP28


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker