Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024692
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2013-09-04 17:102013-10-03 18:19
ReportercaristuView Statuspublic 
Assigned Toshankarb 
PriorityurgentResolutionfixedFixed in Version3.0MP28
StatusclosedFix in branchFixed in SCM revision327a7d8af6ce
ProjectionnoneETAnoneTarget Version3.0MP28
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browserGoogle Chrome
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0024692: Double request to the datasource is done when a numeric field is in the first position of the grid

DescriptionA double request is done to the datasource if we configure a numeric field as the first in the grid. This causes that the target record is not selected when navigating to that window. This sometimes causes that the child tab information doesn't appear.
Steps To Reproduce1) Go to the [Product] window and display the Weight field (the related column uses a numeric reference)
2) Place it in the first position of the grid
3) Go to the [Purchase/Sales Order] window and create a new order with at least one line.
4) Navigate from the [Lines] tab to the [Product] window
TagsPerformance
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0061363)
hgbot (developer)
2013-09-24 09:41

Repository: erp/devel/pi
Changeset: 2bbac483aff8d1414f4017a2c89ae839ad292384
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Tue Sep 24 13:08:10 2013 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/2bbac483aff8d1414f4017a2c89ae839ad292384 [^]

Fixes Issue 0024692: Double request to the datasource is done when a numeric field is in the first position of the grid

In numeric fields, then in the blur event, the filters are applied again if its not applied through performGridAction.
But this was resulting in double datasource calls, if the numeric field is the first field of the grid.
Added validation to performGridAction only if the numeric field is not the first field of the grid.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-number.js
---
(0061377)
hudsonbot (developer)
2013-09-24 20:10

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/af5a5f1a0fe1 [^]

Maturity status: Test
(0061379)
alostale (developer)
2013-09-25 08:57
edited on: 2013-09-25 08:59

Reopening because it causes a regression: blur event in numeric filter fields doesn't apply the filter.

Test cases:
-Following steps to reproduce -> FIXED
-Filtering by numeric field having it in first position in grid pressing enter after setting the number -> WORKS
-Filtering by numeric field having it in other grid position pressing enter after setting the number -> WORKS
-Filter by numeric field in any grid position by entering the number and pressing tab to move to next filter field -> DOES NOT APPLY FILTER: REGRESSION

Note current fix is preventing datasource call in numeric filter fields in ALL cases:

  this.form.getFocusItem() === this

always evaluates true in the blur method

(0061388)
hgbot (developer)
2013-09-25 11:18

Repository: erp/devel/pi
Changeset: 327a7d8af6cee2d1d0abcbf50854380fee17b790
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Wed Sep 25 13:28:36 2013 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/327a7d8af6cee2d1d0abcbf50854380fee17b790 [^]

Fixes Issue 0024692: Double request to the datasource is done when a numeric field is in the first position of the grid

The filter in blur event needs to be applied only if the value is not undefined.
In case there is value in the filter and then the value is cleared,
still the filter will be applied because the value returned will be null and not undefined.
Also the additional datasource call will be avoided as in that case, the value is undefined.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-number.js
---
(0061396)
hudsonbot (developer)
2013-09-25 19:58

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a06bf757c7ec [^]

Maturity status: Test
(0061442)
alostale (developer)
2013-09-27 11:51

Code reviewed and tested according to tests cases explained in note above

- Issue History
Date Modified Username Field Change
2013-09-04 17:10 caristu New Issue
2013-09-04 17:10 caristu Assigned To => AugustoMauch
2013-09-04 17:10 caristu Web browser => Google Chrome
2013-09-04 17:10 caristu Modules => Core
2013-09-04 17:10 caristu Triggers an Emergency Pack => No
2013-09-04 17:10 caristu Issue Monitored: networkb
2013-09-04 17:10 caristu Web browser Google Chrome => Google Chrome
2013-09-04 17:10 caristu Summary Double request to the datasource when a numeric field is the first in the grid => Double request to the datasource is made when a numeric field is the first in the grid
2013-09-04 17:12 caristu Web browser Google Chrome => Google Chrome
2013-09-04 17:12 caristu Summary Double request to the datasource is made when a numeric field is the first in the grid => Double request to the datasource is done when a numeric field is in the first position of the grid
2013-09-10 08:54 shankarb Assigned To AugustoMauch => shankarb
2013-09-16 07:56 shankarb Status new => scheduled
2013-09-16 07:56 shankarb fix_in_branch => pi
2013-09-24 09:40 shankarb Review Assigned To => AugustoMauch
2013-09-24 09:40 shankarb Web browser Google Chrome => Google Chrome
2013-09-24 09:40 shankarb fix_in_branch pi =>
2013-09-24 09:40 shankarb Issue Monitored: AugustoMauch
2013-09-24 09:41 hgbot Checkin
2013-09-24 09:41 hgbot Note Added: 0061363
2013-09-24 09:41 hgbot Status scheduled => resolved
2013-09-24 09:41 hgbot Resolution open => fixed
2013-09-24 09:41 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/2bbac483aff8d1414f4017a2c89ae839ad292384 [^]
2013-09-24 20:10 hudsonbot Checkin
2013-09-24 20:10 hudsonbot Note Added: 0061377
2013-09-25 08:57 alostale Note Added: 0061379
2013-09-25 08:57 alostale Status resolved => new
2013-09-25 08:57 alostale Resolution fixed => open
2013-09-25 08:59 alostale Note Edited: 0061379 View Revisions
2013-09-25 11:18 hgbot Checkin
2013-09-25 11:18 hgbot Note Added: 0061388
2013-09-25 11:18 hgbot Status new => resolved
2013-09-25 11:18 hgbot Resolution open => fixed
2013-09-25 11:18 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/2bbac483aff8d1414f4017a2c89ae839ad292384 [^] => http://code.openbravo.com/erp/devel/pi/rev/327a7d8af6cee2d1d0abcbf50854380fee17b790 [^]
2013-09-25 19:58 hudsonbot Checkin
2013-09-25 19:58 hudsonbot Note Added: 0061396
2013-09-27 10:09 alostale Review Assigned To AugustoMauch => alostale
2013-09-27 11:51 alostale Note Added: 0061442
2013-09-27 11:51 alostale Status resolved => closed
2013-09-27 11:51 alostale Fixed in Version => 3.0MP28
2013-10-03 18:19 alostale Tag Attached: Performance


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker