Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024147
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2013-06-20 13:002013-08-20 12:54
ReporterngarciaView Statuspublic 
Assigned Tomarvintm 
PriorityurgentResolutionfixedFixed in VersionRMP26
StatusclosedFix in branchFixed in SCM revisionb4c8665c2ab1
ProjectionnoneETAnoneTarget VersionRMP25
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0024147: Goods Shipment Line field not filled in Sales Invoice Lines

DescriptionGoods Shipment Line field not filled in Sales Invoice Lines
Steps To ReproduceIn Web POS:
   Create a new receipt
   Select the Invoice this Receipt option
   Paid it
In the backend:
   Navigate to the newly created Sales Invoice
   Check that the Goods Shipment Line field is empty
   If you navigate to the Sales Order Line, you could see that it is linked to a Goods Shipment (Linked Items)
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0024355 closedAtulOpenbravo Openbravo ERP "Good Shipment Line" field information is not filled when creating POS Order with Invoice Terms=Immediate 
related to defect 0032938 closedAtulOpenbravo Openbravo ERP It is necessary a script to add the 1-1 relation between sales invoice line and goods shipment line 

-  Notes
(0059844)
hgbot (developer)
2013-07-03 12:29

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: a2dea72309dc6de286ed062424f90cb53b56d404
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Wed Jul 03 12:29:19 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/a2dea72309dc6de286ed062424f90cb53b56d404 [^]

Fixed issue 24147. Shipment line will be set correctly in the invoice line.

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0059866)
hgbot (developer)
2013-07-04 16:41

Repository: erp/pmods/org.openbravo.retail.posterminal.multiorder
Changeset: a2dea72309dc6de286ed062424f90cb53b56d404
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Wed Jul 03 12:29:19 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/a2dea72309dc6de286ed062424f90cb53b56d404 [^]

Fixed issue 24147. Shipment line will be set correctly in the invoice line.

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0060118)
migueldejuana (developer)
2013-07-19 09:09

Tested and reviewed in 4abc82b73efa
(0060516)
ngarcia (developer)
2013-08-06 19:06

The records created in previous releases should be fixed with a script
(0060603)
hgbot (developer)
2013-08-16 10:00

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: b4c8665c2ab1eff03246c479f50051a4702577b2
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Fri Aug 16 09:58:22 2013 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b4c8665c2ab1eff03246c479f50051a4702577b2 [^]

Fixed issue 24147: Module script has been created to correct errors caused by this issue

---
A build/classes/org/openbravo/retail/posterminal/modulescript/FixDataIssue24147.class
A src-db/database/model/functions/OBPOS_FIXISSUE24147.xml
A src-util/modulescript/src/org/openbravo/retail/posterminal/modulescript/FixDataIssue24147.java
---

- Issue History
Date Modified Username Field Change
2013-06-20 13:00 ngarcia New Issue
2013-06-20 13:00 ngarcia Assigned To => adrianromero
2013-06-20 13:00 ngarcia Issue Monitored: networkb
2013-06-20 13:02 marvintm Assigned To adrianromero => marvintm
2013-06-20 13:02 marvintm Fixed in Version => RMP25
2013-07-03 12:11 marvintm Fixed in Version RMP25 =>
2013-07-03 12:11 marvintm Target Version => RMP25
2013-07-03 12:29 hgbot Checkin
2013-07-03 12:29 hgbot Note Added: 0059844
2013-07-03 12:29 hgbot Status new => resolved
2013-07-03 12:29 hgbot Resolution open => fixed
2013-07-03 12:29 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/a2dea72309dc6de286ed062424f90cb53b56d404 [^]
2013-07-04 16:41 hgbot Checkin
2013-07-04 16:41 hgbot Note Added: 0059866
2013-07-04 16:41 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/a2dea72309dc6de286ed062424f90cb53b56d404 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/a2dea72309dc6de286ed062424f90cb53b56d404 [^]
2013-07-19 09:09 migueldejuana Review Assigned To => migueldejuana
2013-07-19 09:09 migueldejuana Note Added: 0060118
2013-07-19 09:09 migueldejuana Status resolved => closed
2013-07-19 09:09 migueldejuana Fixed in Version => RMP25
2013-08-06 19:06 ngarcia Note Added: 0060516
2013-08-06 19:06 ngarcia Status closed => new
2013-08-06 19:06 ngarcia Resolution fixed => open
2013-08-06 19:06 ngarcia Fixed in Version RMP25 =>
2013-08-16 10:00 hgbot Checkin
2013-08-16 10:00 hgbot Note Added: 0060603
2013-08-16 10:00 hgbot Status new => resolved
2013-08-16 10:00 hgbot Resolution open => fixed
2013-08-16 10:00 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal.multiorder/rev/a2dea72309dc6de286ed062424f90cb53b56d404 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b4c8665c2ab1eff03246c479f50051a4702577b2 [^]
2013-08-20 12:54 marvintm Review Assigned To migueldejuana => marvintm
2013-08-20 12:54 marvintm Status resolved => closed
2013-08-20 12:54 marvintm Fixed in Version => RMP26
2016-01-08 12:41 ngarcia Relationship added related to 0024355
2016-05-12 10:00 ngarcia Relationship added related to 0032938


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker