Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0024355
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2013-07-17 12:382016-03-17 10:55
ReportermaiteView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionb4ee0d43b8e1
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0024355: "Good Shipment Line" field information is not filled when creating POS Order with Invoice Terms=Immediate

Description"Good Shipment Line" field information is not filled when creating POS Order with Invoice Terms=Immediate
Steps To Reproduce1. Create new POS Order for any BP ensuring that Invoice Terms=Immediate
2. Add any line and process. Shipment and Invoice are automatically created
3. From Sales Order Line, navigate to Sales Invoice Line and verify that, in More Information section, "Good Shipment Line" information is not showed.

If you follow same process using Invoice Terms=After delivery, information will be showed.
TagsNo tags attached.
Attached Filespng file icon Issue_24355.png [^] (49,055 bytes) 2016-01-29 14:51

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0028685pi closedreinaldoguerra Openbravo ERP Goods shipment and invoice relationship not created when launching "Create shipments from orders" form. 
related to defect 0024147RMP25 closedmarvintm Retail Modules Goods Shipment Line field not filled in Sales Invoice Lines 
related to design defect 0032061 newTriage Finance Openbravo ERP No "Cost" information shown in Sales Invoice Dimensional Report in case there is no 1 to 1 relation between SO line and GS line 
related to defect 0032670 closedcollazoandy4 Openbravo ERP "Good Shipment Line" field information is not filled in Sales Invoice Line when processing On Credit Order 
related to defect 0032709 closedAtulOpenbravo Openbravo ERP Sales Invoice - Invoice Term=Immediate does not create link to Good Shipment in Sales Invoice 
related to defect 0032938 closedAtulOpenbravo Openbravo ERP It is necessary a script to add the 1-1 relation between sales invoice line and goods shipment line 

-  Notes
(0061506)
jonalegriaesarte (reporter)
2013-10-01 13:48

Target version does not make sense in design defects. Removing it.
(0083647)
AtulOpenbravo (developer)
2016-01-28 05:46

Test Plan
- Create new POS Order for any BP ensuring that Invoice Terms=Immediate
- Add any line and process. Shipment and Invoice are automatically created
- From Sales Order Line, navigate to Sales Invoice Line and verify that, in More Information section, "Good Shipment Line" information is properly shown.
(0083649)
AtulOpenbravo (developer)
2016-01-28 06:23
edited on: 2016-01-28 15:54

Test Plan B
- Create a Product A in F&B España, S.A Org, assign price to it.
- Creare a Product B in F&B España, S.A Org, assign price to it.
- Create Goods Receipt in F&B España, S.A Org. Warehouse Norte.
- Add line with Product A Qty = 5 in RN-0-0-0 Locator.
- Add line with Product B Qty = 5 in RN-0-0-0 Locator.
- Process Goods Receipt

- Create another Goods Receipt in F&B España, Warehouse Sur
- Add line with Product A Qty = 5 in RS-0-0-0 Locator.
- Process Goods Receipt

- Create a POS Sales Order with Immediate Invoice Terms in F&B España, S.A Org.
- Add line with Product A Qty = 10.
- Add line with Product B Qty = 5.
- Process the Order.

- Check that Goods Shipment is created with 3 three lines, 2 for Product A, RN-0-0-0 and RS-0-0-0 one each and 1 for Product B.
- Check that Sales Invoice is created with 2 lines.
- Check that Sales Invoice Line with Product B has link to Goods Shipment Line.
- Check that Sales Invoice Line with Product A has blank Goods Shipment Lines Reference as there are two Shipment Lines associated.

(0083663)
psanjuan (manager)
2016-01-28 14:41

Issue verified.
(0083685)
psanjuan (manager)
2016-01-28 15:48
edited on: 2016-01-28 15:52

Test Plan C

- Create a Product A in F&B España, S.A Org, assign price to it.
- Creare a Product B in F&B España, S.A Org, assign price to it.
- Create a Goods Receipt in F&B España, S.A Org. Warehouse Norte.
- Add line with Product A Qty = 5 in RN-0-0-0 Locator.
- Add line with Product B Qty = 5 in RN-0-0-0 Locator.
- Add line with Product A Qty = 5 in RN-1-0-0 Locator.
- Process Goods Receipt

- Create another Goods Receipt in F&B España, Warehouse Sur.
- Add line with Product B Qty = 5 in RS-0-0-0 Locator.
- Process Goods Receipt.

- Create a POS Sales Order with Immediate Invoice Terms in F&B España, S.A Org.
- Add line with Product A Qty = 10.
- Add line with Product B Qty = 10
- Process the Order.

- Check that Goods Shipment is created with 4 three lines, 2 for Product A, RN-0-0-0 and RN-1-0-0 one each and 2 for Product B, RN-0-0-0 and RS-0-0-0
- Check that Sales Invoice is created with 2 lines.
- Check that Sales Invoice Line with Product A has blank Goods Shipment Lines Reference as there are two Shipment Lines associated.
- Check that Sales Invoice Line with Product B has blank Goods Shipment Lines Reference as there are two Shipment Lines associated.

(0083686)
psanjuan (manager)
2016-01-28 16:00
edited on: 2016-01-29 14:48

All test plan above verified.

Starting from here it is research whether "Cost" info is shown in the Sales Dimensional Report or not. This was really the reason for reporting this bug.

(0083723)
psanjuan (manager)
2016-01-29 12:40
edited on: 2016-01-29 14:52

Test Plan D - Sales Invoice Dimensional Report check (1 to 1 relationship)

- Make sure that there is a costing rule assigned to F&B España. WH is not set as a cost dimension.
- Create a product named "A 24355 A", add a Purchase Price list "Bebidas Alegres" = 100.00; add a sales price list "Tarifa de Ventas" = 200.00
- Create a product named "A 24355 B", add a Purchase Price list "Bebidas Alegres" = 150.00; add a sales price list "Tarifa de Ventas" = 200.00

- Create a purchase order for F&B España, today's date. Enter 10 units of Product "A 24355 A", price 100 and 10 units of Product "A 24355 B", price 150. Book the order.

- Create a Goods receipt to receipt full quantity in WH Norte, Product "A 24355 A" located in RN-1-0-0 and Product "A 24355 B" locates in RN-2-0-0. Complete GR.

- Run costing background process therefore vendor receipt above is cost calculated.

- Create a POS Sales Order with Inmmediate Invoice Terms for F&B España:
- Add line with product "A 24355 A" Qty = 5 units, sales price 200
- Add line with product "A 24355 B" Qty = 5 units, sales price 200
- Complete POS Sales Order.

- Run costing background process therefore customer shipment created as explained below is cost calculated.

- Check that a Goods Shipment is created with 2 lines one for each product located in each storage bin.
- From Sales order lines, navigate to Sales Invoice lines and check that Goods Shipment Line info in shown in there for each line.

- Run Sales Invoice Dimensional Report for today's date an check that cost information is shown:
- Product "A 24355 A" shows an Amount = 1000.00 (5 units * 200.00); and a Cost = 500 (5 units * 100.00), therefor profit = 500.00
- Product "A 24355 B" shows an Amount = 1000.00 (5 units * 200.00); and a Cost = 750 (5 units * 150.00), therefore profit = 250

(0083730)
psanjuan (manager)
2016-01-29 14:06
edited on: 2016-01-29 14:52

Test Plan E - Sales Invoice Dimensional Report check (not 1 to 1 relationship).

- Create a new costing rule by making warehouse a costing dimension.

- Create a product named "A 24355 C", add a Purchase Price list "Bebidas Alegres" = 100.00; add a sales price list "Tarifa de Ventas" = 200.00

- Create a purchase order for F&B España, today's date. Enter 10 units of Product "A 24355 C", price 100 and 10 units. Book the order.

- Create another purchase order for F&B España, today's date. Enter 10 units of Product "A 24355 C", price 150 and 10 units. Book the order.

- Create a Goods receipt to receipt 10 units in WH Norte (RN-1-0-0) at a price / cost of 100.00 and create another Goods receipt to receipt 10 units in WH Sur (RS-1-0-0) at a price/cost of 150.00. Complete Goods Shipments.

- Run costing background process therefore vendor receipts above are cost calculated. Check that the cost in WH Norte is 100.00 (10 units) and the cost in WH Sur is 150.00 (10 units).

- Create a POS Sales Order with "Inmmediate" Invoice Terms for F&B España:
- Add line with product "A 24355 C" Qty = 15 units, sales price 200
- Complete POS Sales Order.

- Run costing background process therefore customer shipment created as explained below is cost calculated.

- Check that a Goods Shipment is created with 2 lines one line for 10 units from RN-1-0-0 and the other line for 5 units from RS-1-0-0.

- Check that a Sales Invoice for just one line (15 units at a price of 200.00) has been created.

- From Sales order lines, navigate to Sales Invoice lines and check that Goods Shipment Line info in not shown in there as sales invoice line can not be related to two goods shipment lines.

- Run Sales Invoice Dimensional Report for today's date an check that "NO cost info is shown in there for the product". See image attached.


Therefore, this bug is fixed in case there is a 1 to 1 relationship between a POS Sales Order Line and a Sales Invoice Line.

A new issue is created as design defect to research on the solution to provide in case 1 to 1 relationship is not met. See issue:

Existing workaround that is to set POS Sales Order Invoice Terms as "After Delivery".

(0083743)
psanjuan (manager)
2016-01-29 15:06

Issue can be code reviewed and closed.
(0083756)
hgbot (developer)
2016-01-31 10:17

Repository: erp/devel/pi
Changeset: b4ee0d43b8e15518ac12e31f734e40a509adf510
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Thu Jan 28 01:01:58 2016 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/b4ee0d43b8e15518ac12e31f734e40a509adf510 [^]

Fixes Issue 24355:In case of processing POS Order with Immediate Invoice
Terms, Invoice Line is not set with Goods Shipment Line information.

In case of POS Order get M_InOutLine_ID for OrderLine, making sure exactly
one record is retreived using Max, Qty compared to get full shipped line
reference only as there could a case where Order Line is split into two or
more based on available stock in different storage bins in that case no
reference would be set in Invoice Line.

---
M src-db/database/model/functions/C_INVOICE_CREATE.xml
---
(0083757)
vmromanos (developer)
2016-01-31 10:17

Code review + testing OK
(0085096)
hudsonbot (developer)
2016-03-17 10:55

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-07-17 12:38 maite New Issue
2013-07-17 12:38 maite Assigned To => dmiguelez
2013-07-17 12:38 maite Modules => Core
2013-07-17 12:38 maite Triggers an Emergency Pack => No
2013-07-17 12:38 maite Target Version => 3.0MP27
2013-07-17 14:30 pramakrishnan Assigned To dmiguelez => pramakrishnan
2013-07-17 14:30 pramakrishnan Status new => scheduled
2013-07-17 14:30 pramakrishnan fix_in_branch => pi
2013-09-02 10:12 jonalegriaesarte Target Version 3.0MP27 => 3.0MP28
2013-09-02 10:12 jonalegriaesarte fix_in_branch pi =>
2013-09-26 12:14 pramakrishnan Type defect => design defect
2013-10-01 13:48 jonalegriaesarte Note Added: 0061506
2013-10-01 13:48 jonalegriaesarte Target Version 3.0MP28 =>
2015-12-18 13:04 ngarcia Issue Monitored: ngarcia
2016-01-08 12:29 ngarcia Relationship added related to 0028685
2016-01-08 12:41 ngarcia Relationship added related to 0024147
2016-01-08 13:02 ngarcia Resolution time => 1455663600
2016-01-08 13:02 ngarcia Type design defect => defect
2016-01-08 13:02 ngarcia Assigned To pramakrishnan => Triage Finance
2016-01-08 13:02 ngarcia Severity minor => major
2016-01-08 13:03 ngarcia Priority high => urgent
2016-01-08 15:05 aferraz Status scheduled => acknowledged
2016-01-08 15:06 aferraz Status acknowledged => scheduled
2016-01-08 15:06 aferraz Status scheduled => feedback
2016-01-08 15:06 aferraz Status feedback => new
2016-01-28 05:45 AtulOpenbravo Assigned To Triage Finance => AtulOpenbravo
2016-01-28 05:46 AtulOpenbravo Status new => scheduled
2016-01-28 05:46 AtulOpenbravo Note Added: 0083647
2016-01-28 06:23 AtulOpenbravo Note Added: 0083648
2016-01-28 06:23 AtulOpenbravo Note Added: 0083649
2016-01-28 06:24 AtulOpenbravo Note Deleted: 0083648
2016-01-28 14:41 psanjuan Note Added: 0083663
2016-01-28 15:48 psanjuan Note Added: 0083685
2016-01-28 15:49 psanjuan Note Edited: 0083649 View Revisions
2016-01-28 15:52 psanjuan Note Edited: 0083685 View Revisions
2016-01-28 15:54 psanjuan Note Edited: 0083649 View Revisions
2016-01-28 16:00 psanjuan Note Added: 0083686
2016-01-28 16:03 psanjuan Note Edited: 0083686 View Revisions
2016-01-29 12:40 psanjuan Note Added: 0083723
2016-01-29 12:41 psanjuan Note Edited: 0083723 View Revisions
2016-01-29 13:22 psanjuan Note Edited: 0083723 View Revisions
2016-01-29 14:06 psanjuan Note Added: 0083730
2016-01-29 14:07 psanjuan Note Edited: 0083723 View Revisions
2016-01-29 14:10 psanjuan Note Edited: 0083730 View Revisions
2016-01-29 14:13 psanjuan Note Edited: 0083730 View Revisions
2016-01-29 14:46 psanjuan Note Edited: 0083730 View Revisions
2016-01-29 14:48 psanjuan Note Edited: 0083686 View Revisions
2016-01-29 14:49 psanjuan Note Edited: 0083723 View Revisions
2016-01-29 14:49 psanjuan Note Edited: 0083730 View Revisions
2016-01-29 14:50 psanjuan Note Edited: 0083730 View Revisions
2016-01-29 14:51 psanjuan Note Edited: 0083730 View Revisions
2016-01-29 14:51 psanjuan File Added: Issue_24355.png
2016-01-29 14:52 psanjuan Note Edited: 0083723 View Revisions
2016-01-29 14:52 psanjuan Note Edited: 0083730 View Revisions
2016-01-29 15:06 psanjuan Note Added: 0083743
2016-01-29 15:11 psanjuan Relationship added related to 0032061
2016-01-31 10:17 hgbot Checkin
2016-01-31 10:17 hgbot Note Added: 0083756
2016-01-31 10:17 hgbot Status scheduled => resolved
2016-01-31 10:17 hgbot Resolution open => fixed
2016-01-31 10:17 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b4ee0d43b8e15518ac12e31f734e40a509adf510 [^]
2016-01-31 10:17 vmromanos Review Assigned To => vmromanos
2016-01-31 10:17 vmromanos Note Added: 0083757
2016-01-31 10:17 vmromanos Status resolved => closed
2016-03-17 10:55 hudsonbot Checkin
2016-03-17 10:55 hudsonbot Note Added: 0085096
2016-04-14 17:44 ngarcia Relationship added related to 0032670
2016-05-11 13:16 aferraz Relationship added related to 0032709
2016-05-12 10:00 ngarcia Relationship added related to 0032938


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker