Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0020311
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 03. Procurement managementmajoralways2012-04-19 11:322012-04-26 12:23
ReporterVictorVillarView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0MP11
StatusclosedFix in branchFixed in SCM revision4cda1ec9b931
ProjectionnoneETAnoneTarget Version3.0MP11
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP10.1SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0020311: Null pointer exception error when the user tries to send an email of one voided invoice

DescriptionWhen the users tries to send an email of one voided invoice (sales or purchase), they received an error.
Steps To ReproduceAs group admin role,
Go to Client window
 Go to Email configuration tab:
    Configure it
Go to Sales invoice or Purchase Invoice window
Send an email of one completed invoice, correct
Void one invoice, try to send it by email. An error appear (see screenshot)

If you check the log (attached) it is a null pointer exception error.
TagsNo tags attached.
Attached Filespng file icon erroremail.png [^] (199,079 bytes) 2012-04-19 11:32


txt file icon emailerrorlog.txt [^] (3,819 bytes) 2012-04-19 11:33 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0047769)
alostale (developer)
2012-04-20 09:05

This issue is not a regression (verified in 3.0MP7.3).

The actual problem is can happen in these two situations:
1. When trying to print at the same time more than one record having them different document types. In this situation in consistently raises NPE.
2. Printing a document and later printing another document with a different document type. This occurs randomly because different selected document types variable is not properly initialized/reused (see issue 0020319). This case is a variant of 1st one and it is the described case. Note this is the described situation, perceived as regression because of its random nature.

Steps to reproduce/test plan:
* Go go Sales Invoice window. In grid mode show Transaction Document column.
* To reproduce case 1:
  -Select 2 completed records with different Transaction Document.
  -Click on email button -> NPE
* To reproduce case 2 (and reported issue):
  -Create a new Sales Invoice with AR Invoice document type.
  -Add lines and complete
  -Email it. OK
  -Void this document. Note there is a new record with Reversed Sales Invoice document type
  -Print this new record -> Randomly NPE can happen

The provided fix is not risky. It doesn't solve thread safety (to be solved by 0020319) but multi document type email.
(0047770)
hgbot (developer)
2012-04-20 09:11

Repository: erp/devel/pi
Changeset: 4cda1ec9b931cd2d443266973afde1c824401037
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Apr 20 09:11:01 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/4cda1ec9b931cd2d443266973afde1c824401037 [^]

fixed bug 20311: NPE when printing multiple documents

  Hidden tags in this case was inccorectly set.

---
M src/org/openbravo/erpCommon/utility/reporting/printing/PrintController.java
---
(0047850)
hudsonbot (developer)
2012-04-21 14:24

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/2eb57286c1fc [^]

Maturity status: Test
(0048009)
AugustoMauch (developer)
2012-04-26 12:23

Code reviewed and verified in pi@52d3acc5d1d4

- Issue History
Date Modified Username Field Change
2012-04-19 11:32 VictorVillar New Issue
2012-04-19 11:32 VictorVillar Assigned To => vmromanos
2012-04-19 11:32 VictorVillar File Added: erroremail.png
2012-04-19 11:32 VictorVillar Modules => Core
2012-04-19 11:33 VictorVillar File Added: emailerrorlog.txt
2012-04-19 11:33 VictorVillar Issue Monitored: networkb
2012-04-19 13:34 jonalegriaesarte Tag Attached: Regression
2012-04-19 13:35 jonalegriaesarte Assigned To vmromanos => alostale
2012-04-19 13:45 jonalegriaesarte Priority urgent => immediate
2012-04-19 15:17 alostale Assigned To alostale => guilleaer
2012-04-19 15:28 shuehner Issue Monitored: shuehner
2012-04-20 08:53 alostale Tag Detached: Regression
2012-04-20 09:05 alostale Note Added: 0047769
2012-04-20 09:10 alostale Assigned To guilleaer => alostale
2012-04-20 09:11 hgbot Checkin
2012-04-20 09:11 hgbot Note Added: 0047770
2012-04-20 09:11 hgbot Status new => resolved
2012-04-20 09:11 hgbot Resolution open => fixed
2012-04-20 09:11 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/4cda1ec9b931cd2d443266973afde1c824401037 [^]
2012-04-21 14:24 hudsonbot Checkin
2012-04-21 14:24 hudsonbot Note Added: 0047850
2012-04-26 12:23 AugustoMauch Note Added: 0048009
2012-04-26 12:23 AugustoMauch Status resolved => closed
2012-04-26 12:23 AugustoMauch Fixed in Version => 3.0MP11


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker