Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0019323
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2011-12-16 17:222011-12-22 03:53
ReporteralostaleView Statuspublic 
Assigned Tomtaal 
PrioritynormalResolutionfixedFixed in Version3.0MP7
StatusclosedFix in branchFixed in SCM revisione643cc426470
ProjectionnoneETAnoneTarget Version3.0MP7
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP6SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0019323: Shown in grid, not displayed fields are not editable

DescriptionWhen a field is marked as not displayed and shown in grid, it is not possible to edit it in grid view even if it should be.
Steps To Reproduce-Create an updatable field in any window
-Set this field as not displayed and shown in grid
-Open that window and edit a record in grid mode -> note this field cannot be edited.
TagsRegression
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 00191223.0MP6 closedmtaal Support calculated fields 
related to defect 00193113.0MP7 closedmtaal Some fields are shown centered while editing in grid 

-  Notes
(0043908)
alostale (developer)
2011-12-16 17:35

It might be introduced in MP6 by 0019122 changeset dfee4d514c2b

In OBStandardView.prepareGridFields

@@ -1954,7 +1960,8 @@
       }
 
       // correct some stuff coming from the form fields
- if (!fld.displayed) {
+ if (fld.displayed === false) {
+ fld.canEdit = false;
         fld.visible = true;
         fld.alwaysTakeSpace = true;
       }

Assigning it to Martin has he did this change.
(0043909)
alostale (developer)
2011-12-16 17:48

Removing the line fld.canEdit = false; seems to solve this problem, but I don't know the purpose of this line.
(0043934)
hgbot (developer)
2011-12-19 10:54

Repository: erp/devel/pi
Changeset: e643cc4264701e62f2e024529878453cd095c7d1
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Mon Dec 19 10:53:17 2011 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e643cc4264701e62f2e024529878453cd095c7d1 [^]

Fixes issue 19323: Shown in grid, not displayed fields are not editable

---
M .hgignore
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0043940)
alostale (developer)
2011-12-19 13:04

Checked on pi@26982b3129be

*Code review:
 -.hgignore shouldn't be changed
*Issue:
 -With this change, the issue is not reproducible anymore
*Regression possibility:
 -The issue reverts part of dfee4d514c2b changeset. Checked calculated fields still work.
 -From a discussion with Martin regarding the purpose of the original change: "It was added as part of the calculated fields development. To me it seems to have been a mistake that I did that change as part of that development..."
(0043989)
hudsonbot (developer)
2011-12-22 03:53

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9ac5e6f282ca [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2011-12-16 17:22 alostale New Issue
2011-12-16 17:22 alostale Assigned To => alostale
2011-12-16 17:22 alostale Modules => Core
2011-12-16 17:22 alostale Tag Attached: Regression
2011-12-16 17:35 alostale Note Added: 0043908
2011-12-16 17:36 alostale Relationship added related to 0019122
2011-12-16 17:36 alostale Assigned To alostale => mtaal
2011-12-16 17:48 alostale Note Added: 0043909
2011-12-19 10:54 hgbot Checkin
2011-12-19 10:54 hgbot Note Added: 0043934
2011-12-19 10:54 hgbot Status new => resolved
2011-12-19 10:54 hgbot Resolution open => fixed
2011-12-19 10:54 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e643cc4264701e62f2e024529878453cd095c7d1 [^]
2011-12-19 10:55 mtaal Relationship added related to 0019311
2011-12-19 13:04 alostale Note Added: 0043940
2011-12-19 13:04 alostale Status resolved => closed
2011-12-19 13:04 alostale Fixed in Version => 3.0MP7
2011-12-22 03:53 hudsonbot Checkin
2011-12-22 03:53 hudsonbot Note Added: 0043989


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker