Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0019086
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2011-11-16 17:302011-11-22 13:15
ReportermiruritaView Statuspublic 
Assigned Tomtaal 
PriorityimmediateResolutionfixedFixed in Version3.0MP5.1
StatusclosedFix in branchpiFixed in SCM revision3fe117772a75
ProjectionnoneETAnoneTarget Version3.0MP5.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP5SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0019086: Selectors in APRM manual windows does not filter when you start typing (they show all records)

DescriptionNew selectors in APRM manual windows does not filter when you start typing.
Does not matter what you type, they show all records.

Filtering when you open selector window is working fine.
Steps To Reproduce1) Go to Financial Account window
2) Select any financial account and click on Add Transaction button
3) Click on Add Payment In/Out button
4) Type 'dummy' and realize that all the business parnters are shown.
TagsRegression
Attached Filespng file icon Selector not filtering.png [^] (46,871 bytes) 2011-11-16 17:30


? file icon 19086.export [^] (1,391 bytes) 2011-11-17 17:06

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00189013.0MP5 closedmtaal Improve default view loading 

-  Notes
(0042904)
alostale (developer)
2011-11-17 08:27

Working fine in current pi@a1a097a6f0d2
(0042905)
mirurita (developer)
2011-11-17 09:34

The problem is in 3.0MP5
(0042921)
mirurita (developer)
2011-11-17 11:30

The problem is in modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/js/ob-smartclient.js

if you do a reversal diff and apply in a MP5 it works
hg diff -r 3.0MP5:3.0MP4 modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/js/ob-smartclient.js

here the revisions
https://code.openbravo.com/erp/devel/pi/log/1f040a883f1c/modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/js/ob-smartclient.js [^]
(0042923)
iperdomo (developer)
2011-11-17 11:58

The real problem is the compareAdvancedCriteria function in isc.DataSource object. In the upgrade Isomorphic introduced a problem, and mtaal try to workaround it with this changeset:
https://code.openbravo.com/erp/devel/pi/diff/395cc1ac0987/modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/js/ob-smartclient.js [^]

This causes the problem. The function was rolled back in issue 0018841
(0043074)
shuehner (administrator)
2011-11-22 12:55

Marking as resolved.
Change was only needed in MP5.1 branch and not in pi (As issue did not happen in pi at time of fix, as change causing it was reverted there already).

https://code.openbravo.com/erp/devel/pi/rev/3fe117772a75 [^]
Author Martin Taal <martin.taal@openbravo.com>
    Thu Nov 17 17:05:37 2011 +0100 (4 days ago)
Fixes issue 19086: Selectors in APRM manual windows does not filter when you start typing (they show all records)
(0043075)
marvintm (developer)
2011-11-22 13:15

Reviewed the diff to search for possible regressions after the change. Mikel checked that the functionality itself worked correctly.

- Issue History
Date Modified Username Field Change
2011-11-16 17:30 mirurita New Issue
2011-11-16 17:30 mirurita Assigned To => alostale
2011-11-16 17:30 mirurita File Added: Selector not filtering.png
2011-11-16 17:30 mirurita Modules => Core
2011-11-16 17:32 mirurita Severity critical => major
2011-11-17 08:27 alostale Note Added: 0042904
2011-11-17 08:27 alostale Status new => closed
2011-11-17 08:27 alostale Resolution open => out of date
2011-11-17 09:34 mirurita Note Added: 0042905
2011-11-17 09:34 mirurita Status closed => new
2011-11-17 09:34 mirurita Resolution out of date => open
2011-11-17 11:17 shuehner Target Version => 3.0MP5.1
2011-11-17 11:19 shuehner Tag Attached: Regression
2011-11-17 11:30 mirurita Note Added: 0042921
2011-11-17 11:50 iperdomo Relationship added related to 0018841
2011-11-17 11:53 iperdomo Relationship deleted related to 0018841
2011-11-17 11:55 iperdomo Relationship added related to 0018901
2011-11-17 11:58 iperdomo Note Added: 0042923
2011-11-17 12:13 mirurita Assigned To alostale => mtaal
2011-11-17 17:06 mtaal File Added: 19086.export
2011-11-22 12:54 shuehner Status new => scheduled
2011-11-22 12:54 shuehner fix_in_branch => pi
2011-11-22 12:55 shuehner Note Added: 0043074
2011-11-22 12:55 shuehner Status scheduled => resolved
2011-11-22 12:55 shuehner Fixed in Version => 3.0MP5.1
2011-11-22 12:55 shuehner Fixed in SCM revision => https://code.openbravo.com/erp/devel/pi/rev/3fe117772a75 [^]
2011-11-22 12:55 shuehner Resolution open => fixed
2011-11-22 13:15 marvintm Note Added: 0043075
2011-11-22 13:15 marvintm Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker