Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0019026
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 01. General setupmajoralways2011-11-09 11:082011-11-12 16:04
ReporterVictorVillarView Statuspublic 
Assigned Tomarvintm 
PriorityimmediateResolutionfixedFixed in Version3.0MP5
StatusclosedFix in branchFixed in SCM revision2532ebd3c0b9
ProjectionnoneETAnoneTarget Version3.0MP5
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP4.1SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0019026: Logo does not appear in jasper reports when you use a role different from Admin

DescriptionThe logo of the company does not show in jasper reports when your role is different from Admin.
Steps To ReproduceAs Group Admin role
Navigate to Sales Invoice:
   select one invoice
   print it
   export in pdf
We realise that the logo appears in print.
As other role, either Sales, Warehouse or Finance role:
Navigate to Sales Order window, for example:
   select one order
   print it
   export in pdf
We realise that the logo does not appear in print.
TagsRegression
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00180823.0MP3 closedmarvintm Performance improvements in image showing 

-  Notes
(0042731)
shuehner (administrator)
2011-11-10 15:52

Re-targeting for MP5.
Note: Workaround exists if needed until fix is available: Give read permission to the window 'Application image' to the roles which need access to the logos.
(0042732)
shuehner (administrator)
2011-11-10 15:56

Bug is that the call to 'imageByte = img.getBindaryData();' in line 2563 in Utility.java is outside of the adminMode block. So the permission check will fail if called by a role not having explicit access to 'ad_image'. Just having the OBDal.get calls inside adminMode is not enough, all property access must be also in an adminMode block.
(0042733)
dmitry_mezentsev (developer)
2011-11-10 16:05

https://issues.openbravo.com/view.php?id=18082 [^] is the issue that introduced regression.
(0042734)
hgbot (developer)
2011-11-10 16:12

Repository: erp/devel/pi
Changeset: 38db7358cec3df00dfa158ed6da792eb359ad73d
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Thu Nov 10 16:11:30 2011 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/38db7358cec3df00dfa158ed6da792eb359ad73d [^]

Fixed issue 19026. Images will be read correctly when the role doesn't have access to the Image window.

---
M src/org/openbravo/erpCommon/utility/Utility.java
---
(0042736)
VictorVillar (developer)
2011-11-10 16:51

Verified
(0042743)
shuehner (administrator)
2011-11-10 17:36

Reviewed & test in pi/pgsql (rev id: 38db7358cec3). Now showing the logo image works with a non-admin role.
Tested with printing sales order with the 'f&b espana sales' role for which printing a sales order before did not show the logo + reported an error to the application log. After applying this fix this use case works fine.
Code change adds adminMode calls around the property access of the Image object also to allows this even in case the user/role used to call this code does not have direct access the ad_image entity.
(0042768)
hgbot (developer)
2011-11-12 15:47

Repository: erp/devel/pi
Changeset: 2532ebd3c0b982d6bff7fc63eb2b8de0c17143a8
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Thu Nov 10 16:11:30 2011 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/2532ebd3c0b982d6bff7fc63eb2b8de0c17143a8 [^]

Fixed issue 19026. Images will be read correctly when the role doesn't have access to the Image window.

---
M src/org/openbravo/erpCommon/utility/Utility.java
---
(0042793)
hudsonbot (developer)
2011-11-12 15:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9752fe729257 [^]

Maturity status: Test
(0042801)
shuehner (administrator)
2011-11-12 16:04

re-closing: has been reopened only because of code-line merge during mp5 release.

- Issue History
Date Modified Username Field Change
2011-11-09 11:08 VictorVillar New Issue
2011-11-09 11:08 VictorVillar Assigned To => marvintm
2011-11-09 11:08 VictorVillar Modules => Core
2011-11-10 15:52 shuehner Note Added: 0042731
2011-11-10 15:52 shuehner Target Version 3.0MP6 => 3.0MP5
2011-11-10 15:54 shuehner Priority urgent => immediate
2011-11-10 15:56 shuehner Note Added: 0042732
2011-11-10 16:05 dmitry_mezentsev Tag Attached: Regression
2011-11-10 16:05 dmitry_mezentsev Relationship added related to 0018082
2011-11-10 16:05 dmitry_mezentsev Note Added: 0042733
2011-11-10 16:12 hgbot Checkin
2011-11-10 16:12 hgbot Note Added: 0042734
2011-11-10 16:12 hgbot Status new => resolved
2011-11-10 16:12 hgbot Resolution open => fixed
2011-11-10 16:12 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/38db7358cec3df00dfa158ed6da792eb359ad73d [^]
2011-11-10 16:51 VictorVillar Note Added: 0042736
2011-11-10 16:51 VictorVillar Status resolved => closed
2011-11-10 16:51 VictorVillar Fixed in Version => 3.0MP5
2011-11-10 17:36 shuehner Note Added: 0042743
2011-11-12 15:47 hgbot Checkin
2011-11-12 15:47 hgbot Note Added: 0042768
2011-11-12 15:47 hgbot Status closed => resolved
2011-11-12 15:47 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/38db7358cec3df00dfa158ed6da792eb359ad73d [^] => http://code.openbravo.com/erp/devel/pi/rev/2532ebd3c0b982d6bff7fc63eb2b8de0c17143a8 [^]
2011-11-12 15:49 hudsonbot Checkin
2011-11-12 15:49 hudsonbot Note Added: 0042793
2011-11-12 16:04 shuehner Note Added: 0042801
2011-11-12 16:04 shuehner Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker