Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0013665
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2010-06-15 17:442012-09-26 17:52
ReportershuehnerView Statuspublic 
Assigned ToAugustoMauch 
PrioritynormalResolutionfixedFixed in Version3.0MP16
StatusclosedFix in branchFixed in SCM revisiond9a38ada2c86
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Todbaz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0013665: When disabling heartbeat, the process for sending beats is only unscheduled in running tomcat, butrunning again after tomcat res

Descriptiontart.

The code for disabling heartbeat does not modify the process_request to update its status (or delete the request). It only unschedules it in the currently running scheduler (inside the currently running tomcat).

This means that the process will be running again after you restart tomcat, however as the ad_system_info flag is set to heartbeat disabled this process will not really send beat.
-> priority: minor

As just wrong local behavior but not functional problem (as no beats get send after disabling it)
Steps To ReproduceCheck code in TestHearbeat servlet around line 111

The pr instance (process request) is read from the db, then not modified, then saved....

TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0018214 closedalostale Scheduled processes executed on tomcat restart 

-  Notes
(0028459)
shuehner (administrator)
2010-06-15 18:38

Updated info from testing this behavior. The process_request does get modified to status unscheduled somehow (perhaps by the scheduler itself). However in that case the

OBDal.getInstance().save(pr);

in TestHearbeat line 111 seems to be useless.
(0052230)
AugustoMauch (developer)
2012-09-19 16:20

Test plan:
 Check that after the change it has not changed the way heartbeat is unscheduled:
- Check that heartbeat is scheduled in the Process Request window
- Open the Heartbeat Configuration window and disable heartbeat.
- Go back to the Process Request window, and check that heartbeat status is unscheduled.
- Go back to Heartbeat Configuration and enable heartbeat again.
- In the Process Request window, check that heartbeat status is scheduled again.
(0052231)
hgbot (developer)
2012-09-19 16:22

Repository: erp/devel/pi
Changeset: d9a38ada2c86d12ca540e1401734cf0b98ccfc9b
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Sep 19 16:17:34 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/d9a38ada2c86d12ca540e1401734cf0b98ccfc9b [^]

Fixes issue 13665: Remove unnecessary DAL save

When heartbeat is disabled, the process request is fetched with DAL, and used to unschedule the process. The process request itself it is not explicitly modified, so there is no need to save it.

---
M src/org/openbravo/erpCommon/ad_process/TestHeartbeat.java
---
(0052616)
AugustoMauch (developer)
2012-09-26 11:52

Reopened to change Closed by field
(0052787)
hudsonbot (developer)
2012-09-26 17:20

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b780e90c6452 [^]

Maturity status: Test
(0052805)
dbaz (developer)
2012-09-26 17:52

Reviewed @ changeset: 18052 - 8a0aed9bd90d

- Issue History
Date Modified Username Field Change
2010-06-15 17:44 shuehner New Issue
2010-06-15 17:44 shuehner Assigned To => alostale
2010-06-15 18:38 shuehner Note Added: 0028459
2010-06-23 10:41 alostale Status new => scheduled
2011-11-16 17:26 alostale Relationship added related to 0018214
2012-09-19 16:18 AugustoMauch Closed by => alostale
2012-09-19 16:20 AugustoMauch Note Added: 0052230
2012-09-19 16:20 AugustoMauch Issue Monitored: alostale
2012-09-19 16:22 hgbot Checkin
2012-09-19 16:22 hgbot Note Added: 0052231
2012-09-19 16:22 hgbot Status scheduled => resolved
2012-09-19 16:22 hgbot Resolution open => fixed
2012-09-19 16:22 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d9a38ada2c86d12ca540e1401734cf0b98ccfc9b [^]
2012-09-26 11:52 AugustoMauch Assigned To alostale => AugustoMauch
2012-09-26 11:52 AugustoMauch Note Added: 0052616
2012-09-26 11:52 AugustoMauch Status resolved => new
2012-09-26 11:52 AugustoMauch Resolution fixed => open
2012-09-26 11:52 AugustoMauch Closed by alostale => dbaz
2012-09-26 11:52 AugustoMauch Status new => scheduled
2012-09-26 11:52 AugustoMauch Status scheduled => resolved
2012-09-26 11:52 AugustoMauch Resolution open => fixed
2012-09-26 17:20 hudsonbot Checkin
2012-09-26 17:20 hudsonbot Note Added: 0052787
2012-09-26 17:52 dbaz Note Added: 0052805
2012-09-26 17:52 dbaz Status resolved => closed
2012-09-26 17:52 dbaz Fixed in Version => 3.0MP16


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker