Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0011498
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2009-11-25 14:112010-01-21 00:00
ReporterpjuvaraView Statuspublic 
Assigned Toalostale 
PriorityhighResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision1c27fbded647
ProjectionnoneETAnoneTarget Version2.50MP11
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version2.50MP8SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0011498: In a read only access window you cannot change the audit display

DescriptionUsers having read only access to a window should be able to choose whether the audit data (created by, creation date, etc.) is or is not displayed for that window.

However, when you click on the show/hide audit icon, the data is refreshed but it is refreshed in the same status as it was before.
Steps To Reproduce1) you have a role that gives you read only access to a particular window
2) in that window, you want to enable Audit because you want to see the last update date and creation date
3) you press on the Audit icon in the menu that is supposed to show these fields
4) the screen is refreshed but the audit fields are still not displayed
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
has duplicate defect 00129702.40MP13 closedadrianromero Problem showing audit in grid view 
related to defect 0011950 closedalostale API check build 260 fails 

-  Notes
(0022507)
psarobe (manager)
2009-12-07 20:11

Sorry Paolo but we don't get the idea. Can you please explain it better?
(0022621)
rafaroda (developer)
2009-12-10 12:00

Reminder sent to: pjuvara

Paolo,

Can you please explain this issue further? http://wiki.openbravo.com/wiki/Bug_Reporting_Guidelines#How_to_Report_an_Issue [^]

Add also a target version.

Thanks.
(0022648)
pjuvara (reporter)
2009-12-10 17:04

Consider this scenario:
1) you have a role that gives you read only access to a particular window
2) in that window, you want to enable Audit because you want to see the last update date and creation date
3) you press on the Audit icon in the menu that is supposed to show these fields
4) the screen is refreshed but the audit fields are still not displayed

I believe that this is due to the fact that the show/hide audit icon, although logically not a write operation, internally updates the database setting some user preferences. Since the screen is marked as read only, the preference is not set and the audit status does not change.

I can demonstrate this behavior in butler. I also demonstrated it to ALO who is aware of it.
(0022652)
rafaroda (developer)
2009-12-10 17:38

Audit fields are displayed in Form view but not in grid view.
(0022856)
alostale (developer)
2009-12-16 11:22

It seems not to be related with read-only access but with roles...

I did the following:
-Change to read-only the access for an System role.
-It still works.
-Add to Production role the Product window as read-only
-Add to Production role the Product Category window as editable
-Log in as Production role
-Test both windows in relation mode, both fail.

The problem seems to be in the front-end since the ChangeAudit backend class is never accessed when it fails.

DBA: Can you take a look to changeAuditStatusRelation method in utils.js? it seems that the ajax call some why is not executed.
(0022979)
dbaz (developer)
2009-12-21 13:09

In
function changeAuditStatus() {
in utils.js

I have just written alert('test'); before the submitXmlHttpRequest and always is fired... Could you please confirm that?

If is the case, the problem is in the java part...
(0023347)
alostale (developer)
2010-01-12 11:44

David you are right,

The problem was that the change audit servlet was defined as a process, therefore before executing it, it is checked the current role has permission to it. So if the new role doesn't have explicit access to the process, it doesn't work.

The solution is not to define this as a process, but simply as a mapping to grant access to every one regardless role. (Note that this will cause a API change without risk).
(0023348)
hgbot (developer)
2010-01-12 11:59

Repository: erp/devel/pi
Changeset: efecabf0e0c31af938447c97d8aa32afcafa8e40
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Jan 12 11:58:22 2010 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/efecabf0e0c31af938447c97d8aa32afcafa8e40 [^]

fixed bug 11498: In a read only access window you cannot change the audit display

---
M src-db/database/sourcedata/AD_MODEL_OBJECT.xml
M src-db/database/sourcedata/AD_PROCESS.xml
---
(0023360)
hgbot (developer)
2010-01-12 15:01

Repository: erp/devel/pi
Changeset: 1c27fbded6473998433ca73f248ea98a6f4a9de2
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Jan 12 14:03:14 2010 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/1c27fbded6473998433ca73f248ea98a6f4a9de2 [^]

related to issue 11498
fixed integrity test 259

---
M referencedata/sampledata/Accounting_Test.xml
M referencedata/sampledata/SmallBazaar.xml
---
(0023611)
iperdomo (developer)
2010-01-20 13:24

Tested on pi @ rev 2abe378dc3dc
- Login as System Administrator
- Go to: General Setup > Process Scheduling > Process Monitor
- Ensure that you are in Grid Mode
- Click the 'Show Audit' icon
(0023633)
hudsonbot (developer)
2010-01-20 23:25

A changeset related to this issue has been promoted to main after passing a series of tests and an OBX has been generated:

Changeset: http://code.openbravo.com/erp/devel/main/rev/efecabf0e0c3 [^]
Merge Changeset: http://code.openbravo.com/erp/devel/main/rev/fa6621f85351 [^]
Tests: http://builds.openbravo.com/view/devel-int/ [^]
OBX: http://builds.openbravo.com/erp/obx/core/OpenbravoERP-2.50CI.15942.obx [^]
(0023636)
hudsonbot (developer)
2010-01-20 23:25

A changeset related to this issue has been promoted to main after passing a series of tests and an OBX has been generated:

Changeset: http://code.openbravo.com/erp/devel/main/rev/1c27fbded647 [^]
Merge Changeset: http://code.openbravo.com/erp/devel/main/rev/fa6621f85351 [^]
Tests: http://builds.openbravo.com/view/devel-int/ [^]
OBX: http://builds.openbravo.com/erp/obx/core/OpenbravoERP-2.50CI.15942.obx [^]

- Issue History
Date Modified Username Field Change
2009-11-25 14:11 pjuvara New Issue
2009-11-25 14:11 pjuvara Assigned To => rafaroda
2009-12-07 20:11 psarobe Note Added: 0022507
2009-12-07 20:11 psarobe Status new => feedback
2009-12-10 12:00 rafaroda Note Added: 0022621
2009-12-10 17:04 pjuvara Note Added: 0022648
2009-12-10 17:04 pjuvara Status feedback => new
2009-12-10 17:05 pjuvara Target Version => 2.50MP11
2009-12-10 17:38 rafaroda Note Added: 0022652
2009-12-10 17:38 rafaroda Assigned To rafaroda => alostale
2009-12-10 17:38 rafaroda Priority normal => high
2009-12-10 17:38 rafaroda Status new => scheduled
2009-12-10 17:38 rafaroda Proposed Solution updated
2009-12-16 11:22 alostale Note Added: 0022856
2009-12-16 11:22 alostale Assigned To alostale => dbaz
2009-12-21 13:09 dbaz Note Added: 0022979
2009-12-21 13:09 dbaz Assigned To dbaz => alostale
2010-01-12 11:44 alostale Note Added: 0023347
2010-01-12 11:59 hgbot Checkin
2010-01-12 11:59 hgbot Note Added: 0023348
2010-01-12 11:59 hgbot Status scheduled => resolved
2010-01-12 11:59 hgbot Resolution open => fixed
2010-01-12 11:59 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/efecabf0e0c31af938447c97d8aa32afcafa8e40 [^]
2010-01-12 15:01 hgbot Checkin
2010-01-12 15:01 hgbot Note Added: 0023360
2010-01-12 15:01 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/efecabf0e0c31af938447c97d8aa32afcafa8e40 [^] => http://code.openbravo.com/erp/devel/pi/rev/1c27fbded6473998433ca73f248ea98a6f4a9de2 [^]
2010-01-13 08:41 alostale Relationship added related to 0011950
2010-01-20 13:24 iperdomo Note Added: 0023611
2010-01-20 13:24 iperdomo Status resolved => closed
2010-01-20 23:25 hudsonbot Checkin
2010-01-20 23:25 hudsonbot Note Added: 0023633
2010-01-20 23:25 hudsonbot Checkin
2010-01-20 23:25 hudsonbot Note Added: 0023636
2010-01-21 00:00 anonymous sf_bug_id 0 => 2935921
2010-05-14 13:01 adrianromero Relationship added has duplicate 0012970


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker