Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0011950
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Otherscriticalhave not tried2010-01-12 22:092010-01-20 00:01
ReportershuehnerView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchpiFixed in SCM revisionb847ebd31eaa
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0011950: API check build 260 fails

DescriptionThis api check build fails:

http://builds.openbravo.com/job/erp_devel_pi-module-integrity-test/260/console [^]

Summary:
  Removed row from table AD_PROCESS - ID: 1005200000

TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00114982.50MP11 closedalostale In a read only access window you cannot change the audit display 

-  Notes
(0023376)
alostale (developer)
2010-01-13 08:40

This change is introduced by fixing issue 0011498.

There's a Servlet that is called to change the audit status (show/not show) for a tab. This Servlet was defined as a process in AD, which means that to be able to operate it, it was necessary to explicitly grant access to the process. The solution for the bug consisted in removing it from processes in AD (which makes the API change) and creating it as a simple mapping.

The risk for this change is 0, because the process was not directly accessible and the as a standard process and the Servlet that was used is still present with the same mapping, that's why I propose to maintain the change.
(0023379)
pjuvara (reporter)
2010-01-13 09:21

Approved.
(0023392)
alostale (developer)
2010-01-13 15:12
edited on: 2010-01-13 16:54

The push to close this issue is blocked till mp10 is released and api-checks repository is unfrozen.

(0023558)
hgbot (developer)
2010-01-19 12:01

Repository: erp/devel/api-checks
Changeset: b847ebd31eaad3595b82b5e1f9012dd5a15cb393
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Jan 19 12:01:23 2010 +0100
URL: http://code.openbravo.com/erp/devel/api-checks/rev/b847ebd31eaad3595b82b5e1f9012dd5a15cb393 [^]

fixed issue 11950: API check build 260 fails

---
M model/sourcedata/AD_PROCESS.xml
---

- Issue History
Date Modified Username Field Change
2010-01-12 22:09 shuehner New Issue
2010-01-12 22:09 shuehner Assigned To => alostale
2010-01-13 08:40 alostale Note Added: 0023376
2010-01-13 08:41 alostale Relationship added related to 0011498
2010-01-13 08:41 alostale Assigned To alostale => pjuvara
2010-01-13 09:21 pjuvara Status new => scheduled
2010-01-13 09:21 pjuvara Note Added: 0023379
2010-01-13 09:21 pjuvara Assigned To pjuvara => shuehner
2010-01-13 09:21 pjuvara fix_in_branch => pi
2010-01-13 10:29 shuehner Assigned To shuehner => alostale
2010-01-13 15:12 alostale Note Added: 0023392
2010-01-13 16:54 alostale Note Edited: 0023392
2010-01-19 12:01 hgbot Checkin
2010-01-19 12:01 hgbot Note Added: 0023558
2010-01-19 12:01 hgbot Status scheduled => resolved
2010-01-19 12:01 hgbot Resolution open => fixed
2010-01-19 12:01 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/api-checks/rev/b847ebd31eaad3595b82b5e1f9012dd5a15cb393 [^]
2010-01-19 12:02 alostale Status resolved => closed
2010-01-20 00:01 anonymous sf_bug_id 0 => 2935293


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker