Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0009522
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2009-06-17 18:482009-09-19 00:00
ReporterAinhoaPagolaView Statuspublic 
Assigned Toiperdomo 
PriorityurgentResolutionfixedFixed in Version2.50MP6
StatusclosedFix in branchpiFixed in SCM revision99e1c0521053
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.5
OS VersionUbuntu 8.4Database version8.3Ant version1.7
Product VersionpiSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0009522: CCC issue when clicking on a button on a window (of a module) without saving previously.

DescriptionIn a extension module, I have created a window that has a button.
This button calls a java process.
There is also a trigger that prevents that two records are inserted in this table.

When I insert a record in this window and click the button without saving the trigger is fired. (It should not, just one record has being inserted!)

If I insert a record and SAVE and then press the button, everything works fine.

Sometime later this problem stops happening (I can not say when/why) but if I create a record and press the button without saving, I get a null pointer exception instead of the triggers exception.
Steps To ReproduceI attach HCM module.

Go to Human Capital Management | Employee
create a new record.

Go to employment information tab. Create a new record and press the complete button. Trigger is fired.
TagsModularity
Attached Files? file icon org.openbravo.hcm.common-1.0.0.obx [^] (220,297 bytes) 2009-06-17 18:55
? file icon org.openbravo.hcm.common-1.0.1.obx [^] (221,192 bytes) 2009-07-03 17:54
diff file icon PatchToInstall101.diff [^] (601 bytes) 2009-07-03 17:54 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0017419)
hgbot (developer)
2009-06-18 11:48

Repository: erp/devel/pi
Changeset: 0dc17b6b58a973c2a9aaae6ddd1e3464be8a8867
Author: Iván Perdomo <ivan.perdomo <at> openbravo.com>
Date: Thu Jun 18 11:47:04 2009 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/0dc17b6b58a973c2a9aaae6ddd1e3464be8a8867 [^]

Fixes issue 9522: Excluding PopupLoading class from autosave process

---
M src/org/openbravo/erpCommon/utility/Utility.java
---
(0017891)
AinhoaPagola (reporter)
2009-07-03 13:51

I still experience strange behavior performing the steps described. I have updated my pi workspace and the issue still persists.
(0019283)
iperdomo (developer)
2009-08-30 18:33

Hi,
I cloned the code from the repo [1] (assuming has changed since the bug report) and I'm not able to complete the employee information due an error. Can you please check it?

[1] https://code.openbravo.com/erp/mods/org.openbravo.hcm.common/ [^]

Cheers,

Iván
(0019285)
iperdomo (developer)
2009-08-30 20:06

@AinhoaPagola:

I'm working on it, that's why I schedule it again.

Cheers,

Iván
(0019286)
hgbot (developer)
2009-08-30 20:43

Repository: erp/devel/pi
Changeset: 241c088297f88cc3ff5169a2039eb3aa8f8940ae
Author: Iván Perdomo <ivan.perdomo <at> openbravo.com>
Date: Sun Aug 30 20:38:59 2009 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/241c088297f88cc3ff5169a2039eb3aa8f8940ae [^]

Fixes issue 9522: Modified way to execute a DAL based process

---
M src-wad/src/org/openbravo/wad/javasource.javaxml
---
(0019287)
hgbot (developer)
2009-08-30 20:43

Repository: erp/devel/pi
Changeset: eb2672fdda9722fdab596e9e5ea703ac7ef92d43
Author: Iván Perdomo <ivan.perdomo <at> openbravo.com>
Date: Sun Aug 30 20:40:48 2009 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/eb2672fdda9722fdab596e9e5ea703ac7ef92d43 [^]

Related to issue 9522: Fixes getNumericParameter calls

---
M src-wad/src/org/openbravo/wad/Wad.java
---
(0019351)
hgbot (developer)
2009-08-31 16:39

Repository: erp/devel/pi
Changeset: 99e1c05210539a7ce49390696270b92fbe963ee1
Author: Iván Perdomo <ivan.perdomo <at> openbravo.com>
Date: Mon Aug 31 16:38:27 2009 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/99e1c05210539a7ce49390696270b92fbe963ee1 [^]

Fixes issue 9522: Modified way to get the process class name

---
M src/org/openbravo/scheduling/ProcessBundle.java
M src/org/openbravo/scheduling/Process_data.xsql
---
(0019715)
AinhoaPagola (reporter)
2009-09-10 11:36

I have tested the fix and i can not reproduce the issue anymore.

Thanks Iván!
(0020179)
psarobe (manager)
2009-09-18 08:36

Thanks Ainhoa

- Issue History
Date Modified Username Field Change
2009-06-17 18:48 AinhoaPagola New Issue
2009-06-17 18:48 AinhoaPagola Assigned To => rafaroda
2009-06-17 18:55 AinhoaPagola Assigned To rafaroda => iperdomo
2009-06-17 18:55 AinhoaPagola File Added: org.openbravo.hcm.common-1.0.0.obx
2009-06-18 10:16 iperdomo Status new => scheduled
2009-06-18 10:16 iperdomo fix_in_branch => pi
2009-06-18 10:17 iperdomo Priority normal => urgent
2009-06-18 10:17 iperdomo fix_in_branch pi =>
2009-06-18 10:50 AinhoaPagola Tag Attached: Modularity
2009-06-18 11:48 hgbot Checkin
2009-06-18 11:48 hgbot Note Added: 0017419
2009-06-18 11:48 hgbot Status scheduled => resolved
2009-06-18 11:48 hgbot Resolution open => fixed
2009-06-18 11:48 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/0dc17b6b58a973c2a9aaae6ddd1e3464be8a8867 [^]
2009-06-22 11:09 psarobe Fixed in Version => main
2009-07-03 13:51 AinhoaPagola Status resolved => new
2009-07-03 13:51 AinhoaPagola Resolution fixed => open
2009-07-03 13:51 AinhoaPagola Note Added: 0017891
2009-07-03 13:51 AinhoaPagola Fixed in Version main =>
2009-07-03 15:30 iperdomo Status new => scheduled
2009-07-03 15:30 iperdomo fix_in_branch => pi
2009-07-03 17:54 AinhoaPagola File Added: org.openbravo.hcm.common-1.0.1.obx
2009-07-03 17:54 AinhoaPagola File Added: PatchToInstall101.diff
2009-08-30 18:33 iperdomo Note Added: 0019283
2009-08-30 18:33 iperdomo Status scheduled => feedback
2009-08-30 18:36 iperdomo Status feedback => scheduled
2009-08-30 20:06 iperdomo Note Added: 0019285
2009-08-30 20:43 hgbot Checkin
2009-08-30 20:43 hgbot Note Added: 0019286
2009-08-30 20:43 hgbot Status scheduled => resolved
2009-08-30 20:43 hgbot Resolution open => fixed
2009-08-30 20:43 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/0dc17b6b58a973c2a9aaae6ddd1e3464be8a8867 [^] => http://code.openbravo.com/erp/devel/pi/rev/241c088297f88cc3ff5169a2039eb3aa8f8940ae [^]
2009-08-30 20:43 hgbot Checkin
2009-08-30 20:43 hgbot Note Added: 0019287
2009-08-30 20:43 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/241c088297f88cc3ff5169a2039eb3aa8f8940ae [^] => http://code.openbravo.com/erp/devel/pi/rev/eb2672fdda9722fdab596e9e5ea703ac7ef92d43 [^]
2009-08-31 16:39 hgbot Checkin
2009-08-31 16:39 hgbot Note Added: 0019351
2009-08-31 16:39 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/eb2672fdda9722fdab596e9e5ea703ac7ef92d43 [^] => http://code.openbravo.com/erp/devel/pi/rev/99e1c05210539a7ce49390696270b92fbe963ee1 [^]
2009-09-10 11:36 AinhoaPagola Note Added: 0019715
2009-09-18 08:36 psarobe Status resolved => closed
2009-09-18 08:36 psarobe Note Added: 0020179
2009-09-18 08:36 psarobe Fixed in Version => 2.50MP6
2009-09-19 00:00 anonymous sf_bug_id 0 => 2861722


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker