Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0009276
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2009-06-01 19:262009-09-02 13:51
ReporterpjuvaraView Statuspublic 
Assigned Toharikrishnan 
PriorityurgentResolutionfixedFixed in Versionpi
StatusclosedFix in branchpiFixed in SCM revision73ff341f80bd
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_11
OS VersionrPath LinuxDatabase version8.3.5Ant version1.7.1
Product Version2.50MP1SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0009276: Organization list does not include summary organizations in the Account Combination window and selector

DescriptionIn the Account Combination window, the Organization list does not include summary organizations.
The same happens in the Account Combination selector.

This is a major problem because you tend to define your account combinations at the top level of the organization hierarchy and the organizations there are summary organizations.

The workaround is to chose a different organization: this is going to have cosmetic issues in the account combination window (not the values you will expect) but will not have any effect in accounting because the organization is always derived from the document to be accounted.
Steps To Reproduce1) Define an organization hierarchy like:
  A (legal entity)
    B (generic)
    C (generic)
  In this case A must be a summary organization
2) Navigate to Information / Account
3) In the Organization field, you can choose B and C but not A (DEFECT)
4) Navigate to Financial Management / Accounting / Setup / Account Combination
5) In the Organization field, you can choose B and C but not A (DEFECT)
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00102022.40MP10 closedharikrishnan Organization list does not include summary organizations in the Account Combination window and selector 
has duplicate defect 0009183 closediperdomo Organization combobox of the Account Selector doesn't display summary level orgs 
has duplicate defect 0009339 closededuardo_Argal Can not select organizations in account combination 

-  Notes
(0016967)
DavidV (reporter)
2009-06-05 02:57

As far as I got understood the concept, summary organizations principially do not have its own transactions. I can not say if it reflects a real-world situation = whether an organisation is a purely summary organisation without any single transaction.

Anyway, let's suppose it makes sense to have s pure summary organisation.

Secondly I suppose that Account selector appears just in active situations (when I need post something to the selected account) not in pasive situations (when I want to query the accounts).

In that conditions, the current (incriminated) behavior is correct. Since, you should not be allowed to select any account in summary organisation for posting transaction.
(0016968)
DavidV (reporter)
2009-06-05 03:08
edited on: 2009-06-05 03:10

The problem pjuvara probably faces (and I face it definitely :) is:

I need to have a parent organisation A (legal entity with accounting)
and its "daughter" organisations (disregarding its legal form).

Problem is in organisation hierarchy definition window (General Setup > Enterprise > Organization) particularly in its Tree screen. I can not subordinate an organization under another one until the intended parent organization is "summary level". This is obviously incorrect behavior (parent organizations regularly have its own transactions).

Recommend to requalify the issue.

(0016969)
DavidV (reporter)
2009-06-05 03:23

By the way, there is a workaround:

you can mark a parent organization as "summary level", arrange the daughter organizations under the parent one and finally change uncheck "summary level" in the parent organization

the hierarchy persists
so, then your parent organization appears in the account selector ...

Quod Erat Demonstrandum :)
(0016973)
iperdomo (developer)
2009-06-05 06:59

@pjuvara:

Can you please comment on DavidV's proposal?

Thanks,
(0017202)
pjuvara (reporter)
2009-06-11 06:43

In 2.50 we have introduced the concept of Organization Type and that is what determines whether an organization can or cannot have transactions.
The Summary Level flag is only used to determine whether an organization can have children in the organization tree.
As such, the Summary Level flag should not have any influence on the availability of this organization in the list of organization in the account combination window.
(0018657)
hgbot (developer)
2009-07-28 14:01

Repository: erp/devel/pi
Changeset: d8d5b6dbf23912dff6e6a3140258225ba169c0fd
Author: David Alsasua <david.alsasua <at> openbravo.com>
Date: Tue Jul 28 14:01:36 2009 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/d8d5b6dbf23912dff6e6a3140258225ba169c0fd [^]

Fixes issue 9276: Organization list does not include summary organizations in the Account Combination window and selector

---
M src-db/database/model/tables/C_ACCTSCHEMA_DEFAULT.xml
M src-db/database/sourcedata/AD_FIELD.xml
M src/org/openbravo/erpCommon/info/Account.java
---
(0019111)
sureshbabu (reporter)
2009-08-20 14:34

Tested, able to select the parent organization.
(0019195)
sureshbabu (reporter)
2009-08-24 15:35

When i tested this issue on Thursday i can able to view the top level organization, but today when i try to reproduce this for a back port issue i am not able to view the same.
(0019196)
harikrishnan (reporter)
2009-08-24 16:17

In this (Financial Management / Accounting / Setup / Account Combination) part the problem is occurring.

(0019215)
hgbot (developer)
2009-08-25 13:00

Repository: erp/devel/pi
Changeset: 73ff341f80bdca3b56c7989c25d9257cd52cb914
Author: Harikrishnan Raja <harikrishnan.raja <at> openbravo.com>
Date: Tue Aug 25 16:29:24 2009 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/73ff341f80bdca3b56c7989c25d9257cd52cb914 [^]

Fixes Issue 9276: Organization list does not include summary organizations in the Account Combination window and selector

---
M src-db/database/sourcedata/AD_COLUMN.xml
---
(0019429)
sureshbabu (reporter)
2009-09-02 13:51

Tested working fine

- Issue History
Date Modified Username Field Change
2009-06-01 19:26 pjuvara New Issue
2009-06-01 19:26 pjuvara Assigned To => rafaroda
2009-06-02 09:21 rafaroda Assigned To rafaroda => iperdomo
2009-06-02 09:21 rafaroda Priority normal => urgent
2009-06-02 09:21 rafaroda Status new => scheduled
2009-06-02 09:22 rafaroda Relationship added has duplicate 0009183
2009-06-04 06:28 DavidV Issue Monitored: DavidV
2009-06-04 06:30 DavidV Issue End Monitor: DavidV
2009-06-04 06:31 DavidV Issue Monitored: DavidV
2009-06-05 02:57 DavidV Note Added: 0016967
2009-06-05 03:08 DavidV Note Added: 0016968
2009-06-05 03:10 DavidV Note Edited: 0016968
2009-06-05 03:23 DavidV Note Added: 0016969
2009-06-05 06:55 pjuvara Relationship added has duplicate 0009339
2009-06-05 06:59 iperdomo Note Added: 0016973
2009-06-05 06:59 iperdomo Status scheduled => feedback
2009-06-10 19:52 iciordia Assigned To iperdomo => eduardo_Argal
2009-06-11 06:43 pjuvara Note Added: 0017202
2009-06-11 06:43 pjuvara Status feedback => new
2009-06-22 09:58 rafaroda Status new => scheduled
2009-06-22 09:58 rafaroda fix_in_branch => pi
2009-07-15 10:32 vmromanos Assigned To eduardo_Argal => vmromanos
2009-07-28 14:01 hgbot Checkin
2009-07-28 14:01 hgbot Note Added: 0018657
2009-07-28 14:01 hgbot Status scheduled => resolved
2009-07-28 14:01 hgbot Resolution open => fixed
2009-07-28 14:01 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d8d5b6dbf23912dff6e6a3140258225ba169c0fd [^]
2009-08-06 12:26 rafaroda Issue cloned 0010202
2009-08-06 12:26 rafaroda Relationship added depends on 0010202
2009-08-20 14:34 sureshbabu Status resolved => closed
2009-08-20 14:34 sureshbabu Note Added: 0019111
2009-08-20 14:34 sureshbabu Fixed in Version => pi
2009-08-21 00:00 anonymous sf_bug_id 0 => 2841447
2009-08-24 15:35 sureshbabu Status closed => new
2009-08-24 15:35 sureshbabu Resolution fixed => open
2009-08-24 15:35 sureshbabu Note Added: 0019195
2009-08-24 15:35 sureshbabu Fixed in Version pi =>
2009-08-24 16:17 harikrishnan Note Added: 0019196
2009-08-25 10:14 rafaroda Status new => scheduled
2009-08-25 10:14 rafaroda Assigned To vmromanos => harikrishnan
2009-08-25 13:00 hgbot Checkin
2009-08-25 13:00 hgbot Note Added: 0019215
2009-08-25 13:00 hgbot Status scheduled => resolved
2009-08-25 13:00 hgbot Resolution open => fixed
2009-08-25 13:00 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/d8d5b6dbf23912dff6e6a3140258225ba169c0fd [^] => http://code.openbravo.com/erp/devel/pi/rev/73ff341f80bdca3b56c7989c25d9257cd52cb914 [^]
2009-09-02 13:51 sureshbabu Status resolved => closed
2009-09-02 13:51 sureshbabu Note Added: 0019429
2009-09-02 13:51 sureshbabu Fixed in Version => pi


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker