Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0054873
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[POS2] POSmajoralways2024-03-07 08:272024-05-24 13:52
ReporterucarrionView Statuspublic 
Assigned ToSABARINATH P 
PrioritynormalResolutionfixedFixed in Version24Q3
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0054873: Unexpected email field when the only POS document delivery method selected in Print

DescriptionIf for a given reason I just want to print documents from the POS and I deactivate the rest of the POS delivery methods, in the popup I still can see the field to add any email even the mail consent checkbox. Those are not expected here.
Steps To ReproduceVideo: https://vimeo.com/920351922/6d859d0355?share=copy [^]
Proposed SolutionThe only option appearing should bt the printing, as configured. Please consider the new ticket printing and the reprint flow too.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0161920)
hgbot (developer)
2024-03-11 07:17

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2/-/merge_requests/2485 [^]
(0162331)
hgbot (developer)
2024-03-19 10:12

Directly closing issue as related merge request is already approved.

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2 [^]
Changeset: 3441f5ce121a6d170e283f2335ede670a9e514c4
Author: Sabarinath <sabarinath.palanisamy.ext@openbravo.com>
Date: 19-03-2024 09:12:17
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2/-/commit/3441f5ce121a6d170e283f2335ede670a9e514c4 [^]

Fixed ISSUE-54873: Added condition for receipt delivery option dialog.
* This condition will display email properties only when we configured email as true in receipt delivery option in backoffice.

---
M web-jspack/org.openbravo.pos2/src/components/ReceiptDeliveryOptions/ReceiptDeliveryOptions.jsx
---
(0162332)
hgbot (developer)
2024-03-19 10:12

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2/-/merge_requests/2485 [^]
(0163156)
Daria_Sh (developer)
2024-04-12 14:21

Tested in qa-retail and confirmed the issue is partially fixed: if the backoffice is configured to show only printing option, the email field is not shown in the pop-up after completing the sale. However, if reopen the order and apply 'Print' option, the email field remains visible in the pop-up
(0163159)
hgbot (developer)
2024-04-12 15:25

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2/-/merge_requests/2565 [^]
(0165101)
hgbot (developer)
2024-05-24 13:52

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2/-/merge_requests/2565 [^]
(0165102)
hgbot (developer)
2024-05-24 13:52

Directly closing issue as related merge request is already approved.

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2 [^]
Changeset: 431fd6110130c9b946c88e40d5281a65c67bc680
Author: Sabarinath <sabarinath.palanisamy.ext@openbravo.com>
Date: 24-05-2024 11:52:25
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2/-/commit/431fd6110130c9b946c88e40d5281a65c67bc680 [^]

Fixed ISSUE-54873: Resolved same issue in bookedreceiptdeliveryoptions

---
M web-jspack/org.openbravo.pos2/src/components/ReceiptDeliveryOptions/BookedReceiptDeliveryOptions/BookedReceiptDeliveryOptions.jsx
M web-jspack/org.openbravo.pos2/src/components/ReceiptDeliveryOptions/BookedReceiptDeliveryOptions/BookedReceiptDeliveryOptionsDialog.jsx
---

- Issue History
Date Modified Username Field Change
2024-03-07 08:27 ucarrion New Issue
2024-03-07 08:27 ucarrion Assigned To => Retail
2024-03-07 08:27 ucarrion Triggers an Emergency Pack => No
2024-03-07 08:28 ucarrion Steps to Reproduce Updated View Revisions
2024-03-08 08:14 SABARINATH P Assigned To Retail => SABARINATH P
2024-03-11 07:17 hgbot Note Added: 0161920
2024-03-11 07:18 SABARINATH P Status new => scheduled
2024-03-19 10:12 hgbot Resolution open => fixed
2024-03-19 10:12 hgbot Status scheduled => closed
2024-03-19 10:12 hgbot Fixed in Version => 24Q2
2024-03-19 10:12 hgbot Note Added: 0162331
2024-03-19 10:12 hgbot Note Added: 0162332
2024-04-12 14:21 Daria_Sh Note Added: 0163156
2024-04-12 14:21 Daria_Sh Status closed => new
2024-04-12 14:21 Daria_Sh Resolution fixed => open
2024-04-12 14:21 Daria_Sh Fixed in Version 24Q2 =>
2024-04-12 15:25 hgbot Note Added: 0163159
2024-04-15 07:21 SABARINATH P Status new => scheduled
2024-05-07 16:13 lorenzofidalgo Target Version => 24Q2
2024-05-24 07:47 marvintm Target Version 24Q2 =>
2024-05-24 13:52 hgbot Resolution open => fixed
2024-05-24 13:52 hgbot Status scheduled => closed
2024-05-24 13:52 hgbot Note Added: 0165101
2024-05-24 13:52 hgbot Fixed in Version => 24Q3
2024-05-24 13:52 hgbot Note Added: 0165102


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker