Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0049784
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[POS2] POSmajorhave not tried2022-07-12 12:542022-09-23 13:03
ReporterplujanView Statuspublic 
Assigned ToRetail 
PrioritynormalResolutionopenFixed in Version
StatusnewFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0049784: [22Q3] Barcode scanner adds two products if the EAN field is focused

DescriptionWhen using the barcode scanner to add products, two lines of the same product are added. On top of the main problem of having an extra product added to the ticket, notice that the product is a grouped one, so it has no sense to have two separated lines neither.
Steps To ReproduceIn a 22Q3 environment, configure the product Alpine Poles to have a given EAN code which you posses the barcode.

Scenario A (wrong)
Log into POS2 as vallblanca
Switch to Scan tab. Notice the focus is in the Code field
Use the barcode scanner to scan the code for Alpine Poles
Error: Two lines of one Alpine Poles are added to the ticket

Scenario B (working as expected)
Log into POS2 as vallblanca
Switch to Scan tab. Click anywhere in the screen to remove the focus from Code field
Use the barcode scanner to scan the code for Alpine Poles
As expected, only one line of Alpine Poles is added to the ticket
TagsFASH
Attached Filesjpg file icon TwoAlpinePoles.jpg [^] (87,902 bytes) 2022-07-12 12:54


? file icon 2 Quantities added on Scan.webm [^] (915,737 bytes) 2022-09-23 11:40

- Relationships Relation Graph ] Dependency Graph ]
duplicate of defect 0049889 closedmeriem_azaf JIRA 3186 - QR code : Product quantity increase randomly. 

-  Notes
(0140081)
rafaroda (developer)
2022-08-12 08:38

Duplicated of 0049889
(0141321)
rafaroda (developer)
2022-09-23 11:40

This 0049784 is wrongly closed, this keeps reproducing, see attached video:

1) You can reproduce it perfectly in Live Builds https://livebuilds.openbravo.com/retail_pos2_pgsql/web/pos/?terminal=VBS-2 [^]

2) You need to have the focus in CODE field int he main scan POS screen: for instance barcode https://barcode.tec-it.com/es/?data=2112345000046 [^] for product with EAN 2112345000046

3) You need to use a REAL scanner (DON’T try by simulating scanner)

- Issue History
Date Modified Username Field Change
2022-07-12 12:54 plujan New Issue
2022-07-12 12:54 plujan Assigned To => Retail
2022-07-12 12:54 plujan File Added: TwoAlpinePoles.jpg
2022-07-12 12:54 plujan Triggers an Emergency Pack => No
2022-07-18 17:42 rafaroda Tag Attached: FASH
2022-08-10 11:52 AugustoMauch Status new => closed
2022-08-11 08:53 AugustoMauch Relationship added duplicate of 0049889
2022-08-12 08:38 rafaroda Note Added: 0140081
2022-09-23 11:40 rafaroda Note Added: 0141321
2022-09-23 11:40 rafaroda File Added: 2 Quantities added on Scan.webm
2022-09-23 13:01 aferraz Status closed => new


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker