Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0047978
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Discounts and Promotionsmajoralways2021-11-03 19:152021-12-23 08:33
ReporterlbressanView Statuspublic 
Assigned Torqueralta 
PrioritynormalResolutionfixedFixed in VersionRR22Q1
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date2021-11-17
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0047978: Does not allow discounts from keyboard configuring touch point ui

DescriptionDoes not allow discounts from the keyboard by configuring the user interface of the point of contact when you deactivate the promotions
Steps To Reproduce1) Go to the "Discount and promotions" window and deactivate all promotions

2) Go to the window "Touchpoint Type" of the terminal that we are going to connect

3) They are in the "Touchpoint Type" window, Go to the "Touchpoint UI Configuration" field and add "Default POS UI Configuration"

4) Go to the "Preference" window and select the property "WEB POS Open Discounts From Keyboard"

5) Go to the POS and select a product, when selecting it you will try to add a "Discount" but we can see that the "Discount" button is disabled
TagsNo tags attached.
Attached Files? file icon TIcket31675.mp4 [^] (2,715,239 bytes) 2021-11-03 19:15

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0133331)
dromero (developer)
2021-11-24 16:45

any update?
(0133695)
hgbot (developer)
2021-12-14 15:13

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/merge_requests/658 [^]
(0133749)
hgbot (developer)
2021-12-16 08:46

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/merge_requests/658 [^]
(0133750)
hgbot (developer)
2021-12-16 08:46

Directly closing issue as related merge request is already approved.

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal [^]
Changeset: 48e23b7e4e4de8e62134e7f531e9d0e826b4c5e6
Author: Rafael Queralta <rafaelcuba81@gmail.com>
Date: 16-12-2021 07:10:06
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/commit/48e23b7e4e4de8e62134e7f531e9d0e826b4c5e6 [^]

Fixed BUG-47978: Allow discounts from the keyboard by configuring the user interface

---
M web/org.openbravo.retail.posterminal/js/actions/discount.js
---
(0133770)
ivazquez (developer)
2021-12-16 15:38

Hello team,

I will re-open the issue because the client detects a new error after applying the patch.

There are the explanatory video: https://watch.screencastify.com/v/weTphqHU3ENkzX1PAr8z [^]

And the Steps to Reproduce are the next:

-Follow the steps indicated in the steps to reproduce of the issue
-After adding a product, without having put anything, click on the Discount button and an error box appears in the upper left corner, and in the google chrome console an error appears saying the following: 'Uncaught BigDecimal(): Not a number: N,a,N'.
-If you add a discount number and click on the Discount button, the discount is applied but the number remains written on the terminal.
(0133808)
hgbot (developer)
2021-12-17 17:00

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/merge_requests/661 [^]
(0133825)
hgbot (developer)
2021-12-20 08:24

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/merge_requests/661 [^]
(0133826)
marvintm (manager)
2021-12-20 08:24

Fixed by this subsequent commit:

https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/merge_requests/661/diffs?commit_id=bb9298e59b79515255de95febed0e15d51033bbd [^]
(0133867)
hgbot (developer)
2021-12-21 10:48

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/merge_requests/663 [^]
(0133868)
hgbot (developer)
2021-12-21 11:05

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal [^]
Changeset: 9d89a8875569d95ea3bc6902f03c235828948f1e
Author: Ranjith S R <ranjith@qualiantech.com>
Date: 21-12-2021 12:31:04
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/commit/9d89a8875569d95ea3bc6902f03c235828948f1e [^]

Related to ISSUE-47978: Keyboard content should not validated when opening discounts

---
M web/org.openbravo.retail.posterminal/js/actions/discount.js
---
(0133869)
hgbot (developer)
2021-12-21 11:05

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/merge_requests/663 [^]
(0133909)
hgbot (developer)
2021-12-22 16:38

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/merge_requests/666 [^]
(0133926)
hgbot (developer)
2021-12-23 08:33

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/merge_requests/666 [^]
(0133927)
hgbot (developer)
2021-12-23 08:33

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal [^]
Changeset: ae5778fe4d8656f74c7c5cface5584c2072afd72
Author: Rafael Queralta <rafaelcuba81@gmail.com>
Date: 23-12-2021 07:32:27
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.retail.posterminal/-/commit/ae5778fe4d8656f74c7c5cface5584c2072afd72 [^]

Related to ISSUE-47978: if Keyboard content is empty percentage value will be equal to 0

---
M web/org.openbravo.retail.posterminal/js/actions/discount.js
---

- Issue History
Date Modified Username Field Change
2021-11-03 19:15 lbressan New Issue
2021-11-03 19:15 lbressan Assigned To => Retail
2021-11-03 19:15 lbressan File Added: TIcket31675.mp4
2021-11-03 19:15 lbressan Regression date => 2021-11-17
2021-11-03 19:15 lbressan Triggers an Emergency Pack => No
2021-11-03 19:18 Practics Issue Monitored: Practics
2021-11-08 17:51 rqueralta Assigned To Retail => rqueralta
2021-11-16 16:43 rqueralta Status new => scheduled
2021-11-24 16:45 dromero Note Added: 0133331
2021-12-14 15:13 hgbot Note Added: 0133695
2021-12-16 08:46 hgbot Note Added: 0133749
2021-12-16 08:46 hgbot Resolution open => fixed
2021-12-16 08:46 hgbot Status scheduled => closed
2021-12-16 08:46 hgbot Fixed in Version => RR22Q1
2021-12-16 08:46 hgbot Note Added: 0133750
2021-12-16 15:38 ivazquez Note Added: 0133770
2021-12-16 15:38 ivazquez Status closed => new
2021-12-16 15:38 ivazquez Resolution fixed => open
2021-12-17 17:00 hgbot Note Added: 0133808
2021-12-20 08:24 hgbot Note Added: 0133825
2021-12-20 08:24 marvintm Note Added: 0133826
2021-12-20 08:25 marvintm Status new => scheduled
2021-12-20 08:25 marvintm Status scheduled => resolved
2021-12-20 08:25 marvintm Resolution open => fixed
2021-12-20 08:25 marvintm Review Assigned To => marvintm
2021-12-20 08:25 marvintm Status resolved => closed
2021-12-21 10:48 hgbot Note Added: 0133867
2021-12-21 11:05 hgbot Note Added: 0133868
2021-12-21 11:05 hgbot Note Added: 0133869
2021-12-22 16:38 hgbot Note Added: 0133909
2021-12-23 08:33 hgbot Note Added: 0133926
2021-12-23 08:33 hgbot Note Added: 0133927


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker