Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0047736
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Localization Pack: Spain] SIImajorhave not tried2021-09-22 15:242021-12-07 13:57
ReporterucarrionView Statuspublic 
Assigned Topsanjuan 
PrioritynormalResolutionopenFixed in Version
StatusnewFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Regression date
Regression introduced by commit
Regression level
Review Assigned To
Regression introduced in release
Summary

0047736: The SII requires to send the customer data including the region of the address when it should not

DescriptionThe SII requires to send the customer data including the region of the address when it should not.

You create in POS a simplified invoice with anonymous customer or an informed customer which has NO region in the address.
When you send the simplified invoice to SII, it fails obliging to the region, when it should not
Steps To Reproduce-Login an spanish POS terminal
-Select a customer whose address is not informing the 'Region' field
-Add a product
-Pay and complete the transaction
-Go to backoffice
-Send the invoice just generated to SII
-Check that the SII process fails due to the region null value
Proposed SolutionIn the 'SII sending' process in the backoffice, check the customer's region, if it is empty, send the organization region instead. See image RegionOfTheStoreForSIISending (Organization window, tab "Information", "Location/Address" selector, Region" field).

Besides that, SII module needs also to implement a new check in the tab "Information" named "SII Location", so end-user can select one in case there are more than one locations for an Organization.

SII process will stop and give a warning to the user in those cases where:
* BP does not have a region
* Organization has more than one region, and none of them is set as SII Location

Warning message will "No region is found either for the customer or the organization. Please configure it either in the Business Partner window or in the Organization window, Information tab."

This new feature is going to be implemented only for sales invoices of type "Factura Simplificada" = Clave Tipo Factura.

Navigate to


TagsNOR
Attached Filesxls file icon DR_v1.1.xls [^] (156,160 bytes) 2021-09-23 10:27
png file icon ConsultaSII-FS.png [^] (193,595 bytes) 2021-09-23 10:28


xml file icon SPRI1000123_Envio1635863354334_FacturaSimplificada.xml [^] (1,607 bytes) 2021-11-02 15:31
xml file icon SPRI1000124_Envio1635863466492_FacturaCompleta.xml [^] (1,714 bytes) 2021-11-02 15:31
png file icon image.png [^] (95,467 bytes) 2021-11-15 15:46


jpg file icon RegionOfTheStoreForSIISending.JPG [^] (123,574 bytes) 2021-11-25 12:21

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0133211)
psanjuan (manager)
2021-11-19 09:39
edited on: 2021-11-19 09:40

This issue needs to be rejected because SII does correct validations in regards to "Region" data, regardless this data (Region) does not need to be informed in SII. See below:

La validación se realiza previo al envío:
/* Check if an invoice can be sent to SII.
// Check Spanish region code from partner address
SIIUtils.invoicePreviousValidations(AEATSIIConfig, Invoice, String)
donde efectivamente, genera error si el país es "España" y la región de la dirección del tercero asociada a la factura está vacía:
image.png


Luego se utiliza esta región para comprobar si una "Factura (Proveedor)" de compra de importación es una factura con IVA diferido:
/* Checks if an import purchase invoice is deferred VAT invoice
SIIUtils.isDeferredVATInvoice(Invoice)
Donde, si el país es España, y el código de la región es "35" (Las Palmas) o "38" (Santa Cruz de Tenerife) o "51" (Ceuta) o "52" (Melilla), entonces devuelve Verdadero.

En "Factura (Cliente)" también se revisa la región:
SIISOAPUtils.createFacturaExpedida(SOAPElement, Invoice)
// Venta Canarias, Ceuta y Melilla
Si la Región es "35" (Las Palmas) o "38" (Santa Cruz de Tenerife) o "51" (Ceuta) o "52" (Melilla), entonces agrega "DesgloseFactura", sino, sigue consultando otros datos (ya no la Región), para volver a decidir si agregar "DesgloseFactura" o "DesgloseTipoOperación", chequeando varias otras condiciones en varias otras bifurcaciones.

(0133514)
psanjuan (manager)
2021-12-07 13:40

Issue re-opened as we need to provide a solution for those cases where BP do not have an address, in particular a region. See proposed solution.

- Issue History
Date Modified Username Field Change
2021-09-22 15:24 ucarrion New Issue
2021-09-22 15:24 ucarrion Assigned To => Jorge Bravo
2021-09-22 15:25 ucarrion Issue Monitored: rafaroda
2021-09-22 15:25 ucarrion Issue Monitored: avicente
2021-09-22 15:25 ucarrion Issue Monitored: psanjuan
2021-09-22 15:26 ucarrion Tag Attached: NOR
2021-09-23 10:25 psanjuan Proposed Solution updated
2021-09-23 10:26 psanjuan Proposed Solution updated
2021-09-23 10:27 psanjuan File Added: DR_v1.1.xls
2021-09-23 10:28 psanjuan File Added: ConsultaSII-FS.png
2021-09-23 10:46 Jorge Bravo Assigned To Jorge Bravo => juabaez
2021-11-02 15:31 psanjuan File Added: SPRI1000123_Envio1635863354334_FacturaSimplificada.xml
2021-11-02 15:31 psanjuan File Added: SPRI1000124_Envio1635863466492_FacturaCompleta.xml
2021-11-15 15:46 psanjuan File Added: image.png
2021-11-15 15:46 psanjuan Proposed Solution updated
2021-11-19 09:39 psanjuan Note Added: 0133211
2021-11-19 09:40 psanjuan Note Edited: 0133211 View Revisions
2021-11-19 09:41 Jorge Bravo Assigned To juabaez => psanjuan
2021-11-19 09:41 psanjuan Status new => closed
2021-11-19 09:41 psanjuan Resolution open => no change required
2021-11-25 12:18 avicente Status closed => new
2021-11-25 12:18 avicente Resolution no change required => open
2021-11-25 12:18 avicente Proposed Solution updated
2021-11-25 12:20 avicente Proposed Solution updated
2021-11-25 12:21 avicente File Added: RegionOfTheStoreForSIISending.JPG
2021-11-25 12:21 avicente Proposed Solution updated
2021-11-25 12:32 psanjuan Proposed Solution updated
2021-11-25 12:33 psanjuan Proposed Solution updated
2021-11-25 12:35 psanjuan Proposed Solution updated
2021-12-07 13:40 psanjuan Note Added: 0133514
2021-12-07 13:45 psanjuan Proposed Solution updated
2021-12-07 13:50 psanjuan Proposed Solution updated


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker