Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0046565
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[POS2] POSmajoralways2021-05-06 17:392021-06-16 11:48
ReporterjmelinView Statuspublic 
Assigned Tohernan-dp 
PrioritynormalResolutionopenFixed in Version
StatusscheduledFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSLinux 64 bitDatabasePostgreSQLJava version7.x
OS VersionOpenbravo Appliance 14.04Database version9.3.xAnt version1.9.x
Product VersionSCM revision 
Review Assigned To
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0046565: JIRA 1615 - Default keymap category not selected after terminating an order

DescriptionAfter an order is done, the POS should display the category selected as default.
Steps To Reproduce    Pre-requisites:
Define keymap
Define a keymap category and a default category for each keymap (not the 1st one)

Steps:
1. Connect to POS
2. Switch to a schema where the default category is not show on the first page
=> the default category is not displayed in the first page

3. Add a product from a non-default category
4. Finish the order
=> after the sales order is completed, it must go back to the default category of the keymap, but remains on the latest selected instead

5. Log out
6. Log in
=> the default schema/default category must be selected , but it's the latest used instead

=> the POS display the latest selected category instead of default one
TagsTakeaway
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0046806TAP scheduledhernan-dp JIRA 1615 - Default keymap category not selected after terminating an order 
has duplicate defect 0046939 closedgorka_gil JIRA 1950 - Default keymap category not selected 
Not all the children of this issue are yet resolved or closed.

-  Notes
(0128553)
jmelin (developer)
2021-05-24 11:16

I challenge the customer about this issue and I told me that if it's not blocking, it's important because it may disturb the cashier.
This is the current behavior on their POS today
(0128955)
hgbot (developer)
2021-06-02 16:26

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2/-/merge_requests/516 [^]
(0129090)
hgbot (developer)
2021-06-05 11:32

Directly closing issue as related merge request is already approved.

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2 [^]
Changeset: 37ac076384c163053182156722f75c073235a07b
Author: hernan-dp <h.de.prada1@gmail.com>
Date: 2021-06-05T11:29:51+02:00
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2/-/commit/37ac076384c163053182156722f75c073235a07b [^]

fixed ISSUE-46565: Respect default category after complete ticket and respected default schema after logout or refresh.

---
M web-jspack/org.openbravo.pos2/src/authentication/loginInitActions.js
M web-jspack/org.openbravo.pos2/src/components/Payments/PaymentKeypad/__test__/PaymentKeypad.test.jsx
M web-jspack/org.openbravo.pos2/src/components/ProductCategoryKeymap/SetDefaultKeymapCategoryId.js
M web-jspack/org.openbravo.pos2/src/model/ticket/__test__/CompleteTicket.test.js
M web-jspack/org.openbravo.pos2/src/model/ticket/user-actions/CompleteTicket.js
M web-jspack/org.openbravo.pos2/src/model/user-interface/actions/SetSelectedKeymapCategory.js
---
(0129091)
hgbot (developer)
2021-06-05 11:32

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.pos2/-/merge_requests/516 [^]
(0129483)
jmelin (developer)
2021-06-14 17:35

The keymap is going back to the defaut category, but the first page of the keymap caroussel is displayed
It should move to the page where the default category is.

- Issue History
Date Modified Username Field Change
2021-05-06 17:39 jmelin New Issue
2021-05-06 17:39 jmelin Assigned To => Retail
2021-05-06 17:39 jmelin Triggers an Emergency Pack => No
2021-05-06 17:39 jmelin Tag Attached: Takeaway
2021-05-07 11:15 jmelin Severity minor => major
2021-05-07 11:17 guilleaer Severity major => minor
2021-05-07 11:18 guilleaer Status new => acknowledged
2021-05-24 11:16 jmelin Note Added: 0128553
2021-05-24 11:16 jmelin Severity minor => major
2021-05-24 12:44 guilleaer Status acknowledged => scheduled
2021-05-24 12:44 guilleaer Status scheduled => acknowledged
2021-05-27 12:37 hernan-dp Assigned To Retail => hernan-dp
2021-05-27 12:38 hernan-dp Status acknowledged => scheduled
2021-05-27 14:45 hernan-dp Note Added: 0128719
2021-06-02 16:26 hgbot Note Added: 0128955
2021-06-02 18:21 AugustoMauch Relationship added has duplicate 0046939
2021-06-02 18:23 AugustoMauch Steps to Reproduce Updated View Revisions
2021-06-05 00:56 guilleaer Note Deleted: 0128719
2021-06-05 11:32 hgbot Resolution open => fixed
2021-06-05 11:32 hgbot Status scheduled => closed
2021-06-05 11:32 hgbot Note Added: 0129090
2021-06-05 11:32 hgbot Note Added: 0129091
2021-06-14 17:35 jmelin Note Added: 0129483
2021-06-14 17:35 jmelin Status closed => new
2021-06-14 17:35 jmelin Resolution fixed => open
2021-06-16 11:48 dmiguelez Status new => scheduled


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker