Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0044419
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2020-06-18 18:152020-07-02 18:59
ReporteraaroncaleroView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityhighResolutionfixedFixed in VersionRR20Q3
StatusclosedFix in branchFixed in SCM revision56a04dc775ee
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0044419: It is possible to generate deleted tickets without orderType, which in turn generate Errors While Importing

DescriptionWhen the Save Deleted Tickets preference is configured, it is possible under specific circumstances to generate tickets without orderType. If these tickets are removed from WebPOS, a record is created in the Errors While Importing POS Data window.
Steps To ReproduceLog in Backend, go to the Preference window and make sure the preference WebPOS Save Removed Tickets is defined with value Y
Log in WebPOS
Create a new ticket
Go to the Menu > Layaway This Receipt.
Add some products to the ticket
Go to the Menu > Pay Open Tickets
Search and select the currently opened layaway and click on Done
Once in the Pay Open Tickets window, refresh the page.
After loading the page, close the Pay Open Tickets screen. Verify that the Layaway label is still present in the normal POS screen.
Refresh the page again.
After loading, verify that the Layaway label is gone.
Check in the browser console that the current ticket is missing its orderType.
Remove the ticket.
Check in Backend that a new record has been created in the Errors While Importing POS Data window.
Proposed SolutionIt seems that reloading the screen while in the Pay Open Tickets window removes some attributes from the order model stored in websql. This issue has been raised because the orderType is checked in the OrderLoader process, but some other fields might be missing too.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0121225)
hgbot (developer)
2020-07-02 13:33

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 56a04dc775ee7e4bdadccc291dd236de506783a4
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Thu Jul 02 17:03:05 2020 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/56a04dc775ee7e4bdadccc291dd236de506783a4 [^]

Fixed issue-44419: MultiOrder attributes should be updated when opening pay open tickets

* When opening pay open tickets or reloading pay open tickets,
  receipt attributes belongsToMultiOrder, originalOrderType should be retained

---
M web/org.openbravo.retail.posterminal/js/components/order.js
M web/org.openbravo.retail.posterminal/js/pointofsale/model/pointofsale-model.js
M web/org.openbravo.retail.posterminal/js/pointofsale/view/pointofsale.js
---

- Issue History
Date Modified Username Field Change
2020-06-18 18:15 aaroncalero New Issue
2020-06-18 18:15 aaroncalero Assigned To => Retail
2020-06-18 18:15 aaroncalero Triggers an Emergency Pack => No
2020-06-26 08:43 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2020-07-02 13:26 ranjith_qualiantech_com Status new => scheduled
2020-07-02 13:33 hgbot Checkin
2020-07-02 13:33 hgbot Note Added: 0121225
2020-07-02 13:33 hgbot Status scheduled => resolved
2020-07-02 13:33 hgbot Resolution open => fixed
2020-07-02 13:33 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/56a04dc775ee7e4bdadccc291dd236de506783a4 [^]
2020-07-02 18:59 marvintm Review Assigned To => marvintm
2020-07-02 18:59 marvintm Status resolved => closed
2020-07-02 18:59 marvintm Fixed in Version => RR20Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker