Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0044345
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajorhave not tried2020-06-11 12:102020-07-08 12:16
Reporterjorge-garciaView Statuspublic 
Assigned Toranjith_qualiantech_com 
PrioritynormalResolutionfixedFixed in VersionRR20Q4
StatusclosedFix in branchFixed in SCM revisionc6b41d47c61f
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0044345: If a OBPOS_LoadPOSWindow hook is executed after the registered hook of sessions, WebPOS could navigate to pointofsale window

DescriptionSessions hook could navigate directly to point of sale window before all OBPOS_LoadPOSWindow has been executed.

This may cause random problem in the code.
Steps To Reproduce1) Using a enviromnet with sessions module, login in ERP
2) Go to VBS-1 record in Touchpoint window and navigate to its Touchpoint Type window
3) Go through each Payment Method and uncheck checkbox of Initial Count Cash

4) Go to WebPOs VBS-1 and before do login in, introduce this code using developers tools
  OB.UTIL.HookManager.registerHook('OBPOS_LoadPOSWindow', function (
    args,
    callbacks
  ) {
    setTimeout(function () {
      OB.UTIL.showConfirmation.display(
        'Interrupt popup',
        'This popup is shown in top of good job popup',
        [
          {
            label: OB.I18N.getLabel('OBMOBC_LblOk'),
            isConfirmButton: true,
            action: function () {
              OB.UTIL.HookManager.callbackExecutor(args, callbacks);
            }
          }
        ]
      );
    }, 1000);
  });
5) Now, login in WebPOS
6) Notice that no initial count cash is needed but for a second the good job popup is shown. After that, our new popup is shown in top of it.
7) Click on OK button and verify WebPOS is stuck in showLoading window.
8) Refresh the webPOS and try to do login and check nothing is happening
Proposed SolutionAt step 8, the webPOS thinks that the webPOs is still loging in an does not allow to do again the login (this could be check in console of chrome).
The problem is at this point of the code https://code.openbravo.com/erp/pmods/org.openbravo.retail.sessions/file/tip/web/org.openbravo.retail.sessions/js/countcash/countcash-model.js#l97 [^]

The callback (which is the hook callback) is launched and the good job popup is shown. The ok button initiates the navigation to webPOS. As this popup is override by the confirmation popup, the logic thinks the login process is still ongoing.

The solution is to avoid sessions hook to initiate the navigation and let the OBPOS_LoadPOSWindow hook callback to initiate the naviagtion.

An partial diff to avoid this kind of problems could be check here:
https://gitlab.com/obcustomers/DKTFR/org.openbravo.retail.sessions-fr-dev/-/commit/e83b97a5bdec6dd1a3b6780e6b86fd66f858786c [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0121324)
hgbot (developer)
2020-07-08 11:50

Repository: erp/pmods/org.openbravo.retail.sessions
Changeset: c6b41d47c61f4e4a86332b4078f8f9487302376d
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Wed Jul 08 15:20:39 2020 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.sessions/rev/c6b41d47c61f4e4a86332b4078f8f9487302376d [^]

Fixed issue-44345: LoadPOSWindow hook should be called after opentill popup closed

* In the LoadPOSWindow hook, OpenTill process will be started.
  hook callback should be called only when GoodJob popup of OpenTill completion process

---
M web/org.openbravo.retail.sessions/js/components/BusinessDateModel.js
M web/org.openbravo.retail.sessions/js/components/loginhook.js
M web/org.openbravo.retail.sessions/js/countcash/countcash-model.js
---

- Issue History
Date Modified Username Field Change
2020-06-11 12:10 jorge-garcia New Issue
2020-06-11 12:10 jorge-garcia Assigned To => Retail
2020-06-11 12:10 jorge-garcia Triggers an Emergency Pack => No
2020-06-16 14:08 jorge-garcia Relationship added related to 0044244
2020-06-24 08:12 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2020-07-01 07:59 ranjith_qualiantech_com Status new => scheduled
2020-07-08 11:50 hgbot Checkin
2020-07-08 11:50 hgbot Note Added: 0121324
2020-07-08 11:50 hgbot Status scheduled => resolved
2020-07-08 11:50 hgbot Resolution open => fixed
2020-07-08 11:50 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.sessions/rev/c6b41d47c61f4e4a86332b4078f8f9487302376d [^]
2020-07-08 12:16 marvintm Review Assigned To => marvintm
2020-07-08 12:16 marvintm Status resolved => closed
2020-07-08 12:16 marvintm Fixed in Version => RR20Q4


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker