Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0044255
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2020-06-01 16:542020-06-10 18:02
ReportermaiteView Statuspublic 
Assigned Toinigo_lerga 
PriorityurgentResolutionfixedFixed in VersionPR20Q3
StatusclosedFix in branchFixed in SCM revisionf97f1e168b23
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2019-06-05
Regression introduced in release3.0PR19Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/d9535ca2cfdf [^]
Triggers an Emergency PackNo
Summary

0044255: Wrong posting in Settled Remittance Lines: cashvat information not generated when it should

DescriptionAs part of this issue (https://issues.openbravo.com/view.php?id=33973 [^]), new column ISPAIDATINVOICING is included in fin_payment_detail table. This column is not initialized so existent documents have it set to NULL

However, the "setInvoiceTaxCashVAT_V" method is only considering details having this column to FALSE (hql.append(" and itcv." + InvoiceTaxCashVAT_V.PROPERTY_ISPAIDATINVOICING + " = false");). So existent elements are not generating CASH VAT posting
Steps To Reproduce0. Environment older than 19Q3 (where ISPAIDATINVOICING does not exists)
1. Create CASH VAT sales invoice. Process and post it
2. Include this invoice in a remittance. Process and post it
3. Run Settle process to the previous remittance line
4. Upgrade environment to version >=19Q3
5. Access to settled the element and post it. Realize that CASH VAT accounting is NOT generated when it should
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0044336PR20Q2.1 closedinigo_lerga Openbravo ERP Wrong posting in Settled Remittance Lines: cashvat information not generated when it should 
depends on backport 0044337PR20Q1.3 closedinigo_lerga Openbravo ERP Wrong posting in Settled Remittance Lines: cashvat information not generated when it should 
caused by feature request 0033973 closedgorka_gil Retail Modules Handling Cash VAT Management during the creation of Orders or Invoices from POS 

-  Notes
(0120724)
inigo_lerga (developer)
2020-06-08 10:43

--Test Plan Mantis HQL--
Openbravo 19Q2 version is the one that needs to be installed.
Beforehand, the environment needs to have Remittance (3.2.5102) and Cash VAT
(1.3.0) modules installed. Also Remittance dataset applied (via Client
Administrator in Enterprise Module Management window).

As the F&B International Group Admin role in Backend:
  - Go to Organization window and open F&B US, Inc.
    Open Information Tab's record and enable Cash VAT.
    Save the record.
  - Go to Tax Rate window and open "CA Sales Tax" record.
    Enable Cash VAT in "More Information" section.
    Go to Accounting Tab and open "F&B International Group US/A"
    record. Select any Tax Due Transitory account and
    Tax Credit Transitory.
    Save the record
  - Go to Financial Account window and open "Bank - Account 1".
    Go to Payment Method Tab and add Remittance as a Payment Method.
    Save the record.
  - Go to Remittance Type window and open Printable Remittance.
    Go to Accounting Tab and create a new record with "*" as Organization
    and "F&B International Group US/A/US Dollar" as General Ledger.
    Set any desired Settlement Account and Sent Account.
    Save the record.
  - Go to Sales Invoice window and create a new record for
    F&B US, Inc. Organization. Set "Healthy Food Supermarkets, Co."
    as Business Partner.
    Set Remittance as Payment Method.
    Go to Lines Tab and create a record with 1 unit of Ale Beer using
    "CA Sales Tax" as Tax rate.
    Save, process and post the Sales Invoice.
  - Go to Remittance window and create a new record with any name desired
    and "Bank - Account 1 - USD" as Financial Account. Set Expected dataset
    at least one month later than the Invoice Date of the previous Sales Invoice.
    Press the Select Orders or Invoices button and choose the record from
    the previous Sales Invoice.
    Save, process and post the Remittance.
  - Go to Settle / Protest Remittances window, find and select the one for F&B US, Inc
    and set as Accounting Date in two days from today.

#UPGRADE ENVIRONMENT VERSION TO 19Q3 OR ABOVE#

As the F&B International Group Admin role in Backend:
  - Go to Remittance window and open the previously created record.
    Go to Settle Tab and select the only record. Unpost it deleting the Accounting
    record. Post it again.

Realize that CASH VAT accounting is now generated.
(0120789)
hgbot (developer)
2020-06-10 17:48

Repository: erp/devel/pi
Changeset: f97f1e168b23261b99ea33322ad122e60c56b691
Author: IƱigo Lerga <inigo.lerga <at> openbravo.com>
Date: Tue Jun 09 18:15:47 2020 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f97f1e168b23261b99ea33322ad122e60c56b691 [^]

Fixes ISSUE-44255: New column ISPAIDATINVOICING now takes
into account null as a possible value in the query in
charge of calculating the linked InvoiceTaxCashVAT_V
records and adding them to the invoiceTaxCashVAT_V list associated.

---
M src/org/openbravo/erpCommon/ad_forms/DocLineCashVATReady_PaymentTransactionReconciliation.java
---
(0120794)
dmiguelez (developer)
2020-06-10 18:02

Code Review + Testing Ok

- Issue History
Date Modified Username Field Change
2020-06-01 16:54 maite New Issue
2020-06-01 16:54 maite Assigned To => Triage Finance
2020-06-01 16:54 maite Modules => Core
2020-06-01 16:54 maite Triggers an Emergency Pack => No
2020-06-01 16:55 maite Relationship added caused by 0033973
2020-06-01 17:07 Practics Issue Monitored: Practics
2020-06-02 13:58 inigo_lerga Assigned To Triage Finance => inigo_lerga
2020-06-02 13:58 inigo_lerga Status new => scheduled
2020-06-08 10:43 inigo_lerga Note Added: 0120724
2020-06-10 17:48 hgbot Checkin
2020-06-10 17:48 hgbot Note Added: 0120789
2020-06-10 17:48 hgbot Status scheduled => resolved
2020-06-10 17:48 hgbot Resolution open => fixed
2020-06-10 17:48 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/f97f1e168b23261b99ea33322ad122e60c56b691 [^]
2020-06-10 17:50 dmiguelez Status resolved => new
2020-06-10 17:50 dmiguelez Resolution fixed => open
2020-06-10 17:51 dmiguelez Status new => scheduled
2020-06-10 17:52 dmiguelez Status scheduled => resolved
2020-06-10 17:52 dmiguelez Resolution open => fixed
2020-06-10 17:56 dmiguelez Regression level => Production - Confirmed Stable
2020-06-10 17:56 dmiguelez Regression date => 2019-06-05
2020-06-10 17:56 dmiguelez Regression introduced in release => 3.0PR19Q3
2020-06-10 17:56 dmiguelez Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/d9535ca2cfdf [^]
2020-06-10 18:02 dmiguelez Review Assigned To => dmiguelez
2020-06-10 18:02 dmiguelez Note Added: 0120794
2020-06-10 18:02 dmiguelez Status resolved => closed
2020-06-10 18:02 dmiguelez Fixed in Version => 3.0PR20Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker