Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0042597
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajorsometimes2019-12-18 14:132020-10-20 07:25
Reportergorka_gilView Statuspublic 
Assigned Toranjith_qualiantech_com 
PrioritynormalResolutionfixedFixed in VersionRR21Q1
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0042597: After click on login, returns for one second to login page

DescriptionSometimes after click on login, returns for one second to login page, and later continues normally with the login
Steps To ReproduceIn Both Pack/Module instance
Load POS
Lock POS
Change JS resource
Restart Tomcat / Or Clean Published Resource
POS - Do Login
Loading Screen will be displayed - OK
Login Screen will be displayed - KO
Loading Screen will be displayed - OK
TagsNo tags attached.
Attached Files? file icon 42597-login-error.webm [^] (268,764 bytes) 2019-12-18 14:14
patch file icon 42597_19Q3_mobilecore.patch [^] (6,352 bytes) 2020-10-20 07:25 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0122803)
marvintm (developer)
2020-09-08 15:02

Not reproducible in pi, reproducible in old versions
(0123745)
hgbot (developer)
2020-10-16 12:49

Merge Request created: https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core/-/merge_requests/86 [^]
(0123756)
hgbot (developer)
2020-10-19 07:23

Merge request merged: https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core/-/merge_requests/86 [^]
(0123757)
hgbot (developer)
2020-10-19 07:23

Directly closing issue as related merge request is already approved.

Repository: https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core [^]
Changeset: 1e1a3b7f2ddfd32590bcca44471894210e34ceca
Author: Ranjith S R <ranjith@qualiantech.com>
Date: 2020-10-19T05:23:49+00:00
URL: https://gitlab.com/openbravo/product/pmods/org.openbravo.mobile.core/-/commit/1e1a3b7f2ddfd32590bcca44471894210e34ceca [^]

Fixed ISSUE-42597: Refactored Fetch Manifest to add/remove EventListeners
* When CacheManifest is modified when doing login/reload, Service Worker EventListener should be removed and added again

---
M web/org.openbravo.mobile.core/source/offline/ob-fetch-manifest.js
---

- Issue History
Date Modified Username Field Change
2019-12-18 14:13 gorka_gil New Issue
2019-12-18 14:13 gorka_gil Assigned To => Retail
2019-12-18 14:13 gorka_gil Triggers an Emergency Pack => No
2019-12-18 14:14 gorka_gil File Added: 42597-login-error.webm
2019-12-20 04:28 rqueralta Assigned To Retail => rqueralta
2019-12-20 04:28 rqueralta Status new => scheduled
2020-08-24 07:26 marvintm Assigned To rqueralta => Retail
2020-09-02 07:09 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2020-09-08 15:02 marvintm Review Assigned To => marvintm
2020-09-08 15:02 marvintm Note Added: 0122803
2020-09-08 15:02 marvintm Status scheduled => closed
2020-09-08 15:02 marvintm Resolution open => unable to reproduce
2020-10-16 06:50 ranjith_qualiantech_com Status closed => new
2020-10-16 06:50 ranjith_qualiantech_com Resolution unable to reproduce => open
2020-10-16 10:22 ranjith_qualiantech_com Summary Sometimes after click on login, returns for one second to login page => After click on login, returns for one second to login page
2020-10-16 10:22 ranjith_qualiantech_com Steps to Reproduce Updated View Revisions
2020-10-16 10:22 ranjith_qualiantech_com Status new => scheduled
2020-10-16 10:26 ranjith_qualiantech_com Steps to Reproduce Updated View Revisions
2020-10-16 12:49 hgbot Note Added: 0123745
2020-10-19 07:23 hgbot Resolution open => fixed
2020-10-19 07:23 hgbot Status scheduled => closed
2020-10-19 07:23 hgbot Note Added: 0123756
2020-10-19 07:23 hgbot Fixed in Version => RR21Q1
2020-10-19 07:23 hgbot Note Added: 0123757
2020-10-20 07:25 ranjith_qualiantech_com File Added: 42597_19Q3_mobilecore.patch


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker