Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0041046
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Retail Modules] Web POSmajoralways2019-05-07 18:572019-07-17 15:54
ReporterbarbararoncatoView Statuspublic 
Assigned Torqueralta 
PrioritynormalResolutionfixedFixed in VersionRR19Q2.1
StatusclosedFix in branchFixed in SCM revision769d4ccf0ccd
ProjectionnoneETAnoneTarget VersionRR19Q2.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0041046: Deferred service not invoiced.

DescriptionDeferred service not invoiced.
Steps To ReproduceSteps to reproduce:
1. Log into webPOS
2. Add a cliente with Invoice Terms = After Order Delivery
3. Select option "Layaway this receipt"
4. Add a product with stock and delivery condition = Pick and Carry
5. Click on the total amount and layaway the receipt
--- In backend, the layaway has qty delivered = 0 and qty invoiced = 0.
6. Go to webPOS again and open the layaway.
7. Add a deferred service and pay it totally.
--- In backend, the order with the service has qty delivered = 0 and qty invoiced = 0.
8. Go to webPOS again, open the layaway from step 5 and pay it totally.
--- In backend, the layaway now has qty delivered = 1 and qty invoiced = 1 the order with the service has qty delivered = 1 and qty invoiced = 0.


Order: https://drive.google.com/open?id=1HSQeFUefnkc-wIC-3w27dKmnLkEkRhxy [^]
Service: https://drive.google.com/open?id=1K5EpeOcnbQn9IiVZB845EAJyJWHR6eml [^]
Proposed SolutionSolution set in the attached file
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0040805 closedrqueralta Deferred service not invoiced. 

-  Notes
(0112949)
hgbot (developer)
2019-06-21 18:13

Repository: retail/backports/3.0RR19Q2.1/org.openbravo.retail.posterminal
Changeset: 769d4ccf0ccd6cdbd6e529acd44b2460f719603c
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Fri Jun 21 12:12:53 2019 -0400
URL: http://code.openbravo.com/retail/backports/3.0RR19Q2.1/org.openbravo.retail.posterminal/rev/769d4ccf0ccd6cdbd6e529acd44b2460f719603c [^]

Fixed issue 41046: The deferred service can generate the invoice now

When a deferred service is delivered due to an order loader hook, the invoice is not created in the case that should. Now, it will be possible to load again that order in the Web POS and synchronize it again creating the invoice for the deferred service lines.

---
M web/org.openbravo.retail.posterminal/js/model/order.js
---
(0113299)
hgbot (developer)
2019-07-11 18:51

Repository: retail/backports/3.0RR19Q2.1/org.openbravo.retail.posterminal
Changeset: f0815bcc86b3c459f532946954a85832db2b0864
Author: Gorka Gil <gorka.gil <at> openbravo.com>
Date: Tue Jun 25 12:24:13 2019 +0200
URL: http://code.openbravo.com/retail/backports/3.0RR19Q2.1/org.openbravo.retail.posterminal/rev/f0815bcc86b3c459f532946954a85832db2b0864 [^]

Related to issue 41046: fix js formater

---
M web/org.openbravo.retail.posterminal/js/model/order.js
---
(0113382)
hgbot (developer)
2019-07-15 17:47

Repository: retail/backports/3.0RR19Q2.1/pi-mobile
Changeset: 65742df92e59f210282168e2a80d4764153d2c7b
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Thu Jun 06 14:24:01 2019 -0400
URL: http://code.openbravo.com/retail/backports/3.0RR19Q2.1/pi-mobile/rev/65742df92e59f210282168e2a80d4764153d2c7b [^]

Related to issue 41046: The deferred service can generate the invoice now

- Changed the expected invoice quantity beacuse the layaway ticket is not invoiced

---
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/prepaymentsAndInvoiceTerms/ImmediatePayOpenTicketsPrepaymentAmountLayaway280.java
---

- Issue History
Date Modified Username Field Change
2019-06-06 20:29 marvintm Type defect => backport
2019-06-06 20:29 marvintm Target Version => RR19Q2.1
2019-06-21 18:13 hgbot Checkin
2019-06-21 18:13 hgbot Note Added: 0112949
2019-06-21 18:13 hgbot Status scheduled => resolved
2019-06-21 18:13 hgbot Resolution open => fixed
2019-06-21 18:13 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e06363a486fc092bdca7210773ff4db6ba5f3bb8 [^] => http://code.openbravo.com/retail/backports/3.0RR19Q2.1/org.openbravo.retail.posterminal/rev/769d4ccf0ccd6cdbd6e529acd44b2460f719603c [^]
2019-07-11 18:51 hgbot Checkin
2019-07-11 18:51 hgbot Note Added: 0113299
2019-07-15 17:47 hgbot Checkin
2019-07-15 17:47 hgbot Note Added: 0113382
2019-07-17 15:54 guilleaer Review Assigned To => guilleaer
2019-07-17 15:54 guilleaer Status resolved => closed
2019-07-17 15:54 guilleaer Fixed in Version => RR19Q2.1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker