Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040827
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2019-05-09 15:482019-05-21 15:17
ReporteralostaleView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q3
StatusclosedFix in branchFixed in SCM revision9c2b642b9342
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version12+
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040827: JDK 12: cannot start application due to Weld error

DescriptionWhen trying to start Openbravo using JDK 12 or higher, an error is thrown.

This is caused by Weld issue 2572 [1].

---
[1] https://issues.jboss.org/browse/WELD-2572 [^]
Steps To ReproduceUsing JDK 12 try to start Tomcat

Caused by: org.jboss.weld.exceptions.WeldException: WELD-001524: Unable to load proxy class for bean Implicit Bean [javax.enterprise.event.Event] with qualifiers [@Default] with class interface javax.enterprise.event.Event
    at org.jboss.weld.bean.proxy.ProxyFactory.getProxyClass(ProxyFactory.java:378)
    at org.jboss.weld.bean.builtin.AbstractFacadeBean.initializeAfterBeanDiscovery(AbstractFacadeBean.java:61)
    at org.jboss.weld.bootstrap.ConcurrentBeanDeployer$AfterBeanDiscoveryInitializerFactory.doWork(ConcurrentBeanDeployer.java:111)
    at org.jboss.weld.bootstrap.ConcurrentBeanDeployer$AfterBeanDiscoveryInitializerFactory.doWork(ConcurrentBeanDeployer.java:102)
    at org.jboss.weld.executor.IterativeWorkerTaskFactory$1.call(IterativeWorkerTaskFactory.java:62)
    at org.jboss.weld.executor.IterativeWorkerTaskFactory$1.call(IterativeWorkerTaskFactory.java:55)
    ... 4 more
Caused by: java.lang.Error: java.lang.NoSuchFieldException: override
    at org.jboss.classfilewriter.ClassFile$1.run(ClassFile.java:394)
    at org.jboss.classfilewriter.ClassFile$1.run(ClassFile.java:385)
    at java.base/java.security.AccessController.doPrivileged(AccessController.java:551)
    at org.jboss.classfilewriter.ClassFile.<clinit>(ClassFile.java:385)
    at org.jboss.weld.bean.proxy.ProxyFactory.newClassFile(ProxyFactory.java:494)
    at org.jboss.weld.bean.proxy.ProxyFactory.createProxyClass(ProxyFactory.java:444)
    at org.jboss.weld.bean.proxy.ProxyFactory.getProxyClass(ProxyFactory.java:370)
    ... 9 more
Caused by: java.lang.NoSuchFieldException: override
    at java.base/java.lang.Class.getDeclaredField(Class.java:2417)
    at org.jboss.classfilewriter.ClassFile$1.run(ClassFile.java:392)
    ... 15 more
Proposed SolutionUpdate Weld to at least 3.1.1 which fixes the issue.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0040193 closedcaristu upgrade Weld to version 3.1.0.Final 
related to design defect 0040840 acknowledgedplatform Illegal Access warning in weld-core-impl-3.1.1.Final.jar using JDK12+ 
blocks feature request 0040826 acknowledgedplatform support JDK 12 and JDK 13 

-  Notes
(0111637)
hgbot (developer)
2019-05-13 09:29

Repository: erp/devel/pi
Changeset: 9c2b642b9342b02921a2c306c7b82839acd70924
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon May 13 09:10:41 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/9c2b642b9342b02921a2c306c7b82839acd70924 [^]

fixes issue 40827: update weld to version 3.1.1

  Update Weld to version 3.1.1 which contains the fix[1] for the issue that causes Tomcat not correctly start using JDK 12.

  [1] https://issues.jboss.org/browse/WELD-2572 [^]

---
M legal/Licensing.txt
A modules/org.openbravo.base.weld/lib/runtime/jboss-classfilewriter-1.2.4.Final.jar
A modules/org.openbravo.base.weld/lib/runtime/weld-core-impl-3.1.1.Final.jar
A modules/org.openbravo.base.weld/lib/runtime/weld-environment-common-3.1.1.Final.jar
A modules/org.openbravo.base.weld/lib/runtime/weld-jsf-3.1.1.Final.jar
A modules/org.openbravo.base.weld/lib/runtime/weld-servlet-core-3.1.1.Final.jar
A modules/org.openbravo.base.weld/lib/runtime/weld-web-3.1.1.Final.jar
R modules/org.openbravo.base.weld/lib/runtime/jboss-classfilewriter-1.2.3.Final.jar
R modules/org.openbravo.base.weld/lib/runtime/weld-core-impl-3.1.0.Final.jar
R modules/org.openbravo.base.weld/lib/runtime/weld-environment-common-3.1.0.Final.jar
R modules/org.openbravo.base.weld/lib/runtime/weld-jsf-3.1.0.Final.jar
R modules/org.openbravo.base.weld/lib/runtime/weld-servlet-core-3.1.0.Final.jar
R modules/org.openbravo.base.weld/lib/runtime/weld-web-3.1.0.Final.jar
---
(0111761)
alostale (developer)
2019-05-17 09:08

tested with jdk 12.0.1+12 and 13-ea+21
(0112026)
hudsonbot (developer)
2019-05-21 15:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9b8f37d9d85e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-05-09 15:48 alostale New Issue
2019-05-09 15:48 alostale Assigned To => platform
2019-05-09 15:48 alostale Modules => Core
2019-05-09 15:48 alostale Triggers an Emergency Pack => No
2019-05-09 15:48 alostale Relationship added related to 0040193
2019-05-09 15:49 alostale Relationship added blocks 0040826
2019-05-09 16:32 shuehner Issue Monitored: shuehner
2019-05-09 19:15 caristu Assigned To platform => caristu
2019-05-10 15:00 caristu Relationship added related to 0040840
2019-05-13 09:29 hgbot Checkin
2019-05-13 09:29 hgbot Note Added: 0111637
2019-05-13 09:29 hgbot Status new => resolved
2019-05-13 09:29 hgbot Resolution open => fixed
2019-05-13 09:29 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/9c2b642b9342b02921a2c306c7b82839acd70924 [^]
2019-05-13 12:54 caristu Review Assigned To => alostale
2019-05-17 09:08 alostale Note Added: 0111761
2019-05-17 09:08 alostale Status resolved => closed
2019-05-17 09:08 alostale Fixed in Version => 3.0PR19Q3
2019-05-21 15:17 hudsonbot Checkin
2019-05-21 15:17 hudsonbot Note Added: 0112026


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker