Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040648
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Retail Modules] StoreServermajorhave not tried2019-04-18 16:172019-06-10 17:49
ReportermtaalView Statuspublic 
Assigned Tomtaal 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision6b962954112a
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040648: Make the store server more sensitive to overloaded cs

Descriptionwhen processing a request the ss should be more sensitive to the cs being overloaded.

Proposal:
- when 3 (max retries will be configurable) read time outs occur on a functional request the ss goes offline
- the timeout will be configurable in seconds (currently it is in minutes)
- every time a time out exception occurs the system will increase the time out wait time, so first time is 1*pref_value, second try uses: 2*pref_value, third time 3*pref_value

For other non-read-time-out exceptions the logic will stay the same that the ss does an extra low-impact ping to the cs.
Steps To ReproduceCreate multi-server env
Put breakpoint for request coming from webpos
Do the action in webpos
See in the MobileServerRequestExecutor the requests times out
Proposed SolutionSee description
TagsNo tags attached.
Attached Filesdiff file icon new_diff_ss.diff [^] (27,338 bytes) 2019-06-05 04:16 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0040994 closedmtaal Store server transition to offline has too long wait time, uses an old preference and can be simplified 

-  Notes
(0111217)
hgbot (developer)
2019-04-22 06:29

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 0dbe7c99bb192978bbe1e81726f0c8a28d3929f2
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Mon Apr 22 06:29:38 2019 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/0dbe7c99bb192978bbe1e81726f0c8a28d3929f2 [^]

Fixes issue 40648: Make the store server more sensitive to overloaded cs
Go offline after all requests timeout

---
M src-db/database/sourcedata/AD_REF_LIST.xml
M src/org/openbravo/mobile/core/servercontroller/MobileServerRequestExecutor.java
---
(0111220)
hgbot (developer)
2019-04-22 22:35

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: b400a851872ad10780132431802a6339887ff5d8
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Mon Apr 22 22:33:49 2019 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/b400a851872ad10780132431802a6339887ff5d8 [^]

Related to issue 40648: Make the store server more sensitive to overloaded cs
Repair api change

---
M src/org/openbravo/mobile/core/servercontroller/MobileServerRequestExecutor.java
---
(0111221)
hgbot (developer)
2019-04-22 22:35

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 44189f9ba4538b6781cdfb1800b9afd6a7017ed2
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Mon Apr 22 22:34:25 2019 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/44189f9ba4538b6781cdfb1800b9afd6a7017ed2 [^]

Related to issue 40648: Make the store server more sensitive to overloaded cs
Updated copyright year

---
M src/org/openbravo/mobile/core/servercontroller/MobileServerRequestExecutor.java
---
(0111292)
AugustoMauch (developer)
2019-04-24 18:19

Code reviewed and verified
(0111515)
mtaal (manager)
2019-05-06 23:14

additional changes needed
(0111645)
AugustoMauch (developer)
2019-05-13 16:09

The new patch looks very, the only think that can be improved is the following message, that is a bit unclear:

// wait a while to not ping-pong between states
(0111694)
hgbot (developer)
2019-05-15 22:33

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: fd1bb5bbc8eee2b9a3340096a4f0f2620ee35c43
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Wed May 15 22:33:24 2019 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/fd1bb5bbc8eee2b9a3340096a4f0f2620ee35c43 [^]

Related to issue 40648: Make the store server more sensitive to overloaded cs

MobileMainServerCheck: do not ping cs on TOF status, go offline after certain wait time
MobileServerController: make logic to set transition timestamp public
MobileServerRequestExecutor: check cnt db errors and read time out errors, go offline if more than max retries found
do not check cs with ping anymore, cache the read time out preference only in case it was read not by a system user

---
M src/org/openbravo/mobile/core/servercontroller/MobileMainServerCheck.java
M src/org/openbravo/mobile/core/servercontroller/MobileServerController.java
M src/org/openbravo/mobile/core/servercontroller/MobileServerRequestExecutor.java
---
(0112140)
hgbot (developer)
2019-05-25 22:08

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 790dfcea17befe2e5b0b94b5d2487ef8fffa4a7c
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Sat May 25 12:08:31 2019 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/790dfcea17befe2e5b0b94b5d2487ef8fffa4a7c [^]

Fixes issue 40648: Make the store server more sensitive to overloaded cs
Changes:
CheckServerAvailability: check postgres connections
MobileMainServerCheck: simplify transition to offline to only wait
MobileServerController: move code to callable method
MobileServerRequestExecutor: change a preference to seconds and use shorter timeout for extra check

---
M src-db/database/sourcedata/AD_REF_LIST.xml
M src/org/openbravo/mobile/core/servercontroller/CheckServerAvailability.java
M src/org/openbravo/mobile/core/servercontroller/MobileMainServerCheck.java
M src/org/openbravo/mobile/core/servercontroller/MobileServerController.java
M src/org/openbravo/mobile/core/servercontroller/MobileServerRequestExecutor.java
---
(0112141)
hgbot (developer)
2019-05-25 23:27

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 72b30431bd75c5b1d5d9d7361414e1331240e230
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Sat May 25 23:26:56 2019 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/72b30431bd75c5b1d5d9d7361414e1331240e230 [^]

Related to issue 40648: Make the store server more sensitive to overloaded cs
Also check server availability before transitioning to online

---
M src/org/openbravo/mobile/core/servercontroller/MobileServerController.java
M src/org/openbravo/mobile/core/servercontroller/MobileServerRequestExecutor.java
---
(0112142)
mtaal (manager)
2019-05-25 23:31

Note:
Commits of 15th May and before have been backed out:
https://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/ca7eed56ca97 [^]
https://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/a4dc69c40a62 [^]
https://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/55ecbb4b768b [^]
https://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/426991f1ccf5 [^]
(0112212)
AugustoMauch (developer)
2019-05-28 17:15

Code reviewed and verified
(0112466)
hgbot (developer)
2019-06-06 11:45

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 4df2d4b41e3cc7d348709a7b7fa008de3b94b4e2
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Thu Jun 06 11:45:49 2019 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/4df2d4b41e3cc7d348709a7b7fa008de3b94b4e2 [^]

Related to issue 40648: readd checks when transition to offline
Use the store org to set the query parameters

---
M src-db/database/sourcedata/AD_REF_LIST.xml
M src/org/openbravo/mobile/core/servercontroller/MobileMainServerCheck.java
M src/org/openbravo/mobile/core/servercontroller/MobileServerRequestExecutor.java
M src/org/openbravo/mobile/core/servercontroller/ServerStateBackground.java
---
(0112467)
hgbot (developer)
2019-06-06 11:47

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: a75e3f6ab144abe75eec8e24a8b990b84d18bf76
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Thu Jun 06 11:47:42 2019 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/a75e3f6ab144abe75eec8e24a8b990b84d18bf76 [^]

Related to issue 40648: Make the store server more sensitive to overloaded cs
Remove unintended line

---
M src/org/openbravo/mobile/core/servercontroller/ServerStateBackground.java
---
(0112491)
hgbot (developer)
2019-06-06 22:28

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 8ef26fe149bdcb184c3c0e21ec85e66d0881c936
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Thu Jun 06 22:28:01 2019 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/8ef26fe149bdcb184c3c0e21ec85e66d0881c936 [^]

Related to issue 40648: Make the store server more sensitive to overloaded cs
Pass the store org explicitly to the check availability and use it to read the preference

---
M src/org/openbravo/mobile/core/servercontroller/CheckServerAvailability.java
M src/org/openbravo/mobile/core/servercontroller/MobileServerRequestExecutor.java
---
(0112492)
hgbot (developer)
2019-06-06 22:30

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 4476b7e46812363e0ca74a6dbf16a601f91c9c04
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Thu Jun 06 22:29:55 2019 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/4476b7e46812363e0ca74a6dbf16a601f91c9c04 [^]

Related to issue 40648: Make the store server more sensitive to overloaded cs
Remove accidental System.err.println

---
M src/org/openbravo/mobile/core/servercontroller/CheckServerAvailability.java
---
(0112510)
hgbot (developer)
2019-06-07 17:45

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 178938b08358a3ac4479cfecac4e442d44e8f986
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Fri Jun 07 17:45:29 2019 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/178938b08358a3ac4479cfecac4e442d44e8f986 [^]

Backed out changeset 4476b7e46812
Related to issue 40648

---
M src/org/openbravo/mobile/core/servercontroller/CheckServerAvailability.java
---
(0112511)
hgbot (developer)
2019-06-07 17:46

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 75caa91d212dd924c1d102c0df68eaf84b9e3749
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Fri Jun 07 17:45:51 2019 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/75caa91d212dd924c1d102c0df68eaf84b9e3749 [^]

Backed out changeset 8ef26fe149bd
Related to issue 40648

---
M src/org/openbravo/mobile/core/servercontroller/CheckServerAvailability.java
M src/org/openbravo/mobile/core/servercontroller/MobileServerRequestExecutor.java
---
(0112516)
hgbot (developer)
2019-06-08 16:56

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 6b962954112a6d5c3a70ab44f4351efc80065594
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Sat Jun 08 16:56:41 2019 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/6b962954112a6d5c3a70ab44f4351efc80065594 [^]

Fixes issue 40648: Make the store server more sensitive to overloaded cs
Use the correct role to ensure that pref on store level works.
Add log with user information in check availability

---
M src/org/openbravo/mobile/core/servercontroller/CheckServerAvailability.java
M src/org/openbravo/mobile/core/servercontroller/MobileServerRequestExecutor.java
---
(0112542)
AugustoMauch (developer)
2019-06-10 15:20

Code reviewed and verified
(0112546)
hgbot (developer)
2019-06-10 16:17

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 9af25c343b365ecc4acc6e36c77b36548fee7fc5
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Mon Jun 10 16:17:39 2019 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/9af25c343b365ecc4acc6e36c77b36548fee7fc5 [^]

Related to issue 40648: Make the store server more sensitive to overloaded cs
Use timeout of 10 secs instead of 5.

---
M src/org/openbravo/mobile/core/servercontroller/MobileServerRequestExecutor.java
---
(0112554)
hgbot (developer)
2019-06-10 17:49

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: a55bccc2a5510743f3b12a3fa52126bf543ef4bf
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Mon Jun 10 17:49:35 2019 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/a55bccc2a5510743f3b12a3fa52126bf543ef4bf [^]

Related to issue 40648: Make the store server more sensitive to overloaded cs
Use the newer api to read the preference on store level without enforcing a role

---
M src/org/openbravo/mobile/core/servercontroller/CheckServerAvailability.java
M src/org/openbravo/mobile/core/servercontroller/MobileServerRequestExecutor.java
---

- Issue History
Date Modified Username Field Change
2019-04-18 16:17 mtaal New Issue
2019-04-18 16:17 mtaal Assigned To => mtaal
2019-04-18 16:17 mtaal Triggers an Emergency Pack => No
2019-04-22 06:29 mtaal Review Assigned To => AugustoMauch
2019-04-22 06:29 hgbot Checkin
2019-04-22 06:29 hgbot Note Added: 0111217
2019-04-22 06:29 hgbot Status new => resolved
2019-04-22 06:29 hgbot Resolution open => fixed
2019-04-22 06:29 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/0dbe7c99bb192978bbe1e81726f0c8a28d3929f2 [^]
2019-04-22 22:35 hgbot Checkin
2019-04-22 22:35 hgbot Note Added: 0111220
2019-04-22 22:35 hgbot Checkin
2019-04-22 22:35 hgbot Note Added: 0111221
2019-04-24 18:19 AugustoMauch Note Added: 0111292
2019-04-24 18:19 AugustoMauch Status resolved => closed
2019-05-06 23:14 mtaal Note Added: 0111515
2019-05-06 23:14 mtaal Status closed => new
2019-05-06 23:14 mtaal Resolution fixed => open
2019-05-06 23:15 mtaal File Added: 40648_but_5.diff
2019-05-07 20:44 mtaal File Deleted: 40648_but_5.diff
2019-05-07 20:44 mtaal File Added: but_core_1.diff
2019-05-13 16:09 AugustoMauch Note Added: 0111645
2019-05-15 22:33 hgbot Checkin
2019-05-15 22:33 hgbot Note Added: 0111694
2019-05-15 22:50 mtaal File Added: 40468_2.diff
2019-05-15 22:51 mtaal File Deleted: 40468_2.diff
2019-05-15 22:51 mtaal File Added: 40648_2.diff
2019-05-25 11:38 mtaal File Deleted: but_core_1.diff
2019-05-25 11:38 mtaal File Deleted: 40648_2.diff
2019-05-25 11:39 mtaal File Added: 40648-complete.diff
2019-05-25 22:08 hgbot Checkin
2019-05-25 22:08 hgbot Note Added: 0112140
2019-05-25 22:08 hgbot Status new => resolved
2019-05-25 22:08 hgbot Resolution open => fixed
2019-05-25 22:08 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/0dbe7c99bb192978bbe1e81726f0c8a28d3929f2 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/790dfcea17befe2e5b0b94b5d2487ef8fffa4a7c [^]
2019-05-25 23:27 hgbot Checkin
2019-05-25 23:27 hgbot Note Added: 0112141
2019-05-25 23:29 mtaal File Deleted: 40648-complete.diff
2019-05-25 23:31 mtaal Note Added: 0112142
2019-05-28 17:15 AugustoMauch Note Added: 0112212
2019-05-28 17:15 AugustoMauch Status resolved => closed
2019-05-31 15:01 mtaal Relationship added related to 0040994
2019-06-05 04:16 mtaal File Added: new_diff_ss.diff
2019-06-06 11:45 hgbot Checkin
2019-06-06 11:45 hgbot Note Added: 0112466
2019-06-06 11:47 hgbot Checkin
2019-06-06 11:47 hgbot Note Added: 0112467
2019-06-06 22:28 hgbot Checkin
2019-06-06 22:28 hgbot Note Added: 0112491
2019-06-06 22:30 hgbot Checkin
2019-06-06 22:30 hgbot Note Added: 0112492
2019-06-07 17:45 hgbot Checkin
2019-06-07 17:45 hgbot Note Added: 0112510
2019-06-07 17:46 hgbot Checkin
2019-06-07 17:46 hgbot Note Added: 0112511
2019-06-08 16:56 hgbot Checkin
2019-06-08 16:56 hgbot Note Added: 0112516
2019-06-08 16:56 hgbot Status closed => resolved
2019-06-08 16:56 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/790dfcea17befe2e5b0b94b5d2487ef8fffa4a7c [^] => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/6b962954112a6d5c3a70ab44f4351efc80065594 [^]
2019-06-10 15:20 AugustoMauch Note Added: 0112542
2019-06-10 15:20 AugustoMauch Status resolved => closed
2019-06-10 16:17 hgbot Checkin
2019-06-10 16:17 hgbot Note Added: 0112546
2019-06-10 17:49 hgbot Checkin
2019-06-10 17:49 hgbot Note Added: 0112554


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker