Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040636
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2019-04-17 14:092019-04-29 09:27
ReportermalsasuaView Statuspublic 
Assigned Toranjith_qualiantech_com 
PrioritynormalResolutionfixedFixed in VersionRR19Q3
StatusclosedFix in branchFixed in SCM revision6a129df0f386
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toadrianromero
Regression levelProduction - Confirmed Stable
Regression date
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b7719b21dbb9fd807522f0751de99059a018b755 [^]
Triggers an Emergency PackNo
Summary

0040636: Tax info is not displayed when total ticket is 0

DescriptionIn the receipt, when total ticket is 0, the tax info is not displayed
Steps To Reproduce[POS]
. new receipt SO1
. add Avalance Transceiver
. complete it
. click in Verified REturn menu option
. select receipt SO1 -> click in line -> Avalanche Transceiver line with qty -1 is added
. add Avalanche Transceiver line
. total ticket is 0
. taxes are not displayed
Error: in previous releases the tax info is displayed (see screenshot)
TagsNo tags attached.
Attached Filespng file icon 18Q3.png [^] (337,024 bytes) 2019-04-17 14:13
png file icon 17Q4.png [^] (273,074 bytes) 2019-04-17 14:13

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0040693RR19Q2 closedranjith_qualiantech_com Tax info is not displayed when total ticket is 0 
depends on backport 0040694RR19Q1.1 closedranjith_qualiantech_com Tax info is not displayed when total ticket is 0 
caused by defect 0038342 closedranjith_qualiantech_com [RR18Q2] Tax labels are not removed when all lines of a receipt are deleted 

-  Notes
(0111216)
hgbot (developer)
2019-04-19 11:17

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 6a129df0f3866e9289a76c82cab6a84c4db4ae60
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Fri Apr 19 14:46:59 2019 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/6a129df0f3866e9289a76c82cab6a84c4db4ae60 [^]

Fixed issue 40636 : Tax List should be hidden when there is no lines present in the receipt

---
M web/org.openbravo.retail.posterminal/js/components/order.js
---
(0111246)
adrianromero (manager)
2019-04-23 18:33

Verified.

- Issue History
Date Modified Username Field Change
2019-04-17 14:09 malsasua New Issue
2019-04-17 14:09 malsasua Assigned To => Retail
2019-04-17 14:09 malsasua Triggers an Emergency Pack => No
2019-04-17 14:13 malsasua File Added: 18Q3.png
2019-04-17 14:13 malsasua File Added: 17Q4.png
2019-04-17 14:14 malsasua Regression level => Production - Confirmed Stable
2019-04-17 14:14 malsasua Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b7719b21dbb9fd807522f0751de99059a018b755 [^]
2019-04-18 10:17 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2019-04-18 10:17 ranjith_qualiantech_com Status new => scheduled
2019-04-19 07:45 ranjith_qualiantech_com Relationship added caused by 0038342
2019-04-19 11:17 hgbot Checkin
2019-04-19 11:17 hgbot Note Added: 0111216
2019-04-19 11:17 hgbot Status scheduled => resolved
2019-04-19 11:17 hgbot Resolution open => fixed
2019-04-19 11:17 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/6a129df0f3866e9289a76c82cab6a84c4db4ae60 [^]
2019-04-23 18:33 adrianromero Review Assigned To => adrianromero
2019-04-23 18:33 adrianromero Note Added: 0111246
2019-04-23 18:33 adrianromero Status resolved => closed
2019-04-23 18:33 adrianromero Fixed in Version => RR19Q3
2019-04-29 09:27 marvintm Status closed => new
2019-04-29 09:27 marvintm Resolution fixed => open
2019-04-29 09:27 marvintm Fixed in Version RR19Q3 =>
2019-04-29 09:27 marvintm Status new => scheduled
2019-04-29 09:27 marvintm Status scheduled => resolved
2019-04-29 09:27 marvintm Fixed in Version => RR19Q3
2019-04-29 09:27 marvintm Resolution open => fixed
2019-04-29 09:27 marvintm Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker