Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040635
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformmajorhave not tried2019-04-17 12:042019-04-26 09:03
ReportercaristuView Statuspublic 
Assigned Toalostale 
PriorityhighResolutionfixedFixed in Version3.0PR19Q1.1
StatusclosedFix in branchFixed in SCM revision35616a3d9406
ProjectionnoneETAnoneTarget Version3.0PR19Q1.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2018-11-22
Regression introduced in release3.0PR19Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/4d71d9e4d6d5c9be49d1a301da6dbeefeb5d9048 [^]
Triggers an Emergency PackNo
Summary

0040635: Generation of Discounts and Promotions windows fails under some circumstances

DescriptionGeneration of Discounts and Promotions windows fails under some circumstances due the following error:

Caused by: org.hibernate.LazyInitializationException: could not initialize proxy [ADTableTree#B6C7204712CC4EDEB5705C93F706DF05] - no Session
    at org.hibernate.proxy.AbstractLazyInitializer.initialize(AbstractLazyInitializer.java:159) ~[hibernate-core-5.3.2.Final.jar:5.3.2.Final]
    at org.hibernate.proxy.AbstractLazyInitializer.getImplementation(AbstractLazyInitializer.java:272) ~[hibernate-core-5.3.2.Final.jar:5.3.2.Final]

See the file with the full error stack trace.
Steps To Reproduce1) Login in Openbravo, having no modules in "in development" status
2) Open the [Discounts and Promotions] window
3) Restart Tomcat
4) Login again with the same browser session and open the [Discounts and Promotions] window
5) Create a new record in the header
6) In a different browser session, login in Openbravo
7) Open the [Discounts and Promotions] window. An error is raised.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0040633 closedalostale Generation of Discounts and Promotions windows fails under some circumstances 

-  Notes
(0111192)
alostale (developer)
2019-04-17 13:13

Fixed with incorrect commit message

https://code.openbravo.com/erp/backports/3.0PR19Q1.1/rev/35616a3d9406 [^]

changeset: 35329:35616a3d9406
tag: tip
user: Asier Lostalé <asier.lostale@openbravo.com>
date: Wed Apr 17 12:57:28 2019 +0200
summary: fixed bug 40655: Discounts and Promotions window fails under some circumstances
(0111342)
caristu (developer)
2019-04-26 09:03

Code reviewed + tested OK.

- Issue History
Date Modified Username Field Change
2019-04-17 12:54 alostale Type defect => backport
2019-04-17 12:54 alostale Target Version => 3.0PR19Q1.1
2019-04-17 13:13 alostale Note Added: 0111192
2019-04-17 13:13 alostale Status scheduled => resolved
2019-04-17 13:13 alostale Fixed in SCM revision => https://code.openbravo.com/erp/backports/3.0PR19Q1.1/rev/35616a3d9406 [^]
2019-04-17 13:13 alostale Resolution open => fixed
2019-04-26 09:03 caristu Note Added: 0111342
2019-04-26 09:03 caristu Status resolved => closed
2019-04-26 09:03 caristu Fixed in Version => 3.0PR19Q1.1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker