Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040633
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2019-04-17 12:042019-05-21 15:16
ReportercaristuView Statuspublic 
Assigned Toalostale 
PriorityhighResolutionfixedFixed in Version3.0PR19Q3
StatusclosedFix in branchFixed in SCM revision77247a463666
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2018-11-22
Regression introduced in release3.0PR19Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/4d71d9e4d6d5c9be49d1a301da6dbeefeb5d9048 [^]
Triggers an Emergency PackNo
Summary

0040633: Generation of Discounts and Promotions windows fails under some circumstances

DescriptionGeneration of Discounts and Promotions windows fails under some circumstances due the following error:

Caused by: org.hibernate.LazyInitializationException: could not initialize proxy [ADTableTree#B6C7204712CC4EDEB5705C93F706DF05] - no Session
    at org.hibernate.proxy.AbstractLazyInitializer.initialize(AbstractLazyInitializer.java:159) ~[hibernate-core-5.3.2.Final.jar:5.3.2.Final]
    at org.hibernate.proxy.AbstractLazyInitializer.getImplementation(AbstractLazyInitializer.java:272) ~[hibernate-core-5.3.2.Final.jar:5.3.2.Final]

See the file with the full error stack trace.
Steps To Reproduce1) Login in Openbravo, having no modules in "in development" status
2) Open the [Discounts and Promotions] window
3) Restart Tomcat
4) Login again with the same browser session and open the [Discounts and Promotions] window
5) Create a new record in the header
6) In a different browser session, login in Openbravo
7) Open the [Discounts and Promotions] window. An error is raised.
TagsNo tags attached.
Attached Filestxt file icon stackTraceError.txt [^] (32,105 bytes) 2019-04-17 12:04 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00406343.0PR19Q2 closedalostale Generation of Discounts and Promotions windows fails under some circumstances 
depends on backport 00406353.0PR19Q1.1 closedalostale Generation of Discounts and Promotions windows fails under some circumstances 
caused by design defect 0039670 closedalostale view generation scalability issues 

-  Notes
(0111182)
caristu (developer)
2019-04-17 12:23
edited on: 2019-04-17 12:23

Workaround: clear the ADCS cache using the JMX bean.

(0111189)
hgbot (developer)
2019-04-17 13:10

Repository: erp/devel/pi
Changeset: 77247a46366613111a6c1dc7ce506475ac0ab652
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Apr 17 12:57:28 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/77247a46366613111a6c1dc7ce506475ac0ab652 [^]

fixed bug 40633: Discounts and Promotions window fails under some circumstances

  When Discount and Promotions view was requested having previously initialized
  ADCS with that window via FIC a LazyInitializationException was thrown.

  The problem is this window has a tree reference field which was partially initialized
  in ADCS.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/ApplicationDictionaryCachedStructures.java
---
(0111190)
hgbot (developer)
2019-04-17 13:10

Repository: erp/devel/pi
Changeset: 70984e92751f9c5840c51382a2bf0bdbc456da51
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Apr 17 12:59:00 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/70984e92751f9c5840c51382a2bf0bdbc456da51 [^]

related to bug 40633: added test case

---
M src-test/src/org/openbravo/test/AllAntTaskTests.java
M src-test/src/org/openbravo/test/base/TestConstants.java
A modules/org.openbravo.client.application/src-test/org/openbravo/client/application/test/ADCSTest.java
---
(0111340)
caristu (developer)
2019-04-26 09:02

Code reviewed + tested OK.
(0111984)
hudsonbot (developer)
2019-05-21 15:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9b8f37d9d85e [^]
Maturity status: Test
(0111985)
hudsonbot (developer)
2019-05-21 15:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9b8f37d9d85e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-04-17 12:04 caristu New Issue
2019-04-17 12:04 caristu Assigned To => platform
2019-04-17 12:04 caristu File Added: stackTraceError.txt
2019-04-17 12:04 caristu Modules => Core
2019-04-17 12:04 caristu Triggers an Emergency Pack => No
2019-04-17 12:05 caristu Relationship added caused by 0039670
2019-04-17 12:05 caristu Regression date => 2018-11-22
2019-04-17 12:05 caristu Regression introduced in release => 3.0PR19Q1
2019-04-17 12:05 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/4d71d9e4d6d5c9be49d1a301da6dbeefeb5d9048 [^]
2019-04-17 12:18 alostale Review Assigned To => caristu
2019-04-17 12:19 alostale Regression level => Production - QA Approved
2019-04-17 12:19 alostale Assigned To platform => alostale
2019-04-17 12:20 alostale Severity minor => major
2019-04-17 12:23 caristu Note Added: 0111182
2019-04-17 12:23 caristu Note Edited: 0111182 View Revisions
2019-04-17 12:54 alostale Status new => scheduled
2019-04-17 13:10 hgbot Checkin
2019-04-17 13:10 hgbot Note Added: 0111189
2019-04-17 13:10 hgbot Status scheduled => resolved
2019-04-17 13:10 hgbot Resolution open => fixed
2019-04-17 13:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/77247a46366613111a6c1dc7ce506475ac0ab652 [^]
2019-04-17 13:10 hgbot Checkin
2019-04-17 13:10 hgbot Note Added: 0111190
2019-04-26 09:02 caristu Note Added: 0111340
2019-04-26 09:02 caristu Status resolved => closed
2019-04-26 09:02 caristu Fixed in Version => 3.0PR19Q3
2019-05-21 15:16 hudsonbot Checkin
2019-05-21 15:16 hudsonbot Note Added: 0111984
2019-05-21 15:16 hudsonbot Checkin
2019-05-21 15:16 hudsonbot Note Added: 0111985


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker