Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040437
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Sessionsmajoralways2019-03-22 10:372019-04-15 11:53
Reportersamuel_nicuesaView Statuspublic 
Assigned Torqueralta 
PriorityhighResolutionfixedFixed in VersionRR19Q3
StatusclosedFix in branchFixed in SCM revision4c1a25c37605
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toadrianromero
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040437: Business date of terminal till and status is updated if business date of the terminal changes

DescriptionBusiness date of terminal till and status is updated if business date of the terminal changes
Steps To Reproduce[BO] VBS-1

- Open store setting business date (22-03-2019)

[POS]

- Login and create some tickets in VSB-1 store

- Don't do cash up


[BO]

- Go to terminal till and status and Business date will be (22-03-2019)

- Go to close store window and close VSB-1 terminal

- Go to open store window and open Vallblanca store using Business date (27-03-2019)

[POS]

- Login again in VBS-1 Terminal

- Cash up needs to be done

- Do cash up and logout will be done

- Go to terminal till and status and terminal VBS-1 will be opened on 22-03-2019 and business date has been changed to (27-03-2019)

- We think that business date needs to be (22-03-2019) instead of (27-03-2019)
TagsNo tags attached.
Attached Filesdiff file icon 40437.diff [^] (1,077 bytes) 2019-04-02 21:33 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0110669)
hgbot (developer)
2019-03-26 18:56

Repository: erp/pmods/org.openbravo.retail.sessions
Changeset: 497591c4f1a65232a685db164f8d3f8a7a04eb98
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Tue Mar 26 13:54:12 2019 -0400
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.sessions/rev/497591c4f1a65232a685db164f8d3f8a7a04eb98 [^]

Fixed issue 40437: Business date of terminal till and status is updated if
business date of the terminal changes

- Updated "Business Date" value to the date when the Till opens instead the
date when the store was opened

---
M src/org/openbravo/retail/sessions/OpenSessionPOS.java
---
(0110924)
hgbot (developer)
2019-03-29 12:47

Repository: erp/pmods/org.openbravo.retail.sessions
Changeset: 4e8db3f10a69f083a594cf1e7d83f9efc0372ead
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Fri Mar 29 12:47:42 2019 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.sessions/rev/4e8db3f10a69f083a594cf1e7d83f9efc0372ead [^]

Related to issue 40437. Rolled back the change as it is not correct.

---
M src/org/openbravo/retail/sessions/OpenSessionPOS.java
---
(0111004)
hgbot (developer)
2019-04-05 14:41

Repository: erp/pmods/org.openbravo.retail.sessions
Changeset: 9af241c929c29e9b1cadbd32187de6e4cc361150
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Tue Apr 02 15:31:03 2019 -0400
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.sessions/rev/9af241c929c29e9b1cadbd32187de6e4cc361150 [^]

Fixed issue 40437: Business date of terminal till and status is updated if
business date of the terminal changes

-Updated "Business Date" field with the cashup process date into Till Status Tab

---
M src/org/openbravo/retail/sessions/SessionModel.java
---
(0111043)
jorge-garcia (developer)
2019-04-09 13:09

The fix is not correct, the bsuinessDtae of the till should be the original businessDate of the till, and not the current update field from the cashup.

The idea is that if the till was opened at 08-04-2019 but I do the cashup at 09-04-2019, the till's business date once created should use 08-04-2019.
(0111069)
hgbot (developer)
2019-04-10 23:42

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: fa0eebed139f5801bcaee4c2cbcdcacc2b725a46
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Wed Apr 10 17:38:48 2019 -0400
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/fa0eebed139f5801bcaee4c2cbcdcacc2b725a46 [^]

Fixed issue 40437: Business date of terminal till and status is updated if
business date of the terminal changes

-Updated "Business Date" field with the previous business date if cashup was
forced to do.

---
M web/org.openbravo.retail.posterminal/js/utils/cashUpReportUtils.js
---
(0111070)
hgbot (developer)
2019-04-10 23:43

Repository: erp/pmods/org.openbravo.retail.sessions
Changeset: 4c1a25c37605570055c5e4c1e2c94fece3fd2fcd
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Wed Apr 10 17:37:29 2019 -0400
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.sessions/rev/4c1a25c37605570055c5e4c1e2c94fece3fd2fcd [^]

Fixed issue 40437: Business date of terminal till and status is updated if
business date of the terminal changes

-Updated "Business Date" field with the previous business date if cashup was
forced to do.

---
M src/org/openbravo/retail/sessions/CloseSessionHook.java
M src/org/openbravo/retail/sessions/SessionModel.java
M web/org.openbravo.retail.sessions/js/components/loginhook.js
---
(0111114)
adrianromero (manager)
2019-04-12 16:49

The fix adds sessions logic into the posterminal creating a circular dependency between the two modules.

All the fix logic must go in the sessions module and the code included in posterminal must be removed.

Mi proposal is that all the fix logic must go in the file loginghook.js. The idea is that in each point it is detected the need of a forced cahup. Line:

OB.MobileApp.model.set('POSS_ForceCashup', true);

It has to be set the current terminal bussiness date and not the changed business date from the server. Even the flow must be modified. Instead of first changing the business date when a change is detected and then checking if a forced cashup is needed. First check if a forced cashup is needed for the current business date. If needed then perform the forced cashup with the current posterminal business date and logout. and if not needed a forced cashup, the business date can be changed and a dialog informing the user is displayed
(0111116)
hgbot (developer)
2019-04-12 23:21

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 091e15597e35ec722293c5f08b35512c504db4ce
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Fri Apr 12 17:09:55 2019 -0400
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/091e15597e35ec722293c5f08b35512c504db4ce [^]

Related to issue 40437: Business date of terminal till and status is updated if
business date of the terminal changes

- Removed this change because a circular dependency with session
modules was created.

---
M web/org.openbravo.retail.posterminal/js/utils/cashUpReportUtils.js
---
(0111117)
hgbot (developer)
2019-04-13 00:17

Repository: erp/pmods/org.openbravo.retail.sessions
Changeset: 4db65e9acd59ebc151c234dcd24623051bf79bb1
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Fri Apr 12 17:37:46 2019 -0400
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.sessions/rev/4db65e9acd59ebc151c234dcd24623051bf79bb1 [^]

Related to issue 40437: Business date of terminal till and status is updated if
business date of the terminal changes

-Modified update business date flow. Now we check if a forced cashup is
needed before change the business date value.

---
M src/org/openbravo/retail/sessions/CloseSessionHook.java
M web/org.openbravo.retail.sessions/js/components/cashup-title-extension.js
M web/org.openbravo.retail.sessions/js/components/loginhook.js
---
(0111124)
adrianromero (manager)
2019-04-15 11:53

Verified

- Issue History
Date Modified Username Field Change
2019-03-22 10:37 samuel_nicuesa New Issue
2019-03-22 10:37 samuel_nicuesa Assigned To => Retail
2019-03-22 10:37 samuel_nicuesa Triggers an Emergency Pack => No
2019-03-22 15:59 rqueralta Assigned To Retail => rqueralta
2019-03-22 15:59 rqueralta Status new => scheduled
2019-03-26 18:56 hgbot Checkin
2019-03-26 18:56 hgbot Note Added: 0110669
2019-03-26 18:56 hgbot Status scheduled => resolved
2019-03-26 18:56 hgbot Resolution open => fixed
2019-03-26 18:56 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.sessions/rev/497591c4f1a65232a685db164f8d3f8a7a04eb98 [^]
2019-03-29 12:03 marvintm Review Assigned To => marvintm
2019-03-29 12:47 hgbot Checkin
2019-03-29 12:47 hgbot Note Added: 0110924
2019-03-29 12:47 marvintm Status resolved => new
2019-03-29 12:47 marvintm Resolution fixed => open
2019-04-02 21:33 rqueralta File Added: 40437.diff
2019-04-05 14:41 hgbot Checkin
2019-04-05 14:41 hgbot Note Added: 0111004
2019-04-05 14:41 hgbot Status new => resolved
2019-04-05 14:41 hgbot Resolution open => fixed
2019-04-05 14:41 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.sessions/rev/497591c4f1a65232a685db164f8d3f8a7a04eb98 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.sessions/rev/9af241c929c29e9b1cadbd32187de6e4cc361150 [^]
2019-04-09 13:09 jorge-garcia Note Added: 0111043
2019-04-09 13:09 jorge-garcia Status resolved => new
2019-04-09 13:09 jorge-garcia Resolution fixed => open
2019-04-10 23:42 hgbot Checkin
2019-04-10 23:42 hgbot Note Added: 0111069
2019-04-10 23:42 hgbot Status new => resolved
2019-04-10 23:42 hgbot Resolution open => fixed
2019-04-10 23:42 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.sessions/rev/9af241c929c29e9b1cadbd32187de6e4cc361150 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/fa0eebed139f5801bcaee4c2cbcdcacc2b725a46 [^]
2019-04-10 23:43 hgbot Checkin
2019-04-10 23:43 hgbot Note Added: 0111070
2019-04-10 23:43 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/fa0eebed139f5801bcaee4c2cbcdcacc2b725a46 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.sessions/rev/4c1a25c37605570055c5e4c1e2c94fece3fd2fcd [^]
2019-04-12 16:49 adrianromero Note Added: 0111114
2019-04-12 16:49 adrianromero Status resolved => new
2019-04-12 16:49 adrianromero Resolution fixed => open
2019-04-12 23:21 hgbot Checkin
2019-04-12 23:21 hgbot Note Added: 0111116
2019-04-13 00:17 hgbot Checkin
2019-04-13 00:17 hgbot Note Added: 0111117
2019-04-13 00:18 rqueralta Status new => scheduled
2019-04-13 00:18 rqueralta Status scheduled => resolved
2019-04-13 00:18 rqueralta Resolution open => fixed
2019-04-15 11:53 adrianromero Review Assigned To marvintm => adrianromero
2019-04-15 11:53 adrianromero Note Added: 0111124
2019-04-15 11:53 adrianromero Status resolved => closed
2019-04-15 11:53 adrianromero Fixed in Version => RR19Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker