Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040337
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Cash upmajorhave not tried2019-03-07 13:412019-03-28 18:01
ReportermalsasuaView Statuspublic 
Assigned Torqueralta 
PriorityhighResolutionfixedFixed in VersionRR19Q2
StatusclosedFix in branchFixed in SCM revisionc74d6f059b73
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040337: Cashup with corrupted data is synced after to update to 18Q3

DescriptionWhen cashup has not been completed in one terminal, and system is updated to 18Q3, the payment method cashup info is corrupted in local database. This info is updated to current balance of financial account of payments.
Steps To ReproduceBO:
. Cash financial account - current balance 0

POS:
. login
. complete cashup -> total to keep for cash payment method: 0
. complete a new sales order SO1 -> amount 10
(Cash financial account - current balance 10)

UPDATE TO 18Q3
POS:
. login
. complete cashup -> starting cash is displaying amount 10 and it should be 0
Proposed SolutionVerify into OB.UTIL.initcashup function if any tables related with the cash up process was rebuilded. If it was done, is necessary eliminate the others related tables, at the beginning of the process. By doing this, we recover all the backend data.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0040484RR19Q1.1 closedrqueralta Cashup with corrupted data is synced after to update to 18Q3 
depends on backport 0040485RR18Q4.3 closedrqueralta Cashup with corrupted data is synced after to update to 18Q3 

-  Notes
(0110438)
hgbot (developer)
2019-03-14 13:30

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: c9244988dd029f49c0cf47841c4179b18561d79b
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Wed Mar 13 19:45:12 2019 -0400
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/c9244988dd029f49c0cf47841c4179b18561d79b [^]

Fixed issue 40337: Cashup with corrupted data is synced after to update to 18Q3

- Before add a new record into paymentmethodcashup table is necessary check if
the model was rebuilded to set the startingCash to 0.

---
M web/org.openbravo.retail.posterminal/js/utils/cashUpReportUtils.js
---
(0110439)
hgbot (developer)
2019-03-14 13:31

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 6fe93e22a3c77d7e9d1fc9f35805b6fdb843ac15
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Wed Mar 13 19:45:00 2019 -0400
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/6fe93e22a3c77d7e9d1fc9f35805b6fdb843ac15 [^]

Fixed issue 40337: Cashup with corrupted data is synced after to update to 18Q3

- Before add a new record into paymentmethodcashup table is necessary check if
the model was rebuilded to set the startingCash to 0.

---
M web/org.openbravo.mobile.core/source/model/ob-terminal-model.js
---
(0110623)
guilleaer (developer)
2019-03-25 12:59
edited on: 2019-03-25 13:02

This fix is not correct (posterminal part)

If payment method cashup information is rebuilded then we need to intialize cashup information from backend. It includes cashup model.

- Remove cashup information and retrieve cashup and payment method cashup information from backend

(0110650)
hgbot (developer)
2019-03-26 12:11

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: d3d5b55bacf27fb7ae575f88aac921986f335df4
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Mon Mar 25 22:59:56 2019 -0400
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/d3d5b55bacf27fb7ae575f88aac921986f335df4 [^]

Fixed issue 40337: Cashup with corrupted data is synced after to update to 18Q3

- Removed this change because it not necessary

---
M web/org.openbravo.retail.posterminal/js/utils/cashUpReportUtils.js
---
(0110651)
hgbot (developer)
2019-03-26 12:12

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: c74d6f059b735e2b45163a54886035c9829cbc49
Author: Rafael Queralta <rafaelcuba81 <at> gmail.com>
Date: Mon Mar 25 23:09:04 2019 -0400
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/c74d6f059b735e2b45163a54886035c9829cbc49 [^]

Fixed issue 40337: Cashup with corrupted data is synced after to update to 18Q3

- If one table related to Cash Up process is rebuilded, is necessary rebuild all
the related tables. "relatedTablesToRebuild" function was added to do it. In this
way we reload all Cash Up data from the backend.

---
M web/org.openbravo.mobile.core/source/model/ob-terminal-model.js
---
(0110901)
guilleaer (developer)
2019-03-28 15:14

Although customer can perceive this problem as a regression it is not a regression in the code. We were not taking into account this situation before.

- Issue History
Date Modified Username Field Change
2019-03-07 13:41 malsasua New Issue
2019-03-07 13:41 malsasua Assigned To => Retail
2019-03-07 13:41 malsasua Regression level => Production - Confirmed Stable
2019-03-07 13:41 malsasua Triggers an Emergency Pack => No
2019-03-09 04:51 rqueralta Assigned To Retail => rqueralta
2019-03-09 04:51 rqueralta Status new => scheduled
2019-03-12 10:00 ngarcia Issue Monitored: ngarcia
2019-03-14 13:30 hgbot Checkin
2019-03-14 13:30 hgbot Note Added: 0110438
2019-03-14 13:30 hgbot Status scheduled => resolved
2019-03-14 13:30 hgbot Resolution open => fixed
2019-03-14 13:30 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/c9244988dd029f49c0cf47841c4179b18561d79b [^]
2019-03-14 13:31 hgbot Checkin
2019-03-14 13:31 hgbot Note Added: 0110439
2019-03-14 13:31 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/c9244988dd029f49c0cf47841c4179b18561d79b [^] => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/6fe93e22a3c77d7e9d1fc9f35805b6fdb843ac15 [^]
2019-03-25 12:59 guilleaer Note Added: 0110623
2019-03-25 12:59 guilleaer Status resolved => new
2019-03-25 12:59 guilleaer Resolution fixed => open
2019-03-25 12:59 guilleaer Regression level Production - Confirmed Stable =>
2019-03-25 13:02 guilleaer Note Edited: 0110623 View Revisions
2019-03-25 20:21 rqueralta Proposed Solution updated
2019-03-26 11:42 egoitz Regression level => Production - Confirmed Stable
2019-03-26 12:11 hgbot Checkin
2019-03-26 12:11 hgbot Note Added: 0110650
2019-03-26 12:11 hgbot Status new => resolved
2019-03-26 12:11 hgbot Resolution open => fixed
2019-03-26 12:11 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/6fe93e22a3c77d7e9d1fc9f35805b6fdb843ac15 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/d3d5b55bacf27fb7ae575f88aac921986f335df4 [^]
2019-03-26 12:12 hgbot Checkin
2019-03-26 12:12 hgbot Note Added: 0110651
2019-03-26 12:12 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/d3d5b55bacf27fb7ae575f88aac921986f335df4 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/c74d6f059b735e2b45163a54886035c9829cbc49 [^]
2019-03-28 13:30 guilleaer Review Assigned To => guilleaer
2019-03-28 13:30 guilleaer Status resolved => closed
2019-03-28 13:30 guilleaer Fixed in Version => RR19Q2
2019-03-28 15:13 guilleaer Regression level Production - Confirmed Stable =>
2019-03-28 15:14 guilleaer Note Added: 0110901
2019-03-28 17:59 guilleaer Status closed => new
2019-03-28 17:59 guilleaer Resolution fixed => open
2019-03-28 17:59 guilleaer Fixed in Version RR19Q2 =>
2019-03-28 18:00 guilleaer Status new => scheduled
2019-03-28 18:00 guilleaer Status scheduled => resolved
2019-03-28 18:01 guilleaer Fixed in Version => RR19Q2
2019-03-28 18:01 guilleaer Resolution open => fixed
2019-03-28 18:01 guilleaer Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker