Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040252
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Gift cards and gift vouchersmajoralways2019-02-21 11:012019-03-01 11:37
ReporterngarciaView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityurgentResolutionfixedFixed in VersionRR19Q2
StatusclosedFix in branchFixed in SCM revisione5569d9ba275
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040252: Cannot cancel a gift card instance if it does not include a payment

DescriptionCannot cancel a gift card instance if it does not include a payment
Steps To ReproduceIn the POS:
   Create a new receipt
   Set a business partner to it
   Add the following two products:
      Gift Card Infinite
      Gift Voucher
   Pay it

In the backoffice:
   Check two records have been created in Gift Card Instance window:
      one with Based on Product Gift Card type and one with Based on Voucher type
   Check both of them have the Payment field empty

   Try to launch the Cancel Gift Card process for them and check the following error message is shown:
      Close Card Exception closing card: <>

   The log shows:
      
ERROR org.openbravo.retail.giftcards.process.CancelGiftCardProcessHandler - Exception closing card: %0
org.openbravo.base.exception.OBException: Exception closing gift card : <>
    at org.openbravo.retail.giftcards.process.GiftCardGLItemUtils.close(GiftCardGLItemUtils.java:92) ~[GiftCardGLItemUtils.class:?]
    at org.openbravo.retail.giftcards.process.GiftCardGLItemUtils.close(GiftCardGLItemUtils.java:68) ~[GiftCardGLItemUtils.class:?]
    at org.openbravo.retail.giftcards.process.GiftCardGLItemUtils.close(GiftCardGLItemUtils.java:63) ~[GiftCardGLItemUtils.class:?]
    at org.openbravo.retail.giftcards.process.CancelGiftCardProcessHandler.doExecute(CancelGiftCardProcessHandler.java:44) [CancelGiftCardProcessHandler.class:?]
    ...
Caused by: java.lang.NullPointerException
    at org.openbravo.retail.giftcards.process.GiftCardGLItemUtils.makeGiftCardTrans(GiftCardGLItemUtils.java:104) ~[GiftCardGLItemUtils.class:?]
    at org.openbravo.retail.giftcards.process.GiftCardGLItemUtils.close(GiftCardGLItemUtils.java:85) ~[GiftCardGLItemUtils.class:?]
    ... 54 more
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0040251 closedranjith_qualiantech_com Cancelled field is not set to Y when launching the Cancel Gift Card process in Gift Card Instance window 

-  Notes
(0110030)
hgbot (developer)
2019-02-22 12:37

Repository: erp/pmods/org.openbravo.retail.giftcards
Changeset: e5569d9ba275f5cd6c14a4d0326356d011622730
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Fri Feb 22 17:06:52 2019 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/e5569d9ba275f5cd6c14a4d0326356d011622730 [^]

Fixed issue 40252 : Validate GiftCard Instance with Payment when cancelleing it

* When cancelling the gift card, Reverse payment when GiftCard Instance payment is presents

---
M src/org/openbravo/retail/giftcards/process/GiftCardGLItemUtils.java
---

- Issue History
Date Modified Username Field Change
2019-02-21 11:01 ngarcia New Issue
2019-02-21 11:01 ngarcia Assigned To => Retail
2019-02-21 11:01 ngarcia Triggers an Emergency Pack => No
2019-02-21 11:02 ngarcia Issue Monitored: networkb
2019-02-21 12:37 rafaroda Relationship added related to 0040251
2019-02-21 14:33 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2019-02-22 06:17 ranjith_qualiantech_com Status new => scheduled
2019-02-22 12:37 hgbot Checkin
2019-02-22 12:37 hgbot Note Added: 0110030
2019-02-22 12:37 hgbot Status scheduled => resolved
2019-02-22 12:37 hgbot Resolution open => fixed
2019-02-22 12:37 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/e5569d9ba275f5cd6c14a4d0326356d011622730 [^]
2019-03-01 11:37 marvintm Review Assigned To => marvintm
2019-03-01 11:37 marvintm Status resolved => closed
2019-03-01 11:37 marvintm Fixed in Version => RR19Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker