Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040198
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2019-02-14 13:592019-03-05 11:35
ReporternicolasurizView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityhighResolutionfixedFixed in VersionRR19Q2
StatusclosedFix in branchFixed in SCM revisionbed7289ed194
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040198: Problem when synchronizing tickets that are already synched

DescriptionWhen synchronizing a ticket that was modified in Backend(for example) and delivered, but it was previously loaded in the POS, if the changes done were related to the orderlines and not to the order, the synchronized ticket is not being taken into account as a modified ticket. Only the lines have the updated attribute modified.
Steps To Reproduce1. Create and synch a ticket in WebPOS without any delivery
2. Load the ticket again in the POS.
3. Modify in the backend an orderline to deliver it. The order header has not been modified.
4. Synch the loaded ticket in the POS --> Check that the ticket can be synch without any error. It should be an error telling that the order is not fully updated.
Proposed SolutionCheck also the updated attribute of the orderlines.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0109982)
hgbot (developer)
2019-02-21 12:22

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: fd2a851dbf79ecff746fe7513d4565254a330ba0
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Thu Feb 21 16:52:05 2019 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/fd2a851dbf79ecff746fe7513d4565254a330ba0 [^]

Fixed issue 40198 : Validate POS OrderLines with Backoffice Orderline to check the Outdated data from POS

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
M src/org/openbravo/retail/posterminal/PaidReceiptLinesProperties.java
M web/org.openbravo.retail.posterminal/js/model/order.js
---
(0110129)
marvintm (developer)
2019-02-28 17:34

Fix seems to be correct, but it needs to be applied in more places:
- OrderLoader.java: in cancel&replace flow, some lines after the current change, around line 263
- CancelLayawayLoader
- ProcessVoidLayaway
(0110160)
hgbot (developer)
2019-03-02 11:44

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: bed7289ed19439d4886e83b706f1516fd1ccb6b5
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Sat Mar 02 16:13:57 2019 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/bed7289ed19439d4886e83b706f1516fd1ccb6b5 [^]

Fixed issue 40198 : Validate POS OrderLines with Backoffice Orderline to check the Outdated data from POS

* Validate Outdated data from POS order lines for CancelLayaway, VoidLayaway and Cancel & Replace

---
M src/org/openbravo/retail/posterminal/CancelLayawayLoader.java
M src/org/openbravo/retail/posterminal/OrderLoader.java
M src/org/openbravo/retail/posterminal/ProcessVoidLayaway.java
---

- Issue History
Date Modified Username Field Change
2019-02-14 13:59 nicolasuriz New Issue
2019-02-14 13:59 nicolasuriz Assigned To => Retail
2019-02-14 13:59 nicolasuriz Triggers an Emergency Pack => No
2019-02-19 07:10 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2019-02-19 07:10 ranjith_qualiantech_com Status new => scheduled
2019-02-21 12:22 hgbot Checkin
2019-02-21 12:22 hgbot Note Added: 0109982
2019-02-21 12:22 hgbot Status scheduled => resolved
2019-02-21 12:22 hgbot Resolution open => fixed
2019-02-21 12:22 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/fd2a851dbf79ecff746fe7513d4565254a330ba0 [^]
2019-02-28 17:34 marvintm Note Added: 0110129
2019-02-28 17:34 marvintm Status resolved => new
2019-02-28 17:34 marvintm Resolution fixed => open
2019-03-01 14:38 ranjith_qualiantech_com Status new => scheduled
2019-03-02 11:44 hgbot Checkin
2019-03-02 11:44 hgbot Note Added: 0110160
2019-03-02 11:44 hgbot Status scheduled => resolved
2019-03-02 11:44 hgbot Resolution open => fixed
2019-03-02 11:44 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/fd2a851dbf79ecff746fe7513d4565254a330ba0 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/bed7289ed19439d4886e83b706f1516fd1ccb6b5 [^]
2019-03-05 11:35 guilleaer Review Assigned To => guilleaer
2019-03-05 11:35 guilleaer Status resolved => closed
2019-03-05 11:35 guilleaer Fixed in Version => RR19Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker