Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040190
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 03. Procurement managementmajoralways2019-02-13 15:032019-03-28 14:56
ReporterfranciscoView Statuspublic 
Assigned Tomarkmm82 
PriorityhighResolutionfixedFixed in Version3.0PR19Q2
StatusclosedFix in branchFixed in SCM revision30c40214364b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040190: Not possible to set Attributes opening a BackOffice session from POS

DescriptionThis case is happening when you a open a BackOffice session from the POS. when you try to select an attribute from Goods Receipts, the buttons in the pop up window (OK Cancel) doesn't work
Steps To Reproduce1. Open the POS and from there click in BackOffice
2. Go to Goods receipt window and create a line with a product that has attributes.
3. When you click the Attribute Set value there is a Pop Up window where you can select the attributes for that product.
4. Both buttons (OK, Cancel) are not working.

We found the following error:

AttributeSetInstance.html?Command=DISPLAY:29
Uncaught TypeError: theOpener.closeSearch is not a function
    at printMessage (AttributeSetInstance.html?Command=DISPLAY:29)
    at onload (AttributeSetInstance.html?Command=DISPLAY:94)
printMessage @ AttributeSetInstance.html?Command=DISPLAY:29
onload @ AttributeSetInstance.html?Command=DISPLAY:94
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0110445)
markmm82 (developer)
2019-03-14 17:25

Test Plan 1:
1. Open the POS and from there click in BackOffice
2. Go to Goods receipt window and create a line with a product that has attributes.
3. When you click the Attribute Set value there is a Pop Up window where you can select the attributes for that product.
4. Enter values for different attributes.
5. Press OK button and notice the popup is closed and the Attribute Set Value field is updated.
6. If you open the the Attribute pop up again and press the Cancel button the pop up is closed successfully.

Test Plan 2: Test accessing the Backoffice directly.
Log out and log in for Vallblanca Store (don't enter in the Web POS)
1. Repeat steps 2 to 6 and notice the Attribute Set popup is working correctly when you click in th OK and Cancel buttons.
(0110556)
hgbot (developer)
2019-03-21 18:13

Repository: erp/devel/pi
Changeset: 30c40214364b7dcfd6ac463e6e55023aa9ea02fc
Author: Mark Molina <mark.molina <at> doceleguas.com>
Date: Thu Mar 14 12:23:44 2019 -0300
URL: http://code.openbravo.com/erp/devel/pi/rev/30c40214364b7dcfd6ac463e6e55023aa9ea02fc [^]

Fixes issue 40190: Not possible to set Attributes opening BackOffice from POS

Was not possible to set Attributes opening a BackOffice session from POS because
an incorrect selection of the opener.

Now to select the opener is asked if it has the closeSearch function registered
and also it is included the getFrame('LayoutMDI').parent object for cases where
is coming from POS

---
M src/org/openbravo/erpCommon/info/AttributeSetInstance.html
---
(0110557)
dmiguelez (developer)
2019-03-21 18:13

Code Review + Testing Ok
(0110881)
hudsonbot (developer)
2019-03-28 14:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-02-13 15:03 francisco New Issue
2019-02-13 15:03 francisco Assigned To => Triage Finance
2019-02-13 15:03 francisco Modules => Core
2019-02-13 15:03 francisco Triggers an Emergency Pack => No
2019-02-13 15:08 francisco Summary Not possible to set Atrributtes opening a Backoffice session from POS => Not possible to set Attributes opening a BackOffice session from POS
2019-02-13 15:10 francisco Description Updated View Revisions
2019-02-13 15:10 francisco Steps to Reproduce Updated View Revisions
2019-03-05 12:39 francisco Type design defect => defect
2019-03-06 10:13 Sandrahuguet Assigned To Triage Finance => markmm82
2019-03-14 14:18 markmm82 Status new => scheduled
2019-03-14 17:25 markmm82 Note Added: 0110445
2019-03-15 09:09 psanjuan Description Updated View Revisions
2019-03-21 18:13 hgbot Checkin
2019-03-21 18:13 hgbot Note Added: 0110556
2019-03-21 18:13 hgbot Status scheduled => resolved
2019-03-21 18:13 hgbot Resolution open => fixed
2019-03-21 18:13 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/30c40214364b7dcfd6ac463e6e55023aa9ea02fc [^]
2019-03-21 18:13 dmiguelez Review Assigned To => dmiguelez
2019-03-21 18:13 dmiguelez Note Added: 0110557
2019-03-21 18:13 dmiguelez Status resolved => closed
2019-03-21 18:13 dmiguelez Fixed in Version => 3.0PR19Q2
2019-03-28 14:56 hudsonbot Checkin
2019-03-28 14:56 hudsonbot Note Added: 0110881


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker