Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040162
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2019-02-06 13:082019-02-18 09:57
ReporteraaroncaleroView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityhighResolutionfixedFixed in VersionRR19Q2
StatusclosedFix in branchFixed in SCM revision63451d02ea07
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression levelProduction - Confirmed Stable
Regression date2017-08-23
Regression introduced in releaseRR17Q2.4
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/443b0a0eb45eeca9e03efe0080f6632ad046c624 [^]
Triggers an Emergency PackNo
Summary

0040162: It is not possible to do login in remote mode if one product category is not active

DescriptionWhen there is one product category deactivated in the backend, and the Remote Mode For Products is enabled, the fullrefresh process is returning an error in ProductCategory model.
Steps To ReproduceLogin in backend and configure the Enable Remote for Product preference.
Go to the category window and disable a category used in Web POS (i.e. Backpacks & Travel)

Try to login in webpos.
A Master Data Loading Error popup will be shown with the error message:
[...] The following model(s) could not be loaded: ProductCategory. [...]
Proposed SolutionThe ProductCategory model uses different queries depending on the Enable Remote for Product preference.
With issue 0037283 only the non-remote query was fixed.

It is needed to add the fullRefreshCondition also to the remote query.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0037283 closedjorge-garcia It is not possible to do login if one product category is not active 
depends on backport 0040228RR19Q1 closedranjith_qualiantech_com It is not possible to do login in remote mode if one product category is not active 
depends on backport 0040229RR18Q4.2 closedranjith_qualiantech_com It is not possible to do login in remote mode if one product category is not active 
depends on backport 0040230RR18Q3.5 closedranjith_qualiantech_com It is not possible to do login in remote mode if one product category is not active 
caused by defect 0036654 closedjorge-garcia A sanity check must be added to the login to avoid some scenarios with corrupted data 

-  Notes
(0109660)
hgbot (developer)
2019-02-11 06:43

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 63451d02ea071b1cf7e92f516266e955030993ce
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Mon Feb 11 11:12:45 2019 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/63451d02ea071b1cf7e92f516266e955030993ce [^]

Fixed issue 40162 : Updated Product Category Query to support incrementalUpdateCriteria

* Updated Product Category and Category Tree Query to support incrementalUpdateCriteria in both normal and full refresh mode

---
M src/org/openbravo/retail/posterminal/master/Category.java
M src/org/openbravo/retail/posterminal/master/CategoryTree.java
---

- Issue History
Date Modified Username Field Change
2019-02-06 13:08 aaroncalero New Issue
2019-02-06 13:08 aaroncalero Assigned To => Retail
2019-02-06 13:08 aaroncalero Regression level => Production - Confirmed Stable
2019-02-06 13:08 aaroncalero Regression date => 2017-08-23
2019-02-06 13:08 aaroncalero Regression introduced in release => RR17Q2.4
2019-02-06 13:08 aaroncalero Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/443b0a0eb45eeca9e03efe0080f6632ad046c624 [^]
2019-02-06 13:08 aaroncalero Triggers an Emergency Pack => No
2019-02-06 13:09 aaroncalero Relationship added related to 0037283
2019-02-06 13:09 aaroncalero Relationship added caused by 0036654
2019-02-08 07:20 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2019-02-08 07:20 ranjith_qualiantech_com Status new => scheduled
2019-02-11 06:43 hgbot Checkin
2019-02-11 06:43 hgbot Note Added: 0109660
2019-02-11 06:43 hgbot Status scheduled => resolved
2019-02-11 06:43 hgbot Resolution open => fixed
2019-02-11 06:43 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/63451d02ea071b1cf7e92f516266e955030993ce [^]
2019-02-18 09:57 marvintm Status resolved => new
2019-02-18 09:57 marvintm Resolution fixed => open
2019-02-18 09:57 marvintm Status new => scheduled
2019-02-18 09:57 marvintm Status scheduled => resolved
2019-02-18 09:57 marvintm Fixed in Version => RR19Q2
2019-02-18 09:57 marvintm Resolution open => fixed
2019-02-18 09:57 marvintm Review Assigned To => marvintm
2019-02-18 09:57 marvintm Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker