Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037283
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2017-11-13 14:222018-01-25 15:57
ReportermalsasuaView Statuspublic 
Assigned Tojorge-garcia 
PrioritynormalResolutionfixedFixed in VersionRR18Q1
StatusclosedFix in branchFixed in SCM revisionbbdcac728f0d
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression levelProduction - Confirmed Stable
Regression date2017-08-23
Regression introduced in releaseRR17Q2.4
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/443b0a0eb45eeca9e03efe0080f6632ad046c624 [^]
Triggers an Emergency PackNo
Summary

0037283: It is not possible to do login if one product category is not active

Descriptionwhen there is one product category deactivated in the backend, the fullrefresh process is returning error in ProductCategoryTree model
Steps To Reproducein backoffice:
. go to product category window:
 . record: ski -> active=N

in POS:
. do login
Error is returned:

The Master Data loading process has encountered an error. The following model(s) could not be loaded: ProductCategoryTree. Please check you internet connection and click reload to refresh the page. If the problem persists please contact your System Administrator.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0037285RR17Q4 closedjorge-garcia It is not possible to do login if one product category is not active 
depends on backport 0037286RR17Q3.2 closedjorge-garcia It is not possible to do login if one product category is not active 
caused by defect 0036654 closedjorge-garcia A sanity check must be added to the login to avoid some scenarios with corrupted data 
related to defect 0040162 closedranjith_qualiantech_com It is not possible to do login in remote mode if one product category is not active 

-  Notes
(0100553)
hgbot (developer)
2017-11-16 16:46

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: bbdcac728f0d49345f677d3a50d1ad509deb62c6
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Wed Nov 15 09:29:26 2017 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/bbdcac728f0d49345f677d3a50d1ad509deb62c6 [^]

Fixed issue 37283: It is not possible to do login if one product category
is not active

With the new sanity check for masterdata models it’s necessary to not
load records deactivated during a full refresh.

During a incremental refresh, it’s necessary to recover the status of
category tree if needed.

---
M src/org/openbravo/retail/posterminal/master/Category.java
M src/org/openbravo/retail/posterminal/master/CategoryTree.java
---
(0101948)
hgbot (developer)
2018-01-25 15:57

Repository: tools/automation/pi-mobile
Changeset: c0dca07db25efa540fe8c29c0bf6a5bd85d82f11
Author: Alejandro <alekosmp86 <at> gmail.com>
Date: Wed Jan 17 17:41:05 2018 -0500
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/c0dca07db25efa540fe8c29c0bf6a5bd85d82f11 [^]

Verifies issue 37283: Added automated test 'I37283_VerifyLoginWithProductCategNotActive'

---
A src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/categorytree/I37283_VerifyLoginWithProductCategNotActive.java
---

- Issue History
Date Modified Username Field Change
2017-11-13 14:22 malsasua New Issue
2017-11-13 14:22 malsasua Assigned To => Retail
2017-11-13 14:22 malsasua Regression level => Production - Confirmed Stable
2017-11-13 14:22 malsasua Triggers an Emergency Pack => No
2017-11-13 14:56 Practics Issue Monitored: Practics
2017-11-14 10:40 jorge-garcia Status new => scheduled
2017-11-14 10:40 jorge-garcia Assigned To Retail => jorge-garcia
2017-11-16 16:46 hgbot Checkin
2017-11-16 16:46 hgbot Note Added: 0100553
2017-11-16 16:46 hgbot Status scheduled => resolved
2017-11-16 16:46 hgbot Resolution open => fixed
2017-11-16 16:46 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/bbdcac728f0d49345f677d3a50d1ad509deb62c6 [^]
2017-11-17 10:43 jorge-garcia Regression date => 2017-08-23
2017-11-17 10:43 jorge-garcia Regression introduced in release => main
2017-11-17 10:43 jorge-garcia Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/443b0a0eb45eeca9e03efe0080f6632ad046c624 [^]
2017-11-17 10:44 jorge-garcia Relationship added caused by 0036654
2017-11-17 13:21 marvintm Review Assigned To => marvintm
2017-11-17 13:21 marvintm Status resolved => closed
2017-11-17 13:21 marvintm Fixed in Version => RR18Q1
2017-11-17 13:22 marvintm Regression introduced in release main => RR17Q2.4
2018-01-25 15:57 hgbot Checkin
2018-01-25 15:57 hgbot Note Added: 0101948
2019-02-06 13:09 aaroncalero Relationship added related to 0040162


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker