Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0040160
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Y. DBSourceManagerminorhave not tried2019-02-06 12:542019-02-18 16:04
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR19Q2
StatusclosedFix in branchFixed in SCM revisionaa473ad13ee3
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0040160: Avoid delay per exported module in export.database

DescriptionThere is a delay in export.database per exported module. Having a big amount of modules this delay can cause that the task lasting several minutes until it is completed.
Steps To Reproduce1) Set all modules in "in development"
2) Run ant export.database
3) Note that there is a delay per exported module:

     [java] 87769 [main] INFO org.openbravo.ddlutils.task.ExportDatabase - Exporting module: 2.50 to 3.00 Compatibility Skin
     [java] 87779 [main] INFO org.openbravo.ddlutils.task.ExportDatabase - Database [name=PostgreSql server; 551 tables; 0 sequences; 47 views; 311 functions; 319 triggers]
     [java] 90722 [main] INFO org.openbravo.ddlutils.util.DBSMOBUtil - Loading data from XML files <-- Note delay of 2943 milliseconds
....
     [java] 94521 [main] INFO org.openbravo.ddlutils.task.ExportDatabase - Exporting module: Apache External Connection Pool
     [java] 94532 [main] INFO org.openbravo.ddlutils.task.ExportDatabase - Database [name=PostgreSql server; 551 tables; 0 sequences; 47 views; 311 functions; 319 triggers]
     [java] 96271 [main] INFO org.openbravo.ddlutils.util.DBSMOBUtil - Loading data from XML files <-- Note delay of 1739 milliseconds
...
     [java] 96535 [main] INFO org.openbravo.ddlutils.task.ExportDatabase - Exporting module: Core
     [java] 96547 [main] INFO org.openbravo.ddlutils.task.ExportDatabase - Database [name=PostgreSql server; 551 tables; 0 sequences; 47 views; 311 functions; 319 triggers]
     [java] 98047 [main] INFO org.openbravo.ddlutils.util.DBSMOBUtil - Loading data from XML files <-- Note delay of 1500 seconds
...
TagsPerformance
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0040210 newplatform Integrate standard export database process into the DBSM test infrastructure 
related to defect 0040227 resolvedalostale confusing export.database log 
related to backport 00402353.0PR19Q1 resolvedcaristu Avoid delay per exported module in export.database 

-  Notes
(0109843)
hgbot (developer)
2019-02-14 18:21

Repository: erp/devel/dbsm-main
Changeset: aa473ad13ee3bbd7b52363a2d38d5423c143d34a
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Feb 14 17:59:31 2019 +0100
URL: http://code.openbravo.com/erp/devel/dbsm-main/rev/aa473ad13ee3bbd7b52363a2d38d5423c143d34a [^]

fixes bug 40160: Avoid delay per exported module in export.database

  Before exporting the source data of the modules in "in development" status, the model is reloaded from the previously exported XML model files. This is done to ensure that the source data is exported using the same order of the columns which is defined in the XML files, instead of using the order in the database because this can be different.

  For example, the order can be different in the database when adding a new column to a table. The new column will be added at the last position, because the table will not be recreated. But if this new column is not the last one in the XML file that defines the table, then under this scenario the order of the columns in the database will be different from the order in the XML file.

  This model reloading was being done per every module being exported. This is not needed as the model does not change at this point, so it can be reloaded just once, right before starting the exportation of the source data.

---
M src/org/openbravo/ddlutils/task/ExportDatabase.java
---
(0109844)
hgbot (developer)
2019-02-14 18:21

Repository: erp/devel/dbsm-main
Changeset: 99d740ff328656b961560e274c6f357c1430461f
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Feb 14 18:16:46 2019 +0100
URL: http://code.openbravo.com/erp/devel/dbsm-main/rev/99d740ff328656b961560e274c6f357c1430461f [^]

related to issue 40160: add test case

 This test should be completed once the test infrastructure is ready for it. See issue https://issues.openbravo.com/view.php?id=40210 [^]

---
M src-test/src/org/openbravo/dbsm/test/model/ModelSuite.java
A src-test/data/columnOrder/TEST.xml
A src-test/src/org/openbravo/dbsm/test/model/recreation/ColumnOrderOnExport.java
---
(0109845)
hgbot (developer)
2019-02-14 18:23

Repository: erp/devel/pi
Changeset: 48bd5af1230a00751aa8aae225519a9451af1267
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Feb 14 18:23:00 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/48bd5af1230a00751aa8aae225519a9451af1267 [^]

related to issue 40160: Update DBSM library

---
M src-db/database/lib/dbsourcemanager.jar
---
(0109855)
alostale (developer)
2019-02-15 11:04

reviewed + tested

- Issue History
Date Modified Username Field Change
2019-02-06 12:54 caristu New Issue
2019-02-06 12:54 caristu Assigned To => caristu
2019-02-06 12:54 caristu Modules => Core
2019-02-06 12:54 caristu Triggers an Emergency Pack => No
2019-02-06 13:12 caristu Description Updated View Revisions
2019-02-06 16:51 caristu Steps to Reproduce Updated View Revisions
2019-02-06 16:52 caristu Steps to Reproduce Updated View Revisions
2019-02-06 16:53 caristu Status new => scheduled
2019-02-14 17:25 caristu Relationship added related to 0040210
2019-02-14 18:21 hgbot Checkin
2019-02-14 18:21 hgbot Note Added: 0109843
2019-02-14 18:21 hgbot Status scheduled => resolved
2019-02-14 18:21 hgbot Resolution open => fixed
2019-02-14 18:21 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/dbsm-main/rev/aa473ad13ee3bbd7b52363a2d38d5423c143d34a [^]
2019-02-14 18:21 hgbot Checkin
2019-02-14 18:21 hgbot Note Added: 0109844
2019-02-14 18:23 hgbot Checkin
2019-02-14 18:23 hgbot Note Added: 0109845
2019-02-14 18:24 caristu Review Assigned To => alostale
2019-02-15 11:04 alostale Note Added: 0109855
2019-02-15 11:04 alostale Status resolved => closed
2019-02-15 11:04 alostale Fixed in Version => 3.0PR19Q2
2019-02-18 09:21 alostale Relationship added related to 0040227
2019-02-18 16:02 caristu Issue cloned 0040235
2019-02-18 16:02 caristu Relationship added related to 0040235
2019-02-18 16:04 caristu Tag Attached: Performance


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker