Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039889
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2019-01-09 11:092019-03-28 14:55
ReporterngarciaView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityimmediateResolutionfixedFixed in Version3.0PR19Q2
StatusclosedFix in branchFixed in SCM revisionaa95d0940466
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2018-06-20
Regression introduced in release3.0PR18Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/58cf1a94960f [^]
Triggers an Emergency PackNo
Summary

0039889: Cannot process a Simple G/L Journal with Open Items option selected on a line

DescriptionCannot process a Simple G/L Journal with Open Items option selected on a line
Steps To ReproduceAs group admin role:
   Create a Simple G/L Journal:
      Organization: F&B US East Coast
      General Ledger: F&B International Group US/A/US Dollar
   Add a line to it:
      Account: 1110 - Checking Account
      Debit: 100
      Open Items: Y
      Select Financial Account, Payment Method, G/L Item and Payment Date
   Add another line to it:
      Account: 1120 - Funds In-Transfer
      Credit: 100
      Open Items: N
   Try to complete it and check the following error is shown:
      java.lang.IllegalArgumentException: Type specified for TypedQuery [org.openbravo.erpCommon.ad_forms.AcctSchema] is incompatible with query return type [class org.openbravo.model.financialmgmt.accounting.coa.AcctSchema]
TagsNo tags attached.
Attached Filesdiff file icon 39889_Proposed.diff [^] (1,496 bytes) 2019-01-09 13:12 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00398913.0PR19Q1 closedAtulOpenbravo Cannot process a Simple G/L Journal with Open Items option selected on a line 
depends on backport 00398923.0PR18Q4.2 closedAtulOpenbravo Cannot process a Simple G/L Journal with Open Items option selected on a line 
caused by feature request 0037064 closedcaristu upgrade hibernate 
blocks defect 0039895 closedAtulOpenbravo Simple G/L Journal line can be removed although it has related payment. Payment can be deleted although the journal is processed 

-  Notes
(0108867)
AtulOpenbravo (developer)
2019-01-09 12:56

Test Plan

- As group admin role:
- Create a Simple G/L Journal:
      Organization: F&B US East Coast
      General Ledger: F&B International Group US/A/US Dollar
- Add a line to it:
      Account: 1110 - Checking Account
      Debit: 100
      Open Items: Y
      Select Financial Account, Payment Method, G/L Item and Payment Date.
- Add another line to it:
      Account: 1120 - Funds In-Transfer
      Credit: 100
      Open Items: N
- Try to complete it.
- Realize that Journal is completed successfully.
(0108882)
hgbot (developer)
2019-01-10 10:19

Repository: erp/devel/pi
Changeset: aa95d094046650f81968414c12e9fa38543dc117
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Thu Jan 10 12:26:05 2019 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/aa95d094046650f81968414c12e9fa38543dc117 [^]

Fixes Issue 39889:Cannot process a Simple G/L Journal with
Open Items option selected on a line

Type of typed query was wrongly mentioned during hibernate
upgrade, org.openbravo.model.financialmgmt.accounting.coa.AcctSchema
required instead of org.openbravo.erpCommon.ad_forms.AcctSchema

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/process/FIN_AddPaymentFromJournalLine.java
---
(0108885)
Sandrahuguet (developer)
2019-01-10 10:20

Code review + testing ok
(0110718)
hudsonbot (developer)
2019-03-28 14:55

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2019-01-09 11:09 ngarcia New Issue
2019-01-09 11:09 ngarcia Assigned To => Triage Finance
2019-01-09 11:09 ngarcia Modules => Core
2019-01-09 11:09 ngarcia Triggers an Emergency Pack => No
2019-01-09 11:11 ngarcia Issue Monitored: networkb
2019-01-09 11:22 Sandrahuguet Assigned To Triage Finance => AtulOpenbravo
2019-01-09 12:50 AtulOpenbravo Regression date => 2018-06-20
2019-01-09 12:50 AtulOpenbravo Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/58cf1a94960f [^]
2019-01-09 12:52 Sandrahuguet Regression level => Production - QA Approved
2019-01-09 12:54 AtulOpenbravo Status new => scheduled
2019-01-09 12:54 Sandrahuguet Regression introduced in release => 3.0PR18Q4
2019-01-09 12:56 AtulOpenbravo Note Added: 0108867
2019-01-09 12:56 AtulOpenbravo Status scheduled => acknowledged
2019-01-09 13:04 AtulOpenbravo Status acknowledged => scheduled
2019-01-09 13:12 AtulOpenbravo File Added: 39889_Proposed.diff
2019-01-09 13:21 ngarcia Summary Cannot process a Simple G/L Item with Open Items option selected on a line => Cannot process a Simple G/L Journal with Open Items option selected on a line
2019-01-09 13:21 ngarcia Description Updated View Revisions
2019-01-09 13:21 ngarcia Description Updated View Revisions
2019-01-09 13:29 ngarcia Relationship added blocks 0039895
2019-01-10 10:19 hgbot Checkin
2019-01-10 10:19 hgbot Note Added: 0108882
2019-01-10 10:19 hgbot Status scheduled => resolved
2019-01-10 10:19 hgbot Resolution open => fixed
2019-01-10 10:19 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/aa95d094046650f81968414c12e9fa38543dc117 [^]
2019-01-10 10:20 Sandrahuguet Review Assigned To => Sandrahuguet
2019-01-10 10:20 Sandrahuguet Note Added: 0108885
2019-01-10 10:20 Sandrahuguet Status resolved => closed
2019-01-10 10:20 Sandrahuguet Fixed in Version => 3.0PR19Q2
2019-01-11 11:09 alostale Relationship added caused by 0037064
2019-03-28 14:55 hudsonbot Checkin
2019-03-28 14:55 hudsonbot Note Added: 0110718


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker