Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039859
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2018-12-27 16:302019-01-03 09:12
ReporterLeyreView Statuspublic 
Assigned ToAugustoMauch 
PriorityurgentResolutionfixedFixed in Version3.0PR19Q2
StatusclosedFix in branchFixed in SCM revision4f9bcd0a6fff
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2018-05-18
Regression introduced in release3.0PR18Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/3404760330bcfea180a7869095eefbabf5e760e0 [^]
Triggers an Emergency PackNo
Summary

0039859: Reconciliation reports not generated

DescriptionWhen the printing of the reconciliation reports is launched, the popup remains frozen and no report is generated.
Steps To ReproduceBackend:
1. Open "Financial Account" window.
2. Select the "Reconciliations" tab of an account with information in this tab.
3. Select any Reconciliation
4. Press Reconciliation Details or Reconciliation Summary buttons

Verify that the pop-up remains frozen and no report is generated.
Proposed SolutionThe log shows a non-existent jrxml error.
It seems that in version 18Q3 a new class "ReportCompiler.java" was inserted that modified the previous way to compile / execute jasper subreports.
This class extracts the name of the subreports using the name of the parameter. In "ReportReconciliation.java", the name given to the parameter related to the Payments subreport is "SUBREP_PAYMENT".
According to this logic, when compiling the subreport, the jrxml "PAYMENT.jrxml" is searched, when in fact it is called "OutstandingPayment.jrxml".

It works incorrectly from version 18Q3
TagsNo tags attached.
Attached Filesdiff file icon subReportRefactor.diff [^] (6,786 bytes) 2018-12-28 13:19 [Show Content]
diff file icon subReportRefactor2.diff [^] (4,395 bytes) 2018-12-31 13:47 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0038588 newTriage Finance Refactor reports based on HttpSecureAppServlet.renderJR to avoid manual subreport compilation 
depends on backport 00398693.0PR19Q1 closedAugustoMauch Reconciliation reports not generated 
depends on backport 00398703.0PR18Q4.2 closedAugustoMauch Reconciliation reports not generated 
depends on backport 00398713.0PR18Q3.5 closedAugustoMauch Reconciliation reports not generated 
caused by feature request 0038518 closedcaristu Ability of compiling subreports with HttpSecureAppServlet.renderJR 

-  Notes
(0108789)
hgbot (developer)
2019-01-02 17:27

Repository: erp/devel/pi
Changeset: 4f9bcd0a6fff981c60cfff6196949beba5800b0d
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Dec 31 15:58:22 2018 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/4f9bcd0a6fff981c60cfff6196949beba5800b0d [^]

Fixes issue 39859: Replaces SUBREP_ prefix in report

The SUBREP_ prefix can only be used in a report parameter if there exists a jrxml file wich the same
name as the parameter suffix. Otherwise the report is not generated.

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/ad_reports/ReportReconciliation.java
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/ad_reports/ReportReconciliation.jrxml
---
(0108800)
hgbot (developer)
2019-01-03 08:44

Repository: erp/devel/pi
Changeset: 8688e0940a7d142419897c77d59840542e1b4d27
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Thu Jan 03 08:43:09 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/8688e0940a7d142419897c77d59840542e1b4d27 [^]

related to issue 39859 update copyright year

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/ad_reports/ReportReconciliation.java
---
(0108807)
Sandrahuguet (developer)
2019-01-03 09:12

Code review + testing OK

- Issue History
Date Modified Username Field Change
2018-12-27 16:30 Leyre New Issue
2018-12-27 16:30 Leyre Assigned To => Triage Finance
2018-12-27 16:30 Leyre Modules => Core
2018-12-27 16:30 Leyre Regression date => 2019-01-17
2018-12-27 16:30 Leyre Regression introduced in release => 3.0PR18Q3
2018-12-27 16:30 Leyre Triggers an Emergency Pack => No
2018-12-27 16:33 Leyre Regression date 2019-01-17 =>
2018-12-27 17:07 Sandrahuguet Relationship added related to 0038518
2018-12-27 17:07 Sandrahuguet Assigned To Triage Finance => AugustoMauch
2018-12-28 09:09 Sandrahuguet Steps to Reproduce Updated View Revisions
2018-12-28 13:18 AugustoMauch Assigned To AugustoMauch => Sandrahuguet
2018-12-28 13:19 AugustoMauch File Added: subReportRefactor.diff
2018-12-28 14:11 AugustoMauch Relationship replaced caused by 0038518
2018-12-28 14:11 AugustoMauch Relationship added related to 0038588
2018-12-28 14:47 Sandrahuguet Regression level => Production - Confirmed Stable
2018-12-28 14:47 Sandrahuguet Regression date => 2018-05-18
2018-12-28 14:47 Sandrahuguet Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/3404760330bcfea180a7869095eefbabf5e760e0 [^]
2018-12-28 14:47 Sandrahuguet Assigned To Sandrahuguet => platform
2018-12-31 13:47 AugustoMauch File Added: subReportRefactor2.diff
2018-12-31 13:49 AugustoMauch Assigned To platform => Triage Finance
2018-12-31 15:57 AugustoMauch Assigned To Triage Finance => AugustoMauch
2019-01-02 17:27 hgbot Checkin
2019-01-02 17:27 hgbot Note Added: 0108789
2019-01-02 17:27 hgbot Status new => resolved
2019-01-02 17:27 hgbot Resolution open => fixed
2019-01-02 17:27 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/4f9bcd0a6fff981c60cfff6196949beba5800b0d [^]
2019-01-02 17:27 AugustoMauch Status resolved => new
2019-01-02 17:27 AugustoMauch Resolution fixed => open
2019-01-02 18:39 AugustoMauch Status new => scheduled
2019-01-02 18:39 AugustoMauch Status scheduled => resolved
2019-01-02 18:39 AugustoMauch Resolution open => fixed
2019-01-03 08:44 hgbot Checkin
2019-01-03 08:44 hgbot Note Added: 0108800
2019-01-03 09:12 Sandrahuguet Review Assigned To => Sandrahuguet
2019-01-03 09:12 Sandrahuguet Note Added: 0108807
2019-01-03 09:12 Sandrahuguet Status resolved => closed
2019-01-03 09:12 Sandrahuguet Fixed in Version => 3.0PR19Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker