Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039598
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Cash upmajoralways2018-11-06 19:492018-12-04 13:25
ReportermalsasuaView Statuspublic 
Assigned Toranjith_qualiantech_com 
PrioritynormalResolutionfixedFixed in VersionRR19Q1
StatusclosedFix in branchFixed in SCM revision060d9bc5396a
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039598: In cashup, Invoice is not created with "Save Removed Tickets" preference active and Sales Order with one line deleted

Descriptionwhen preference Save Removed Tickets is enabled, and a Sales Order has got a deleted line, the invoice is not created during CAshup Process for this Sales Order.
Steps To ReproduceBO:
. enable Save REmoved Ticket preference

POS:
. create new Sales Order docno=SO1:
 . add line
 . complete
. create new Sales Order docno=SO2:
 . chage BP: Arturo Montoro
 . add line
 . add line
 . detete previous line
 . complete
. do cashup

BO:
. invoice has been created to SO1 but not to SO2
Proposed Solutionin org.openbravo.retail.posterminal/src/org/openbravo/retail/posterminal/OrderGroupingProcessor_data.xsql file:
condition
and not exists (select 1 from c_orderline ol2 where
        (ol2.qtyinvoiced <> 0 or ol2.qtyordered = 0 or ol2.qtydelivered <> ol2.qtyordered)
        and ol2.c_order_id = o.c_order_id)

shold be modified. The qtyordered of line deleted is 0, and it is not satisfying this condition.

It should be modified in all methods
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0045204 closedranjith_qualiantech_com Invoice should not be created for deleted ticket when doing cashup 

-  Notes
(0107928)
hgbot (developer)
2018-11-15 10:20

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 858b91018c05ef3d851ebea88aa454cb67ea20a8
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Thu Nov 15 14:50:12 2018 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/858b91018c05ef3d851ebea88aa454cb67ea20a8 [^]

Fixed issue 39598 : Modified OrderGroupingProcessorData to save invoice line with qty as 0

* If Save Remove ticker Pref. is enabled, Orderline quantity will saved as zero.
  While doing Cashup, Invoice and Invoice lines are not created due to line quantity as 0
  So, added em_obpos_isdeleted validation in addition with Orderline quantity for generating invoice and invoiceline during cashup

---
M src/org/openbravo/retail/posterminal/OrderGroupingProcessor_data.xsql
---
(0107929)
hgbot (developer)
2018-11-15 10:20

Repository: tools/automation/pi-mobile
Changeset: 27746e2782cf4c0eda1a15da584a14ca6d209002
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Thu Nov 15 14:50:40 2018 +0530
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/27746e2782cf4c0eda1a15da584a14ca6d209002 [^]

Verifies issue 39598 : Added Automated Test 'I39598_VerifyInvoiceAfterCashUpWithSaveRemovePref'

---
A src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/cashup/I39598_VerifyInvoiceAfterCashUpWithSaveRemovePref.java
---
(0107945)
marvintm (developer)
2018-11-16 11:48

Fix is not correct.

The first part of the fix (first three changes) makes sense, because we want to ensure that tickets which contain one deleted line are taken into account when creating the cashup invoice.

However, the second part (last two changes) is not correct, because even though we want to consider those tickets, we don't want to invoice lines which have been deleted, only lines which have not been.

So, currently, if you create a ticket which contains lines which are not deleted together with lines which have been deleted, all lines are invoiced, and this is wrong (only non-deleted lines should be invoiced). If you delete a ticket, all its lines are also invoiced, and this is also wrong (in this case no lines should be invoiced).

I think just removing the two last changes should achieve the desired behaviour.
(0107996)
hgbot (developer)
2018-11-20 06:56

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 060d9bc5396ac52ceaca9ab65f93cd1cfe438a79
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue Nov 20 11:26:14 2018 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/060d9bc5396ac52ceaca9ab65f93cd1cfe438a79 [^]

Fixed issue 39598 : Modified OrderGroupingProcessorData to save invoice if one lines with qty

* If all the lines have quantity zero, then Invoice and Invoice lines should not be created
* If any one lines have quantity greater than zero, then Invoice and Invoice lines should be created

---
M src/org/openbravo/retail/posterminal/OrderGroupingProcessor_data.xsql
---
(0107997)
hgbot (developer)
2018-11-20 06:56

Repository: tools/automation/pi-mobile
Changeset: 2fc2c5f729fedb983f128b368c940f077c3aef09
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue Nov 20 11:26:24 2018 +0530
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/2fc2c5f729fedb983f128b368c940f077c3aef09 [^]

Verifies issue 39598 : Modified Automated Test 'I39598_VerifyInvoiceAfterCashUpWithSaveRemovePref'

* Added New Case for verifying the receipt and invoice by deleteing the whole receipt with Save Remove Ticket Preference

---
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/cashup/I39598_VerifyInvoiceAfterCashUpWithSaveRemovePref.java
---

- Issue History
Date Modified Username Field Change
2018-11-06 19:49 malsasua New Issue
2018-11-06 19:49 malsasua Assigned To => Retail
2018-11-06 19:49 malsasua Resolution time => 1543186800
2018-11-06 19:49 malsasua Triggers an Emergency Pack => No
2018-11-09 08:58 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2018-11-12 10:50 ranjith_qualiantech_com Status new => scheduled
2018-11-15 10:20 hgbot Checkin
2018-11-15 10:20 hgbot Note Added: 0107928
2018-11-15 10:20 hgbot Status scheduled => resolved
2018-11-15 10:20 hgbot Resolution open => fixed
2018-11-15 10:20 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/858b91018c05ef3d851ebea88aa454cb67ea20a8 [^]
2018-11-15 10:20 hgbot Checkin
2018-11-15 10:20 hgbot Note Added: 0107929
2018-11-16 11:48 marvintm Note Added: 0107945
2018-11-16 11:48 marvintm Status resolved => new
2018-11-16 11:48 marvintm Resolution fixed => open
2018-11-19 11:56 ranjith_qualiantech_com Status new => scheduled
2018-11-20 06:56 hgbot Checkin
2018-11-20 06:56 hgbot Note Added: 0107996
2018-11-20 06:56 hgbot Status scheduled => resolved
2018-11-20 06:56 hgbot Resolution open => fixed
2018-11-20 06:56 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/858b91018c05ef3d851ebea88aa454cb67ea20a8 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/060d9bc5396ac52ceaca9ab65f93cd1cfe438a79 [^]
2018-11-20 06:56 hgbot Checkin
2018-11-20 06:56 hgbot Note Added: 0107997
2018-12-04 13:25 marvintm Review Assigned To => marvintm
2018-12-04 13:25 marvintm Status resolved => closed
2018-12-04 13:25 marvintm Fixed in Version => RR19Q1
2020-11-12 14:11 ngarcia Relationship added related to 0045204


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker