Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039578
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformmajoralways2018-11-01 08:282018-11-02 10:38
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PriorityurgentResolutionfixedFixed in Version3.0PR18Q3.3
StatusclosedFix in branchFixed in SCM revision091e374d8f51
ProjectionnoneETAnoneTarget Version3.0PR18Q3.3
OSAnyDatabaseAnyJava version10+
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039578: JDK 10+: cannot send email

DescriptionIt is not possible to send emails using Java 10 or 11.
Steps To Reproduce1. Open Client window and configure Email settings tabs
2. Create and complete a Sales Invoice
3. Click on Email toolbar button and send it
  -> ERROR: "An unexpected error has occurred"
   In logs:
java.lang.NoClassDefFoundError: com/sun/activation/registries/LogSupport
    at javax.activation.MailcapCommandMap.<init>(MailcapCommandMap.java:179)
    at javax.activation.CommandMap.getDefaultCommandMap(CommandMap.java:85)
    at javax.activation.DataHandler.getCommandMap(DataHandler.java:167)
    at javax.activation.DataHandler.getDataContentHandler(DataHandler.java:629)
    at javax.activation.DataHandler.writeTo(DataHandler.java:329)
    at javax.mail.internet.MimeUtility.getEncoding(MimeUtility.java:340)
    at javax.mail.internet.MimeBodyPart.updateHeaders(MimeBodyPart.java:1573)
    at javax.mail.internet.MimeBodyPart.updateHeaders(MimeBodyPart.java:1172)
    at javax.mail.internet.MimeMultipart.updateHeaders(MimeMultipart.java:522)
    at javax.mail.internet.MimeBodyPart.updateHeaders(MimeBodyPart.java:1531)
    at javax.mail.internet.MimeMessage.updateHeaders(MimeMessage.java:2271)
    at javax.mail.internet.MimeMessage.saveChanges(MimeMessage.java:2231)
    at javax.mail.internet.MimeMessage.writeTo(MimeMessage.java:1910)
    at com.sun.mail.smtp.SMTPTransport.sendMessage(SMTPTransport.java:1315)
    at org.openbravo.erpCommon.utility.poc.EmailManager.sendEmail(EmailManager.java:224)
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0039576 closedalostale JDK 9+: cannot send email 

-  Notes
(0107709)
hgbot (developer)
2018-11-01 12:24

Repository: erp/backports/3.0PR18Q3.3
Changeset: 091e374d8f51c5927da6bd6ec37cfb1af91c8dac
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Nov 01 09:54:53 2018 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR18Q3.3/rev/091e374d8f51c5927da6bd6ec37cfb1af91c8dac [^]

fixed bug 39578: cannot send email with JDK9+

  It was not possible because mail libraries relies on some classes that were
  in hidden modules by default starting from JDK 9 and completelly removed in
  11.

  Fixed by replacing javax.activation-api-1.2.0 by javax.activation-1.2.0
  (com.sun.activation:javax.activation).

  Note javax.activation-api is not purely an API but it also includes implementation
  for classes in javax.activation package (which was included in previous JDKs)
  but it depends on classes in com.sun.activation which have also been removed
  from JDK and not included in activation-api jar but yes in activation one.

  The contents of javax.activation package are identicall in both jars.

  Note also javax.mail-1.6.1 depends on activation-1.1 (javax.activation:activation)
  to manage MIME data, that version was released in 2009; newer javax.activation-1.2.0
  (2017) has same API including new fixes.

---
M legal/Licensing.txt
M modules/org.openbravo.apachejdbcconnectionpool/src/org/openbravo/apachejdbcconnectionpool/JdbcExternalConnectionPool.java
A lib/runtime/javax.activation-1.2.0.jar
R lib/runtime/javax.activation-api-1.2.0.jar
---
(0107710)
hgbot (developer)
2018-11-01 12:43

Repository: erp/backports/3.0PR18Q3.3
Changeset: f6b82d4591f7e5ef0376d517c1b6860dc82393e9
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Nov 01 12:43:40 2018 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR18Q3.3/rev/f6b82d4591f7e5ef0376d517c1b6860dc82393e9 [^]

related to bug 39578: partial back out of changeset 091e374d8f51c592

  as it contained unintended unrelated changes

---
M modules/org.openbravo.apachejdbcconnectionpool/src/org/openbravo/apachejdbcconnectionpool/JdbcExternalConnectionPool.java
---
(0107718)
AugustoMauch (developer)
2018-11-02 10:38

Code reviewed and verified

- Issue History
Date Modified Username Field Change
2018-11-01 08:30 alostale Type defect => backport
2018-11-01 08:30 alostale Target Version => 3.0PR18Q3.3
2018-11-01 12:24 hgbot Checkin
2018-11-01 12:24 hgbot Note Added: 0107709
2018-11-01 12:24 hgbot Status scheduled => resolved
2018-11-01 12:24 hgbot Resolution open => fixed
2018-11-01 12:24 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR18Q3.3/rev/091e374d8f51c5927da6bd6ec37cfb1af91c8dac [^]
2018-11-01 12:43 hgbot Checkin
2018-11-01 12:43 hgbot Note Added: 0107710
2018-11-02 10:38 AugustoMauch Review Assigned To caristu => AugustoMauch
2018-11-02 10:38 AugustoMauch Note Added: 0107718
2018-11-02 10:38 AugustoMauch Status resolved => closed
2018-11-02 10:38 AugustoMauch Fixed in Version => 3.0PR18Q3.3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker