Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039530
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2018-10-24 13:092018-12-11 20:22
ReporterngarciaView Statuspublic 
Assigned Tomarkmm82 
PriorityurgentResolutionfixedFixed in Version3.0PR19Q1
StatusclosedFix in branchFixed in SCM revision0b6bb996e29d
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039530: No stock error for Orphan lines in Return to Vendor Shipment if it includes instance attributes

DescriptionNo stock error for Orphan lines in Return to Vendor Shipment if it includes instance attributes
Steps To ReproduceAs group admin role:
   Set RM Allow Orphan Line preference to Y
   Log out and log in

   Configure the Inventory Status of storage bins to allow negative stock (select a status with Overissue = 'Y')

   Create a new product
   Set Lot Attribute set to it
   Add a purchase price list it

   Create a Goods Receipt
   Add previously created product
   Set 1 in Attribute Set Value field
   Add a movement quantity and complete

   Create a Return to Vendor header
   Insert Orphan Line
   Select previously create product
   Add 1 in Attribute Set Value field (as the product with attribute set value cannot be selected in Product selector, it will be a new attribute set instance and there will not be stock of it)
   Book it
 
   Create a Return To Vendor Shipment header and select Pick/Edit Lines
   Select previously created line and you will get the following error:

      "There isn't enough available stock for RM order No: 1000002"
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0039469 newTriage Finance Orphan lines do not currently support instance attributes 

-  Notes
(0107678)
markmm82 (developer)
2018-10-30 18:32
edited on: 2018-11-02 16:07

Test Plan 1:
As group admin role:
   Set RM Allow Orphan Line preference to Y
   Log out and log in

   Configure the Inventory Status of some storage bins to allow negative stock (select a status with Overissue = 'Y').
     For instance select España Región Norte warehouse.
     Go to Storage Bin tab and select Rn-1-0-0 storage bin.
     Change the Inventory status by pressing the Change Status button.
       Select Undefined-Overissue Inventory Status. Done.

   Create a new product
   Set Lot Attribute set to it
   Add a purchase price list to it, for instance Tarifa Bebidas Alegres.

   Create a Goods Receipt for Bebidas Alegres bp.
   Add a new line with previously created product
   Set 1 in Attribute Set Value field
   Add a movement quantity and complete

   Create a Return to Vendor header for Bebidas Alegres bp.
   Insert Orphan Line
     Select previously create product
     Add 1 in Attribute Set Value field (as the product with attribute set value cannot be selected in Product selector, it will be a new attribute set instance and there will not be stock of it)
   Book it
 
   Create a Return To Vendor Shipment header for Bebidas Alegres bp and select Pick/Edit Lines
   Select previously created line and set as Ship Qty the movement quatity.
   Press Done and notice the process ends successfully and a new line is created.
   Complete the document and notice the process ends successfully.
   Go to the overissue bin and you will find in the Bin Contents tab a new entry with negative stock.

Test Plan 2:
As group admin role:

Go to Preference Window and create a new record with:
- Organization: *
- Property: RM Allow Orphan Line
- Value: Y
All fields from Visibility section empty

Log out and Log in again

Go to Product Window and create a new record with:
- Organization: F&B US
- Search Key: Test
- Name: Test
Move to Price Tab and create a new record with:
- Price List Version: Be Soft Drinker Price List
- Unit Price: 10
- List Price: 10

Go to Return to Vendor window and create a new record with:
- Organization: F&B US
- Business Partner: Be Soft Drinker
- Warehouse: US East Coast
Click on Insert Orphan Line Button and set:
- Product: Test
- Returned: 100
Click on Ok and Book the Document

Go to Warehouse And Storage Bins Window and select US East Coast Warehouse
Move to Storage Bin Tab and select EC-0-0-0 Bin
Click on Change Status button and select Undefined-OverIssue. Click ok
Now there is one Bin in the Warehouse that allows negative stock

Go to Return to Vendor Shipment Window and create a new record with:
- Organization: F&B US
- Business Partner: Be Soft Drinker
- Warehouse: US East Coast
Click on Pick/Edit Lines and select the line from the previous Return to Vendor Document.
Notice that the Storage Bin field has been filled with EC-0-0-0 Bin, since it is a Bin that allows to go to negative stock.

Enter any Ship Quantity, for instance 20. Press Done and Complete the RTVS.
Notice the process is completed successfully.

Go to the storage bin tab and notice that there is a new entry in the Bin Contents related to the RTVS. Select the line with the created product and notice it has a negative stock value.

(0107726)
markmm82 (developer)
2018-11-02 16:14

Updated wiki documentation with this change, added a note explaining how the P&E will work when the line hasn't stock but exists a storage bin with overissue inventory status:
http://wiki.openbravo.com/wiki/Return_to_Vendor_Shipment [^]
(0107783)
hgbot (developer)
2018-11-07 17:39

Repository: erp/devel/pi
Changeset: 0b6bb996e29dc13fb00d884912faa1499b427cab
Author: Mark <markmm82 <at> gmail.com>
Date: Fri Nov 02 12:54:48 2018 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/0b6bb996e29dc13fb00d884912faa1499b427cab [^]

Fixes issue 39530: No stock error for Orphan lines in Return to Vendor Shipment

By default the UI will show an error if there is no stock available and there
not exists at least one storage bin linked to an inventory status configured as
overissue = Y inside the Return To Vendor Shipment's Warehouse.

If there is no overissue bin inside the RTVS warehouse, then the No Stock error
is shown when the line is selected. Also when the RTVS line is inserted, the storage
bin is automatically filled with the overissue bin and when the RTVS is processed,
the stock goes to negative in that bin.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/return-material/ob-return-material.js
A modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/actionHandler/CheckExistsOverissueBinForRFCShipmentWH.java
---
(0107784)
Sandrahuguet (developer)
2018-11-07 17:40

Code review + testing OK
(0108454)
hudsonbot (developer)
2018-12-11 20:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/470e3cd384c5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-10-24 13:09 ngarcia New Issue
2018-10-24 13:09 ngarcia Assigned To => Triage Finance
2018-10-24 13:09 ngarcia Modules => Core
2018-10-24 13:09 ngarcia Triggers an Emergency Pack => No
2018-10-24 13:09 ngarcia Issue generated from 0039469
2018-10-24 13:09 ngarcia Relationship added related to 0039469
2018-10-24 13:10 ngarcia Issue Monitored: networkb
2018-10-24 16:27 martinsdan Issue Monitored: martinsdan
2018-10-25 12:12 dmiguelez Assigned To Triage Finance => markmm82
2018-10-25 20:42 markmm82 Status new => scheduled
2018-10-30 18:32 markmm82 Note Added: 0107678
2018-11-02 15:43 markmm82 Note Edited: 0107678 View Revisions
2018-11-02 16:07 markmm82 Note Edited: 0107678 View Revisions
2018-11-02 16:14 markmm82 Note Added: 0107726
2018-11-07 17:39 hgbot Checkin
2018-11-07 17:39 hgbot Note Added: 0107783
2018-11-07 17:39 hgbot Status scheduled => resolved
2018-11-07 17:39 hgbot Resolution open => fixed
2018-11-07 17:39 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/0b6bb996e29dc13fb00d884912faa1499b427cab [^]
2018-11-07 17:40 Sandrahuguet Review Assigned To => Sandrahuguet
2018-11-07 17:40 Sandrahuguet Note Added: 0107784
2018-11-07 17:40 Sandrahuguet Status resolved => closed
2018-11-07 17:40 Sandrahuguet Fixed in Version => 3.0PR19Q1
2018-12-11 20:22 hudsonbot Checkin
2018-12-11 20:22 hudsonbot Note Added: 0108454


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker