Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039448
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 03. Procurement managementmajorhave not tried2018-10-15 12:302018-12-11 20:22
ReporterplujanView Statuspublic 
Assigned Tomarkmm82 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q1
StatusclosedFix in branchFixed in SCM revisionab186b7fabcd
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionmainSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression level
Regression date2017-11-06
Regression introduced in release3.0PR18Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/01c6dc6168f6 [^]
Triggers an Emergency PackNo
Summary

0039448: [PR18Q4] "Create Lines From" on Goods Receipt not working properly when using Alternate UOM

DescriptionI've tried to create a partial receipt using the Create Lines From and when introducing the actual received quantity in AUoM the line is filled with the total quantity for the line.
Steps To ReproduceLogin As System Administrator
Go to Preference window and create a new preference:
Client = System
Organizatin = *
Property = Enable UOM Management
Value = Y
Visible at Client/Organization/User/Role/Window = all of them empty.

1. Login as QA Admin user
2. Create a Purchase Order header with the following data:
-Type: Purchase Order
-Business Partner: Vendor A
-Warehouse: Spain warehouse
-Payment method: 1 (Spain)

3. Create three lines:
-Line 1: 10 Quantity of "Raw Material A"
-Line 2: 10 Quantity of "Raw Material B"
-Line 3: 10 Quantity of "Raw Material C"

4. Book the Order

5. Create a new Goods Receipt header with the same date of the Order
6. Click the "Create Lines From" button to open the pop up
7. Complete all the related data. Mark the line for Raw Material A to full return and set Raw Material B to 8 (as shown in the screenshot)
8. Accept the changes and check the result. Note the line for Raw Material B was set to 10 instead (as shown in the second screenshot)
TagsNo tags attached.
Attached Filespng file icon AUOM_Error_1.png [^] (31,398 bytes) 2018-10-15 12:30


png file icon AUOM_Error_2.png [^] (37,886 bytes) 2018-10-15 12:30

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00394543.0PR18Q4 closedmarkmm82 [PR18Q4] "Create Lines From" on Goods Receipt not working properly when using Alternate UOM 
depends on backport 00394553.0PR18Q3.2 closedmarkmm82 [PR18Q4] "Create Lines From" on Goods Receipt not working properly when using Alternate UOM 
depends on backport 00394563.0PR18Q2.3 closedmarkmm82 [PR18Q4] "Create Lines From" on Goods Receipt not working properly when using Alternate UOM 
caused by defect 0037221 closedcollazoandy4 Cannot add a purchase order line to a goods receipt if both secondary UOM and alternate UOM are configured for the product 

-  Notes
(0107354)
hgbot (developer)
2018-10-17 08:48

Repository: erp/devel/pi
Changeset: ab186b7fabcd96fe988c40eef01b2c1424de167b
Author: Mark <markmm82 <at> gmail.com>
Date: Mon Oct 15 22:39:09 2018 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/ab186b7fabcd96fe988c40eef01b2c1424de167b [^]

Fixes issue 39448: "Create Lines From" on Goods Receipt not working properly
when using Alternate UOM

Was taking as the AUM Qty the original value from the line instead of the value
defned on the P&E, this way if the value is changed, for instance for partiall receipts
then the process will create a line with the selected quantity instead of the entire
quantity of the original line wich is creating from.

---
M src/org/openbravo/erpCommon/ad_actionButton/CreateFrom.java
---
(0107362)
Sandrahuguet (developer)
2018-10-17 09:28

Code review + testing OK
(0108431)
hudsonbot (developer)
2018-12-11 20:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/470e3cd384c5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-10-15 12:30 plujan New Issue
2018-10-15 12:30 plujan Assigned To => Triage Finance
2018-10-15 12:30 plujan File Added: AUOM_Error_1.png
2018-10-15 12:30 plujan Modules => Core
2018-10-15 12:30 plujan Triggers an Emergency Pack => No
2018-10-15 12:30 plujan File Added: AUOM_Error_2.png
2018-10-15 12:43 Sandrahuguet Assigned To Triage Finance => markmm82
2018-10-16 08:39 Sandrahuguet Regression date => 2017-11-06
2018-10-16 08:39 Sandrahuguet Regression introduced in release => 3.0PR18Q1
2018-10-16 08:39 Sandrahuguet Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/01c6dc6168f6 [^]
2018-10-16 08:40 Sandrahuguet Status new => scheduled
2018-10-16 09:20 martinsdan Issue Monitored: martinsdan
2018-10-16 09:50 Sandrahuguet Steps to Reproduce Updated View Revisions
2018-10-16 10:00 Sandrahuguet Relationship added caused by 0037221
2018-10-17 08:48 hgbot Checkin
2018-10-17 08:48 hgbot Note Added: 0107354
2018-10-17 08:48 hgbot Status scheduled => resolved
2018-10-17 08:48 hgbot Resolution open => fixed
2018-10-17 08:48 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ab186b7fabcd96fe988c40eef01b2c1424de167b [^]
2018-10-17 09:28 Sandrahuguet Review Assigned To => Sandrahuguet
2018-10-17 09:28 Sandrahuguet Note Added: 0107362
2018-10-17 09:28 Sandrahuguet Status resolved => closed
2018-10-17 09:28 Sandrahuguet Fixed in Version => 3.0PR19Q1
2018-12-11 20:22 hudsonbot Checkin
2018-12-11 20:22 hudsonbot Note Added: 0108431


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker