Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039418
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2018-10-08 09:512018-10-15 14:20
ReporteravicenteView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityhighResolutionfixedFixed in VersionRR19Q1
StatusclosedFix in branchFixed in SCM revision4e4d7ef93bd0
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039418: Inconsistent order status in webpos after a synchronization error

DescriptionInconsistent order status in webpos after a synchronization error. See video https://drive.google.com/file/d/1aC7SYFV22_PNcjMdhvdnLXr7fXbaZhw2/view [^]
Steps To ReproduceIn backend:
-In preference window, set preference WebPOS Synchronized Mode=Y

To force the synchronization error:
- Create a new warehouse with an storage bin deactivated.
- In organization window, give max priority to the previously created warehouse (min num means max priority).

To reproduce the issue:
- Log into webPOS, create a layaway. The synchronization error happens even select a different wh.
- Try to synchronized the layaway. Check that an error is displayed while synchronization due to wh without sb.
- Create a new ticket.
- Open Pay Open tickets and pay totally --> error is displayed again and the following inconsistencies appear:
-- Total amount of each ticket is 0.00.
-- Delete the payment and close pay open ticket. Check that one of the tickets has the total amount button disabled. When try to delete this ticket, an error message says that there is a linked payment.
TagsSER-QA
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0107234)
hgbot (developer)
2018-10-11 08:02

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 4e4d7ef93bd0dc92a5a14487c190fb059846725e
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Thu Oct 11 11:32:01 2018 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/4e4d7ef93bd0dc92a5a14487c190fb059846725e [^]

Fixed issue 39418 : Restore MultiOrder if any error occurs in Sync process

---
M web/org.openbravo.retail.posterminal/js/data/dataordersave.js
---
(0107255)
marvintm (developer)
2018-10-11 17:55

Most of the problem is fixed, but the first ticket still displays total amount "0" in Pay Open Tickets window, although when you go back to main window both are displayed correctly.
(0107303)
marvintm (developer)
2018-10-15 14:20

Finally the fix is correct, so I'm closing the issue.

- Issue History
Date Modified Username Field Change
2018-10-08 09:51 avicente New Issue
2018-10-08 09:51 avicente Assigned To => Retail
2018-10-08 09:51 avicente Triggers an Emergency Pack => No
2018-10-08 09:52 avicente Tag Attached: SER-QA
2018-10-08 11:40 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2018-10-08 11:40 ranjith_qualiantech_com Status new => scheduled
2018-10-11 08:02 hgbot Checkin
2018-10-11 08:02 hgbot Note Added: 0107234
2018-10-11 08:02 hgbot Status scheduled => resolved
2018-10-11 08:02 hgbot Resolution open => fixed
2018-10-11 08:02 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/4e4d7ef93bd0dc92a5a14487c190fb059846725e [^]
2018-10-11 17:55 marvintm Note Added: 0107255
2018-10-11 17:55 marvintm Status resolved => new
2018-10-11 17:55 marvintm Resolution fixed => open
2018-10-15 09:32 ranjith_qualiantech_com Status new => scheduled
2018-10-15 14:20 marvintm Note Added: 0107303
2018-10-15 14:20 marvintm Status scheduled => resolved
2018-10-15 14:20 marvintm Fixed in Version => RR19Q1
2018-10-15 14:20 marvintm Resolution open => fixed
2018-10-15 14:20 marvintm Review Assigned To => marvintm
2018-10-15 14:20 marvintm Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker