Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039349
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 02. Master data managementmajoralways2018-09-25 13:582019-05-21 15:17
Reportersamuel_nicuesaView Statuspublic 
Assigned ToAtulOpenbravo 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q3
StatusclosedFix in branchFixed in SCM revisioneac83131aa3f
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039349: Return from Customer pick/edit lines process takes more time to be loaded on an environment with thousands of orders.

DescriptionReturn from Customer pick/edit lines process takes more time to be loaded on an environment with thousands of orders.

This problem has been reported by one client that has a lot of records in this window.
Steps To Reproduce[BO]

Navigate to Return from customer window , select one record and click on Pick/Edit line.

If you have thousand of orders the process takes more time to finish.
TagsPerformance
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on feature request 0029943 closedalostale support to define DB functions volatility 
related to defect 0040865 closedAtulOpenbravo Set VOLATILITY LEVEL for Database functions 

-  Notes
(0107464)
markmm82 (developer)
2018-10-19 16:37
edited on: 2018-10-19 16:40

The main performance problem presented by the executed query is the number of calls made to the function: m_get_default_aum_for_document.
 
Since this function does not make modifications to the database, it can be changed to stable type [1] and with this change the query improves the performance and costs almost a minute to 5s.

At the moment, this property is not supported by the platform when the database is exported (export.database), so while temporarily solving the performance problem, the definition of the function can be modified directly in the client environment of the following way:

alter function m_get_default_aum_for_document (varchar, varchar) STABLE;

It is very important to keep in mind that any future update of the system will cause this change to be lost until this type of function is supported on the platform.

[1] https://www.postgresql.org/docs/9.5/static/sql-createfunction.html [^]

(0107497)
vmromanos (developer)
2018-10-22 17:10

This issue is blocked by a feature request.

Removed resolution time.
Patch has been sent to the customer. Once the FR is fixed, we will fix this issue too.
(0111582)
hgbot (developer)
2019-05-09 08:27

Repository: erp/devel/pi
Changeset: eac83131aa3f2e7a2d1682cb421ac848cf85e4f0
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Mon May 06 14:08:39 2019 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/eac83131aa3f2e7a2d1682cb421ac848cf85e4f0 [^]

Fixes Issue 0039349: Return from Customer pick/edit lines process
takes more time to be loaded on an environment with thousands of
orders.

** Modified volatility level of db function
M_GET_DEFAULT_AUM_FOR_DOCUMENT as STABLE

---
M src-db/database/model/functions/M_GET_DEFAULT_AUM_FOR_DOCUMENT.xml
---
(0111583)
Sandrahuguet (developer)
2019-05-09 08:44

code review + testing ok
(0112023)
hudsonbot (developer)
2019-05-21 15:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9b8f37d9d85e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-09-25 13:58 samuel_nicuesa New Issue
2018-09-25 13:58 samuel_nicuesa Assigned To => Triage Finance
2018-09-25 13:58 samuel_nicuesa Modules => Core
2018-09-25 13:58 samuel_nicuesa Triggers an Emergency Pack => No
2018-09-25 17:34 Sandrahuguet Tag Attached: Performance
2018-09-27 12:46 Sandrahuguet Assigned To Triage Finance => markmm82
2018-10-02 17:01 markmm82 Status new => scheduled
2018-10-19 08:09 vmromanos Relationship added depends on 0029943
2018-10-19 16:37 markmm82 Note Added: 0107464
2018-10-19 16:40 markmm82 Note Edited: 0107464 View Revisions
2018-10-22 17:10 vmromanos Note Added: 0107497
2018-10-31 17:28 vmromanos Assigned To markmm82 => Triage Finance
2018-10-31 17:28 vmromanos Status scheduled => acknowledged
2019-05-06 10:43 AtulOpenbravo Assigned To Triage Finance => AtulOpenbravo
2019-05-06 10:43 AtulOpenbravo Status acknowledged => scheduled
2019-05-09 08:27 hgbot Checkin
2019-05-09 08:27 hgbot Note Added: 0111582
2019-05-09 08:27 hgbot Status scheduled => resolved
2019-05-09 08:27 hgbot Resolution open => fixed
2019-05-09 08:27 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/eac83131aa3f2e7a2d1682cb421ac848cf85e4f0 [^]
2019-05-09 08:44 Sandrahuguet Review Assigned To => Sandrahuguet
2019-05-09 08:44 Sandrahuguet Note Added: 0111583
2019-05-09 08:44 Sandrahuguet Status resolved => closed
2019-05-09 08:44 Sandrahuguet Fixed in Version => 3.0PR19Q3
2019-05-13 18:16 AtulOpenbravo Relationship added related to 0040865
2019-05-21 15:17 hudsonbot Checkin
2019-05-21 15:17 hudsonbot Note Added: 0112023


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker